Rewind on file via smb causes playback to stop/hang

Playing an mkv via smb. All good, until I press Rewind. When I click resume, it says buffering and nothing happens. Have to click stop to resume playing.
Forwarding is fine.

Need logs :slight_smile:

How do I do that @sam_nazarko ? I’ve had a look at the Wiki, isn’t documented there.

Of course it is…

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

1 Like

Are you actually using rewind or step backs? Honestly, this is pretty much as the system is designed. It doesn’t make much sense to continue caching a ton of data that has already been viewed. That would simply be occupying cache space that would be much more useful to ensure smooth streaming as you are watching. It’s not reasonable to expect that an entire file should be cached on such low power/low resource devices. The rare occasions that someone does need to rewind, living with a little buffering should be reasonable.

I think you’re missing the point. Rewind isn’t working. When you rewind, the interface freezes and you have to start over. I have this problem too over NFS. Fast-forward works fine. I’ll also try to work on getting some logs as well.

Is this on a Vero 4K?
Have you tried copying the file locally?

I notice on other devices if I try and seek far back or far forward, the video may stop. This is due to aggresive seeking and you’ll find it on all platforms. And also, without stating the obvious, sometimes you seek further than the lenth of the video, so Kodi will stop playback.

I asked for debug logs so I could check anything was out of the ordinary.

  1. Yes, this is a 4k
  2. I haven’t yet. I’ll try that with a smaller file and see what happens.

The log is here: http://paste.osmc.io/uhutujayin

I skipped forward several chapters to around 00:09:30, then did rewind until the time was 00:09:20. Upon hitting play, it never resumed playing.

If I play a file from the network using WiFi and try and skip really fast using skip steps, I sometimes experience the same. But I seek to a specific point (click to seek now possible in the skin), I do not. Local playback seems unaffected for me.

My Vero4K is connected via ethernet. It seems to transfer at about 11MB/s (megaBYTEs) if I copy a file from NFS to /dev/null. Interestingly, it is only negotiated at 1000-HD… but that’s an issue for some other time.

I just tried using rewind on local storage (internal and external SD). I’m using a ~1GB MP4 (different video from the one in my previous log). I watched about 1.5 minutes into the movie, then tried to rewind 5-10 seconds and get the same behavior.

New log: http://paste.osmc.io/ofovediyem

1 Like

That’s almost 100Mbps which is the maximum speed for the Ethernet PHY.

Okay – I’ll try and get a chance to look at this soon. Are you able to replicate this with any clip, or only specific ones? It would be good if we could find a common clip then I can work on improving the situation and it will be easy for you to compare.

Can you replicate the problem with 1080p Big Buck Bunny?

Does

At the moment, I can’t recall ever being able to rewind (even with my previous Vero 2), but it isn’t something I do very often so this isn’t a scientific statement.

I agree on replicating the issue with a common video. For some reason that link you posted wouldn’t load, but it seems like this is the same video from a different mirror:
https://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_1080p_surround.avi

I’m downloading that right now and will report back later. It seems like the source is throttling me, so it will take a little while to download.

Just wanted to confirm that the bunny movie exhibits the same issue. Interestingly, the interface still works as if the movie was playing (the time continues to count and the animated progress bar continues moving to the right), just no audio and the video is frozen. This is while playing the movie from the home directory on local storage.

Any update on this?

I’ve tried replicating this locally.

On very high bitrate content if I seek forward or back it hangs for one or two seconds, then playback resumes. Is this the issue you have, or does the playback completely halt?

I’ve tried playback via sshfs and off the eMMC

No, it just hangs after I rewind. I have to stop playback, and resume. I just can’t rewind.

Can you also post a debug log?
Struggling to reproduce this with Big Buck Bunny

Sam

I’m seeing the same exact behavior with files saved onto a local SD card.

Are you using passthrough?
Was the video passing through audio as PCM? Debug log will be very helpful

We can fix this quite easily, but not in the April update as that window is closed. I’ll let you know when I have something to test

Sam

Yes, using audio passthrough. I’ll review the instructions for generating a log.