Rewind on file via smb causes playback to stop/hang

Yeah, I’m still seeing this behavior with ANY media source: addon, local, smb, nas, etc. Do any kind of rewind and the player hangs.


Stepping (pressing left / right) works fine :slight_smile:

1 Like

Yes – it’s not the best solution for now, but it works.


Just my 2 cents worth. Rewind freezes with me also but can FF fine, at all multiplier settings.
Skip works fine both ways. Good to see a fix is being worked on.

I noticed that even though the picture has frozen and nothing will get it to unfreeze, if you bring up the status bar at the bottom, it shows the time position in the movie counting backwards. Say I try to rewind at 30 minutes into a movie, which freezes the picture. The time shows moving backwards and I press stop at 20 minutes. When I go to start the movie again, I get the choice of starting at the beginning or where I left off. The ‘where I left off’, shows 20 minutes, not the 30 where it froze. Hope that snippet of info is of some use to you sam_nazarko

Happy to see that this is being worked on, I also have the issue that if i want to rewind few minutes or seconds back or forward the player will hang ( file played directly from local Drive).

However going from chapter to chapter in files that have those works without any issues.

Just installed the July update. Rewind still freezes so a fix may not be in this update? Perhaps next update?

I didn’t announce a fix for this issue in this update because there isn’t one at this time unfortunately.

I don’t have a solution for this – at least not at this time. It seems to be an issue with Kodi’s VideoPlayer + AML implementation (so affects all devices)

For now, just skip as suggested above.

If a solution is found, I will update this thread.

Seems like the issue is fixed here.

Unfortunately it is not fixed for me just yet. Skipping is ok, seeing backwards still hangs the playback.

Indeed. I think we won’t see a fix until Kodi v18 unfortunately due to limitations of the current VideoPlayer architecture.

I’d be interested in knowing if the issue is resolved in Kodi v18.

I’ll happily try the Kodi 18 beta release if you can explain how to install it.

Make a backup (as only way back is a reinstall) and check this thread.

I’ve upgraded to version 17.8-094 using the instructions, is this Kodi 18?

The behaviour is now a little different. Skipping back still works. Seeking backwards counts down the timer (same with Kodi 17) but pressing play now restart the playing from the point the seeking started. Like no seeking was done. For example at 0:20:00 you seek backwards to 0:19:30 and press play. The movie resumes at 20:00. With Kodi 17 pressing play after the seeking would just hang the playback.

Hi @RichieB

Thanks for living on the dangerous side and trying out Kodi v18.

It’s a very early test build, but yes. Our test builds track master, which will end up Kodi v18 eventually.

Things will be a bit topsy-turvy in these stages. Thanks for the details.

has this issue been fixed? I am still experiencing the same thing when I try to rewind on some movies

Kodi 18 not even beta yet. No release ETA.

Not even beta yet.

I’m seeing the same behavior on my Vero 4K. Interestingly, I copied the .kodi directory from a working RPi3 to this Vero4K. The behavior was NOT experience withhp the RPi3 but is experienced with the Vero4K. To summarize, the playback settings are the same between my working RPi3 and the Vero4K, however the Vero4K is experiencing the documented freeze issues during rewind but not the RPi3. If this info helps anyone I’d be happy to generate and share logs for both devices.

If you read the previous 10-15 posts here, you’ll see there is no definitive fix yet.

Thanks. Yeah, I noticed there’s no solution as of yet. If anyone is, or might be in the future, working on a solution, I can generate logs for a Vero4K that is exhibiting the behavior and a nearly identical RPi3 that does not exphibit the behavior. I’m not savvy enough to offer much technical assistance but perhaps there might be something of use in those two datasets?