Rollback latest Kodi update? Another bootloop

Hi all,

I have OSMC installed on a RPi3 and the wife is telling me yesterday it auto updated itself. Unfortunately, it boots into the HDHR PVR interface and then goes into a bootloop after being online (in terms of GUI) for around 3 seconds.

I’ve tried an fsck on the partition and it says I need to use data from a superblock, none of which work.

Is there a way I can rollback this latest update? If not, how can I manually remove the settings , repo sources, list of addons, etc?

It’s not possible that the update happened without someone selecting OK. It will prompt and give you the option.

Are you trying to say that you see a sad face over and over again? Or is it really rebooting?

Can you SSH in to the Pi still? If so, try running

sudo touch /forcefsck
sudo reboot

Thanks for the reply.

It boots into the default window (which in this case is the PVR and starts updating channels). After about 3 seconds, it shows the sad face and reboots.

I could SSH into it, but it won’t be online long enough for me to do anything.

It is so frustrating having to wipe your entire config every 6 months and never even getting to solve why it happened. I’m sure I’ll be in this situation again in a few months

No – this doesn’t sound right.
This can happen with major Kodi upgrades. The last one was just over two years ago.

If you log in via SSH and upload logs, we can probably pinpoint the issue so you only need to remove a single add-on or change skin etc.


Thanks but SSH’ing into it will be impossible when I’d have around 7 seconds to get what I need before it reboots. Can I get the log manually off the card?

Also, it went into a bootloop during the last update around 2 or 3 months ago (admittedly I’d not updated it in a long time for this exact reason)

If you had the same problem before, I’d suggest it’s time for a new SD card.

But are you sure it rebooting? Have you actually tried SSHing in?


the bootloop is just Kodi restarting the pi doesn’t actually restart.

Once we’ve got you back running again, better make sure you have backups. SD cards can fail any time.

If you can ssh in, then go

sudo systemctl stop mediacenter
grab-logs -A

post the url you see here, then

mv ~/.kodi ~/kodi.bak
sudo systemctl start mediacenter

If that works, then we are probably looking for an add-on that’s not compatible with Leia.

1 Like

After starting another install, I think I’ve worked out what it is. I’ve come across another bootloop after installing the HDHR

It boots, Kodi interface comes up, top right shows PVR channel scan and within around 1.5 seconds it crashes. How do I manually remove this script or startup procedure?

Edit: went into /home/, checked show hidden folders, then deleted any PVR folders and it seems to be working. Obviously I’ve lost the PVR for now, but it does boot and doesn’t bootloop.

PVR add-ones are already included in OSMC

Hope you don’t mind me piggybacking off the thread. I’m also stuck in a bootloop, although I don’t even get the screen to load up at all.

My thoughts were it’s probably time to replace the SD card. I have a new one here, can I just copy everything across?

I can actually SSH into the box even though OSMC is sad face/blue screening. Is there anything I can run from there to take a full backup of my media library etc as I don’t want to lose the watched/not watched information?

I stopped mediacenter as suggested and did grab-logs -A, logs are here

You are not in a ‘boot loop’. That is Kodi (not OSMC) restarting.

OSMC is the linux distribution you are using. Kodi is the media player.

You could post logs here since you can ssh in still:

grab-logs -A

and share the URL.

Beat me to it as I was editing my post! Yes indeed, it is just Kodi in a loop.

2019-06-10 20:52:53.149 T:2979378384  NOTICE: start dvd mediatype detection

I don’t recall seeing that error before. But you did not do a full debug log so It’s hard to tell. You could try with a fresh kodi setup:

sudo systemctl stop mediacenter
mv ~osmc/.kodi ~osmc/
sudo systemctl start mediacenter

and start from there. You can copy files back from the saved configuration until you find the problem. (always stop mediacenter before trying this)

Just ran all 3 commands, still stuck in the Kodi blue sad face loop.

New logs please, but if kodi will not start with a fresh .kodi directory that’s odd.

Are these the files I’ll need to copy down off the SD card to make sure I don’t lose my media library etc. ?


OK, will cut some new logs.

If you are going to re-install, save the complete .kodi directory. But if you try that I’d suggest a new SD card as your problem could be a failing card and a reinstall will only mask the problem.

New logs

Do you have a DVD drive connected? If you do try disconnecting. it.