RPi 2 random stutter over LAN

Hey guys,

First of all, great work. Love it. Thank you.

I have been experiencing problems with OSMC on my Pi2 for a couple months now. Not sure when it started exactly.

The issue is that I read movies off of a Nas that works fine.
When reading from my Mac it’s fine. From the Pi (connected via Ethernet), whatever video size 480p, 720p or 1080p I get video freezes or stutters during playback. Audio is fine, but the video freezes for a second or 2 then playback continues.

I would argue the freezes are longer on bigger video sizes but am not 100% sure.

Any ideas or hints as to how to investigate this ?

Thx

teu

1 Like

Yes, provide debug enabled logs…

Hey ActionA, would you mind giving me indications on how to enable the logs, and which logs I would need to send ?
Thanks

Please check the “Providing diagnostic logs” at http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

I’ve done what you asked, and set the logs up.

=> http://paste.osmc.io/opatezugov

I activated the logging and launched an episode as I usually do.
Episode is small, around 250Mb, which is really small in terms of bandwith.

Insight would be great.

Cheers

Does enabling omxplayer in video/acceleration settings avoid the issue?
I assume you have “adjust refresh to match video” and “sync playback to display” enabled?

1 Like

Hey ActionA,

Hardware acceleration for OMXPlayer was enabled.

Sync playback to display was checked.
Adjust display refresh rate was off. Have turned it to Always, and will give it a try.

Note: My raspberryPI is connected to my TV though a Samsung soundbar, so I wonder if the Sync playback refresh rate thing can actually work.

Will investigate by trying the following:
Test 1: Try with Sync playback turned off, cause maybe the soundbar is the one creating problems ?
Test 2: Activate Sync playback and Adjust display refresh to always.

Will update with result ASAP.

Result of test 1: fail. Still get the freezes.

Cheers

Does this occur for ALL files? Or just some?

I only use OSMC for video files that are all stored on my NAS.
This happens on all types of files.

Usually they are .mp4 files, in the 200’ish sizes, however they can also be in .mkv 720p (and sometimes 1080p), of much larger sizes, 700ish megs, even 4gb sometimes.

Am running different tests, but since the freezes are quite random, it’s difficult to predict.

Is the Pi directly connected to the router? Is the Nas directly connected? Does the NAS support NFS? This is almost certainly an issue with your network or NAS rather than OSMC and the Pi if you are wired.

Both NAS and Pi are wired to the router.

To be honest, I can’t know the time for sure, but give it at least a good 6 months ago, it was fine. Never a freeze.

Only changes that have occurred since are:

  • 1 - the soundbar (but can’t say for sure the freezes were occurring before the soundbar)
  • 2 - a different TV
  • 3 - updates to OSMC (always up to date)

I will investigate more, by trying different settings.

For one, I see, that the resolution for the TV was incorrectly set to “Desktop”, have now set it to 1920x1080.

I am done for the night, unfortunately, but will monitor on next watch, will update the thread with my findings.

I will also, try the NFS access to the NAS. For now, I’m using smb.

Cheers

Can you copy a problematic file to the Pi (either sdcard or directly attached USB stick).
Does that have the stutter? If it does it’s a file encoding/player issue. If not it’s a network issue.

1 Like

I think I have the same problem, or nearly the same. Had OSMC for about 6 months and just recently it started to freeze/stutter for 2-3 seconds.
Always used wifi but will try Wired just to be sure.

Anyways, Cheers!

Update of the day.

I watched a whole movie (big file, around 4Gb), with no freeze. None !
First success I would say :slight_smile:

I turned off Adjust and Sync. And was running from NFS.

Now, maybe NFS is better over samba, however i’ve always been using samba, so has there been any samba changes, somewhere around 6 months ago that could explain this ?

Cheers

i want to ask some… what codec use this file ? Xvid ? x264 ? or ? You can give some mediainfo ?
I have notify the x264 if the profile it’s higher of “HIGH@L3.1” i obtain some struttering image on my Pi2 whereas with mail@l3.0 or lower profile i never obtained problems and usually i use samba (PC-Windows <-> Pi2 by LAN and 2 routers) and all file it’s about 2GB of size.

Every 2 or 3 days… i also can suggest to you to reset your routers. i thinks this can help you to resolve some problems…

For example, I recently obtain the same exact problems only whit a specific XVID files:
Video continue to struttering and it’s unwatchable… i compare the mediainfo of this whit all my other xvid file and apparently all it’s ok (no packed bitstream or similar).

I mostly got high profile x264 mkv’s … they all run without problems, even high bitrate bluray rips run without a problem.
But indeed … i’m interested in the mediainfo of his files as well :wink:

If you need to reset your network equipment, you need to buy better stuff … i’ve had one time a problem, related to a router and replacing that one solved all the problems it caused.

I don’t really need to reset but but I do it anyway… tipically every one or two week. :slightly_smiling:

Ok… check the mediainfo of this mkv… before to buy this my Pi2 i have a WD standalone players and the x264 whit profile High@L4.x not working (and it’s also indicated in the manual) for a hardware limitation.

Now on Pi2 sometime i have found some x264 whit Main@L4.0 and it’s working… i never found a file whit an higher profile over “the world of internet” :wink:

Running silky smooth, cpu not even above 10% usage …

[code]General
Unique ID : 251373940480041184065839076800297602043 (0xBD1CDC23C6E4C94787EFC063C9668BFB)
Complete name : blablabla.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 10.9 GiB
Duration : 2h 21mn
Overall bit rate : 11.0 Mbps
Encoded date : UTC 2015-12-29 20:19:25
Writing application : mkvmerge v8.5.2 (‘DiAMOND’) 64bit
Writing library : libebml v1.3.3 + libmatroska v1.4.4

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 2h 21mn
Bit rate : 9 543 Kbps
Width : 1 920 pixels
Height : 800 pixels
Display aspect ratio : 2.40:1
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.259
Stream size : 9.21 GiB (84%)
Writing library : x264 core 148 r2638 7599210
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=24 / lookahead_threads=4 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=2pass / mbtree=1 / bitrate=9543 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Language : English
Default : Yes
Forced : No

Audio
ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Mode : 16
Format settings, Endianness : Big
Codec ID : A_DTS
Duration : 2h 21mn
Bit rate mode : Constant
Bit rate : 1 509 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 24 bits
Compression mode : Lossy
Stream size : 1.49 GiB (14%)
Language : English
Default : Yes
Forced : No

Text #1
ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Default : Yes
Forced : Yes

Text #2
ID : 4
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Default : No
Forced : No

Text #3
ID : 5
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Title : sdh
Default : No
Forced : No

Menu
00:00:00.000 : en:00:00:00.000
00:03:22.285 : en:00:03:22.285
00:10:08.983 : en:00:10:08.983
00:15:24.590 : en:00:15:24.590
00:18:25.187 : en:00:18:25.187
00:21:34.376 : en:00:21:34.376
00:24:28.092 : en:00:24:28.092
00:28:52.689 : en:00:28:52.689
00:31:36.645 : en:00:31:36.645
00:34:21.101 : en:00:34:21.101
00:39:13.434 : en:00:39:13.434
00:41:21.771 : en:00:41:21.771
00:46:23.531 : en:00:46:23.531
00:49:25.087 : en:00:49:25.087
00:56:15.747 : en:00:56:15.747
00:59:40.494 : en:00:59:40.494
01:02:23.823 : en:01:02:23.823
01:06:53.134 : en:01:06:53.134
01:09:52.980 : en:01:09:52.980
01:13:51.302 : en:01:13:51.302
01:18:38.255 : en:01:18:38.255
01:22:52.467 : en:01:22:52.467
01:30:41.269 : en:01:30:41.269
01:37:30.094 : en:01:37:30.094
01:43:31.997 : en:01:43:31.997
01:46:16.287 : en:01:46:16.287
01:50:18.737 : en:01:50:18.737
01:54:07.966 : en:01:54:07.966
01:57:49.312 : en:01:57:49.312
02:04:41.683 : en:02:04:41.683
02:11:05.733 : en:02:11:05.733
02:13:28.792 : en:02:13:28.792[/code]

Exactly… on my previous WD Standalone this file would not be reproducible.

I never tryed this profile on my Pi2… when i need to encode some file myself i ever used the HIGH@L3.1 (many many user this profile) and i thinks it’s best choice for maintain the best compatibility also on “old” hardware standalone players…

OT
Otherwise… WOOOOW 10.000 for average bitrate… lol all file i ever watched on my Pi2 use bitrate loss to 2000 :slight_smile: and size lower than 2GB :slight_smile:

Believe me … your RPi 2 can handle almost everything :wink: