Rpi Krypton builds missing My OSMC Program Add On

Might just be me but I am testing Krypton builds on a Rpi 3 and the My OSMC by KodiKarnage add on is missing so cannot re-configure OSMC settings.

Is this expected?

Cheers
Spart

Think this was covered in the v17 thread.

It’s not expected.

Usual logs will help

Sam

OK thanks Sam.

Cheers
Spart

Did you look under Program addons?

Indeed – where is it missing from?

From Program add-ons!!!

It was there before enabling and installing Krypton builds.

Cheers
Spart

So do you mean the shortcut isn’t in the Estuary add-on?

Correct. It has disappeared. However I have found it in My Addons - Program Addons but it is disabled.

I remembered from teh last round of testing that it was disabled/ But enabling it resulted in a Sad Face boot loop. Must have been disabled by the install process for Krypton. Not sure I want to enable it without a way to disable it!. Must have been disabled for a reason.

Is there a way to disable an enabled add on from the command line? To get out of the boot loop.

Cheers
Spart

You can likely disable it via SQLite addon DB

We haven’t patched estuary to add our icon yet, so not finding it on the home screen is expected

Sam

It’s missing from the Program Addons!

Cheers
Spart

Exactly what configurations do you need it for? Everything can be manually config’d without the addon quite easily.

Need to change DNS server and gateway information.

Cheers
Spart

Use connmanctl directly in CLI then.

Can you take a screenshot?

I thought you just found it in programs

We normally make it visible in Confluence with a simple patch. I plan to do the same with Estuary

Really need a log to see what’s going on though. Seems fine for other users

How is Pi 1 progress going?

Estuary Program Addons:


Estuary Addon Browser - My Addons - Program Addons

Seems to have been disabled by installing Krypton builds.

Rpi 1 is doing good so far. No freezing yet. Will keep testing.

Cheers
Spart

“My OSMC” runs for me (using a fresh install of osmc from the raspberry pi site followed by an update to 16.8-154 as described here: http://forum.kodi.tv/showthread.php?tid=265306 ). Using the Estuary skin.

The first time I ran it the mouse pointer was corrupted and all there on the screen was “OSMC” in the the upper left and a rotating osmc logo in the center which responds to mouse over and exits when clicked. No other functionality seems to be working/present but I guess thats slightly different than not running at. After a reboot, the mouse pointer was restored but it still functions as described above.

Is there a way to configure (discover and connect) bluetooth devices from the cli? Enabling was pretty straight forward.

Thanks

Thanks! Though, I don’t see any obvious means by which to enable “parts of MyOSMC”.

Did you continue reading the thread? It’s all there.

I spoke to Milhouse about this in Slack today. This commit should address the issue and will be available in my Krypton builds when I release them:

CC @gmc, you should pick this. Needs some testing anyway.