Rpi2 - it's again a good hardware at today ? Issue after November Update

Yesterday i have update my OSMC setup to the recent “November Update” whit kodi 19.3 new kernel and other fix.

I have reboot my Rpi2… last night I used it as usual and i obtain a lot of trouble.
I can make a general summary:

  • The Skin and navigation menù it’s very smooth (i use Estuary as skin).
  • I have tryed to watch some youtube video by current and update addons (currently 6.8.18). In some cases i can see a weird issue… the tv screen goes completely black usually after about 5 seconds of playback started and it’s all back normally immediatelly after about 1 second.
    Another weirds issue… during the video reproduction if i open the GUI (by press OK on my tv remote for example or open the infobar) the playback start to stuttering. On previously build (August update) I had never noticed anything like it. I have also noticed another weirds… if i open the “PlayerDebug” information during a playback i can see a lot of frames skipped. For example for a youtube video whit about 5 minutes duration the skip frames reach value like 500 or 600 (and problably there’s the nature of struttering cited uphere).

Previously i have made capped the resolution for DASH… i have capped the resolution to 720p@60 because apparently the Rpi2 provides various problems with videos at 1080p@60 maybe because hardware it’s not to much capable to support it.

At this point the question it’s:
It’s Rpi2 it’s a good hardware at today ?
It’s the Rpi2 current build completely tested ?
It’s this weirds trouble just one problem of mine that you can’t reproduce ?

Thats a delayed refresh rate switch that seems to happen with the youtube addon. If you disable adjust refresh rate that should go away.

I don’t think anyone in the development team still has a Pi2 so the answer is maybe (as it should behave similar as the Pi3)

“adjust frame rate” setting… ok. where is this setting? in the addons settings or in the main settings of kodi ?

About Rpi2 vs Rpi3 here i have found a valid compare:

Obviously the Rpi3 have a “better” hardware and the benchmark on this compare speak clearly…

Let’s see in the next few days…pity that now is not the right time to do a possible hardware upgrade :slight_smile:

Settings>Player>Videos>Adjust display refresh rate> Off

I have also a problem since the update on my pi 2 yesterday.
I used to watch h264 movies without any problem but since the update I can’t watch anything, the sound is good but the video is very very slow like the CPU isn’t able to process it, like 3 or 4 fps.

It would help to provide logs in a separate version as well as information about which version you upgraded from.

The system was updated from the lastest build from August.
I followed the instruction to get logs but it doesn’t work to have an URL from OSMC and I can’t access to the paste.osmc.io to send it, something is wrong with this website.
Another way to send logs ?

Have you checked Settings->Player->Allow hardware acceleration?

1 Like

Seeing this post explains a lot. My RPI2 was working fine yesterday but I’ve been seeing stuttering issues all day today when watching MKVs. I’ve just found out that someone else in the house updated OSMC yesterday evening.

Yes hardware acceleration was already enabled.
I found the address of the pastebin (the link in the instructions is wrong).
So here the log, I launched 2 videos and it was syncing and buffering several times.

I tried a fresh new install on another SD card with the november update to be sure and it does the same thing, so it’s not all the other stuffs I installed that slow down the system.

Stuttering issue here as well. Rpi 2, November update.

Same issue here with a rpi3. Only use it for live tv and it’s shuttering a lot.

For those with stuttering issues:

No idea why someone thought it would be a good idea to disable non-HEVC acceleration by default.


Yes thank you, I didn’t notice this option, I disabled it and it works fine again.

So… who had the brilliant idea of enabling this setting by default? :sweat_smile:

I actually saw that setting yesterday before posting here, but thought this is probably just a bad UI text since this enabled by default wouldn’t make sense right?!

I’ve removed the option completely.

Thanks for that. All working again now :slight_smile:

OMG… I have back here right now because i want to post my addictional feedback :slight_smile:
About some minutes ago from an addons i have found a streaming of a TV Show at 1080p@60Fps.
For this same show i can also choose 720@60Fps and i have saved to my “Favorites” to maded some test.
Because this same shot at 720p it’s will watchable whitout any issue… at 1080p struttering and all it’s become unwatchable.

At this point i have start to check some setting in same section of kodi suggested by @fzinken … here:

Here i have try to change… from “Direct to Plan” to “EGL”… no works. OSMC made in crash immediatelly when i try to start to watch any video (also from another addons).
At reboot i have re-set this setting to “Direct To Plan”.

After that i have try to look the description how all other setting… and i have try to enable and disable the Hardware accellation but apparently nothings changed.

Immediatelly after that i have made the modification already descripted here by @redballons99 :slight_smile:
I have disable the “only allow accelleration for HEVC” and… BAAAAAM

The same TV Show it’s works FLAWLESSY at 1080p@60fps!!!

I’m back here to write this and i have found all this reply whit same solution…

At this point i have some question about this settings… this settings can be create some damaged my rpi2 hardware ? My case it’s not have fan… it’s can be create somethigs like overheating for example with a long view or similar ?

No, that option doesn’t cause any damage as it actually reduces the load from the CPU

Just a FYI, all the RPi’s monitor the CPU temperature and with stock settings will slow themselves down if they get too hot.