Rpi2 - it's again a good hardware at today ? Issue after November Update

Seeing this post explains a lot. My RPI2 was working fine yesterday but I’ve been seeing stuttering issues all day today when watching MKVs. I’ve just found out that someone else in the house updated OSMC yesterday evening.

Yes hardware acceleration was already enabled.
I found the address of the pastebin (the link in the instructions is wrong).
So here the log, I launched 2 videos and it was syncing and buffering several times.

I tried a fresh new install on another SD card with the november update to be sure and it does the same thing, so it’s not all the other stuffs I installed that slow down the system.

Stuttering issue here as well. Rpi 2, November update.

Same issue here with a rpi3. Only use it for live tv and it’s shuttering a lot.

For those with stuttering issues:

No idea why someone thought it would be a good idea to disable non-HEVC acceleration by default.


Yes thank you, I didn’t notice this option, I disabled it and it works fine again.

So… who had the brilliant idea of enabling this setting by default? :sweat_smile:

I actually saw that setting yesterday before posting here, but thought this is probably just a bad UI text since this enabled by default wouldn’t make sense right?!

I’ve removed the option completely.

Thanks for that. All working again now :slight_smile:

OMG… I have back here right now because i want to post my addictional feedback :slight_smile:
About some minutes ago from an addons i have found a streaming of a TV Show at 1080p@60Fps.
For this same show i can also choose 720@60Fps and i have saved to my “Favorites” to maded some test.
Because this same shot at 720p it’s will watchable whitout any issue… at 1080p struttering and all it’s become unwatchable.

At this point i have start to check some setting in same section of kodi suggested by @fzinken … here:

Here i have try to change… from “Direct to Plan” to “EGL”… no works. OSMC made in crash immediatelly when i try to start to watch any video (also from another addons).
At reboot i have re-set this setting to “Direct To Plan”.

After that i have try to look the description how all other setting… and i have try to enable and disable the Hardware accellation but apparently nothings changed.

Immediatelly after that i have made the modification already descripted here by @redballons99 :slight_smile:
I have disable the “only allow accelleration for HEVC” and… BAAAAAM

The same TV Show it’s works FLAWLESSY at 1080p@60fps!!!

I’m back here to write this and i have found all this reply whit same solution…

At this point i have some question about this settings… this settings can be create some damaged my rpi2 hardware ? My case it’s not have fan… it’s can be create somethigs like overheating for example with a long view or similar ?

No, that option doesn’t cause any damage as it actually reduces the load from the CPU

Just a FYI, all the RPi’s monitor the CPU temperature and with stock settings will slow themselves down if they get too hot.

Thanks for all the support on here. I had a problem with HD recordings in the UK. I disabled the HEVC acceleration and my HD recordings now play fine.

However the SD recordings from UK channels play squashed into 4:3 format. If I change the setting for 3:4 recordings to be stretched to 16:9 then those work OK.

The only problem I have now is that 4:3 recordings (the Snowman - it’s coming up to Xmas and the grandkids will enjoy it) it comes out stretched.

If you’re feeling brave, you could try enabling the whitelist. (Not certain that will help, but it might).

I wrote a guide about it: [HowTo] Guide to the Kodi whitelist function and related settings

Thanks - I had previously found your guide and found it very useful - good job - so I tried it.

In the bottom left corner of the screen when I have a particular item highlighted it says Mpeg2 and 576.

In whitelisting I can find 720x576p and that is what I’ve whitelisted, but it makes no difference.

Am I doing something wrong?

I may have been a bit premature here. I’ll follow your guide again.

There are a few other settings you need beside the whitelist itself - see my guide for details. I’m not promising this will help, mind you, but it might. :slight_smile:


I am unable to find the option “only allow accelleration for HEVC” the novmber OSMC release I am running on a rp3b.

Some videos are stocking in scenes with a lot of moving small details, for example large rain drops.
Can anyone send a screenshot?



This option was removed from the release and no longer needs to be configured.

You won’t get HEVC acceleration on a Raspberry Pi 3 anymore with Kodi v19 unfortunately.

That is a clear answer, thanks a lot. So, if current OSMC Kodi 19.3 is stocking, I should stay with Kodi 18. :frowning: