RPi2 + OSMC is always active source

hey guys, long time user but first time posting.

In the last few weeks or so I’ve been noticing some issues involing CEC /switch inputs between my Pi2 and other inputs. Note: my Pi2, Chromecast, and Cable box are all hooked up to a receiver, and then one HDMI to the TV. I use the Panasonic TV remote via CEC to control my Pi2 (currently running latest OSMC version).

Right now my problem is that if I’m on the Pi2 input, and I switch to my cable box, after 2-4 seconds the receiver input changes right back to the Pi2. I can repeat this over and over. I did a little test today and found something weird:

  1. I’m on the Pi2 input, and I then reset the Pi. Once the Pi + OSMC has fully loaded, i touch nothing, and switch to cable box input. It works great! The receiver will not switch me back to the Pi
  2. So now I go back to the Pi, and perform a restart. The Pi reboots and OMSC loads. Instead of touching nothing, this time I toggle between menus a bit, just up and down my main home menu. I then select cable box input and my receiver switches inputs correctly, BUT then receiver will then switch back to the Pi 2-4 seconds later. This occurs again and again if I attempt to go to my cable box input

This ‘issue’ is repeatable. It seems that just by moving through a few menus, or activating the GUI sounds, somehow forces a permanent ‘active’ signal or something, and then im stuck with this problem.

Nothing has changed on my receiver nor my TV, no updates or anything like that. Only thing that has changed is I’ve kept my OSMC build up to date.

here’s the link to the log, hopefully I’ve done it correctly: http://paste.osmc.io/cecinijiti

please let me know if you need any additional info, thanks in advance!


May be nothing to do with it, but as you mentioned you’re using CEC to allow the Panasonic remote to control OSMC you might find the following 2 threads also worth following:

CEC does not work with Philips TV
[CEC]AVR shutdown after switching from TV to OSMC

Sorry that’s not a direct answer to your specific problem, but hopefully you might find the information there useful.

thanks for the reply, I read through those threads and although not exactly the problem I have, perhaps they are related. I also found this thread from a few weeks ago which sounds somewhat similar to the problem I’m having (the link shows a similar issue on Plex, but perhaps there is some low-level common software bug affected OSMC as well?):

1 Like

There are actually 2 cec systems in OSMC, one at the OS level and one at the Kodi level. Cec settings in config.txt change the OS settings but have no effect on the Kodi settings. Go to Settings>Input Devices>Peripherals>Cec to change the Kodi cec settings, you should be able to turn off the switching from there.

1 Like

Thanks for the reply. Yeah I’m aware of those and I’ve made sure that I’ve enabled CEC, but then essentially turned every other setting off.

I’m quite puzzled by this one

1 Like