[RPI3] [April Update] Sad face right after boot

Just updated and I am facing the “Sadface” right after the boot of my RPI 3. Everything was working fine before that. I can’t enable Debugging or Upload logs because I can’t access the My OSMC interface. But I still can login via ssh.

I am using Emby Server + Hyperion.

Here is the dmesg output http://paste.osmc.io/qoliyojugu.vhdl

Provide full logs with grab-logs -A

thanks for the hint. Here you go: http://paste.osmc.io/gufacucala

Most likely one of your addons is failing. To proof that theory execute.

mv .kodi kodi.bak
sudo systemctl restart mediacenter

If it starts then you will have to find out the addon that gives trouble.

That did the trick. Any easy way to find out which addon is making problems? Without trying to install them one by one and configure everything again?

It’s one of the pirate ones you have. We don’t recommend it anyway, as it grinds performance to a halt (very large repo)

I have pirate ones? I only installed amazon prime which isn’t even functional anymore.

I’d advise you start fresh. To make it clearer, you have a repository which carries pirate add-ons. We can’t provide support for that. Further, the repository is so large it can reduce system performance

Will do. Thanks for help. I just noticed that I can’t even connect with the Kodi Remote for iOS. Even in the fresh kodi profile.

Nervermind. I need to enable that feature in kodi settings…

If you moved .kodi you may need to reconfigure it again.

Copy the guisettings.xml from the .kodi.bak to .kodi


I just reconfigured everything. All went well. I configured Emby and the Theme “The Arctic Zephyr: From Ashes”. After doing a reboot I am back to the “sad face” loop.

Logs: http://paste.osmc.io/mecodocime

I have installed rbp2-mediacenter-osmc (16.0.0-13) via apt-get upgrade now and nothing changed. Still “sad face” loop.

It looks like the theme is to blame here. If I remove it from the guisettings.xml it will boot without a problem. I can than activate the theme via settings->appearance and the theme is working. But as soon as I reboot I will be in the “sad face” loop.

Here is a latest log: http://paste.osmc.io/dipolezive


I’m also having troubles with after the latest update and the Arctic Zephyr skin. Sad face…
Is there any way to get the skin working? Or do we have to ask te maker?

It worked fine till 16.0.

I just updated on my rpi 2, sad face too, and can’t ssh as it restarts by itself 5 sec after showing the face… I don’t use many addons, but I had emby, and the theme 1080X (I think it was this one).

Do you have a linux PC or can boot live CD to move guisettings.xml to check if that solves the issue?

He can just log in to the console locally.

My bad, it was not restarting, just the TV… Anyway, after moving .kodi to kodi.bak it actually worked. As I didn’t have much addons it will be easy to find which one is problematic.

Please report back, while one other user said it was actually something from guisettings.xml and he was just able to move the whole kodi folder back excluding the guisettings.xml

mm, no guisetting.xml in my folder, but funny thing, after my changes, I decided to put back my old kodi.bak to .kodi, it actually worked, and then, when I decided to put my skin back (Xperience1080), it crashed. So it seems it was the skin.

sorry thought you know what I ment .kodi/userdata/guisettings.xml

Thanks for the information. May I ask if you had upgrade from the Feburary/March version or an older?