RPi3 HDMI not working after boot despite hdmi_force_hotplug


I am using a Raspberry PI 3 witch OSMC 2022.03-01 and a Philips Screeneo connected via HDMI. As the Screeneo takes quite some tiime to start, the Raspberry Pi boots up before the Screeneo is ready and therefore does not detect the HDMI device and turns HDMI output off. The only thing that works to get the HDMI output is to reboot the Raspberry after the Screeneo is ready.

I played around with the HDMI-settings in /boot/config-user.txt that were suggested in other forum-entries, but non of them seems to change anything. I tried several combinations:

# The settings below I turned on/off but HDMI still doesn't work after boot

I also thought about workaround where I detect whether the HDMI output is active and then reboot if necessary, but I couldn’t find a solution as tvservice is not working (tvservice is not supported when using the vc4-kms-v3d driver.)

I’m not quite sure what I’m doing wrong. Any help would be appreciated to either fix the issue or find a workaround!


I have the same problem on mi Pi 3B+, hotplug does not work. Note that it used to work I think before the November 21 update. From that time I’ve had no luck trying to enable it back.

The only solution is to reboot once the display is ON.

That hotplug command doesn’t work with kms which is now default. If your needing to boot your RPi before the display is able to provide its info then you could probably just feed it an edid like was done in this thread…

1 Like

Thanks for the link! It works fine now.

1 Like