RPi3a+ new install boots to sad face

Hi,

I am a newcomer to OSMC, and have trouble just booting it ; Kodi does not show up, I get a sad face instead.

Detailed version: Using the OSMC installer on MacOS, I prepared a new Sandisk SD card with the 2021.12-1 image for Raspberry 2 / 3, configured to use my wifi setup. I put that card into a brand new Rpi3a+, no other devices connected except for an HDMI monitor and a USB keyboard, and waited a while for the installation to finish. I ended up with a sad face on a blue screen, but managed to log in on the console.

On my wifi router there is no trace of the raspberry. In case this matters, my ssid is hidden, and the router uses WPA2 PSK. This is a Rpi3a+, so I cannot use ethernet. Here are the logs: Logs created on: 2021-12-25 17:30:18 - (Uptime = 61.58)0wwkXuO5 : UNAME0 - Pastebin.com . I also checked the ssid and key in /boot/preseed.cfg, no typo there.

Does anyone know what I could try to debug this ? Thanks !


David

I just tried the older 2020.11-1 version, and this one works (1), so I get my problem is related to the new video stack. Is the Raspberry 3a+ supported by current OSMC ?

1: except it did not connect to wifi by itself although it was configured to; I had to manually set the ssid and key again after booting.

I found I had to install without wifi settings and then enter WIFI password via the GUI

Thanks, that’s what I did too, and it worked on the 2020.11-1 version.
Still, any idea why latest OSMC would not start the GUI on my Rpi 3a+ ?

If it works without specifying WiFi settings, then it’s an issue with the pre-seeder which will be fixed in the near future.

Thanks ! Although my main problem is not about wifi, sorry if I conflated the issues here. To summarise:

  • with OSMC 2021.12-1 the boot on my Rpi3a+ does not reach the Kodi interface, and shows the “sad face” screen instead
  • version 2020.11-1 works as intended.

I see a lot of messages about OpenGL and failure to allocate GPU memory in the log, so I was wondering if the RPi3a+ were still supported by the current OSMC builds.

Replying to myself: adding the following lines in config.txt allowed me to finally reach Kodi.

[pi3]
dtoverlay=vc4-kms-v3d,cma-256

3a+, like Zero-2, only have 512Mb so this makes sense. Maybe this could be included in a future release, with a more specific tag like [boardtype=9020e0] (not tested).

I’ll open a different thread for my wireless issues.

If you can test that, I can definitely get it included.

Sam

according to Raspberry Pi Documentation - The config.txt file the syntax and number should be:
[board-type=0x9020e0]

Unfortunately that does not work on my board. If you think of something else I can test, I will gladly.

Dav

I’ll ask @popcornmix.

board_type should just include the board type component of the board revision.
That is 0x0e for pi3a+.
So “board-type=0x0e”

Thanks!

I confirm this works on my 3a+

Hi

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv buster-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

I’d also recommend you deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.