Run Into a Sad Face While Playing Video

#12

I was able to find out that the audio on the UHD disc had very noticeable compression artifacts. That’s why the people that released the remux I posted media info of used the 24bit audio from the regular German Blu-ray disc that had to be synced. The framerate of the video, subtitles and chapters had to be changed from 23.976fps to 25fps to match that of the audio. This also explains why it says HYBRID REMUX in the file name. Hybrid meaning they used multiple discs to make a the remux.

I’m just guessing but Maybe if @eagerbeaver is trying to play the Original media from the UHD those artefacts could have caused osmc to crash

#13

@k2u3 Does this mean there’s no fix for this?

This one still occurs on November 2018 update (OSMC_TGT_vero3_20181101.img.gz)

#14

Sorry for the late reply.
Can I get a small MKV sample to reproduce this?

Cheers

Sam

#15

Sure

#16

I just watched the 3rd episode in 2160p on my 1080p SDR TV and my vero 4k+ didn’t crash and I also haven’t had any other issues other then that the picture could have been a bit brighter.

#17

HDR -> SDR improvements are planned

Cheers

1 Like
#18

Following up on this. Using test build 2019.04-1 and problem still persists. New log

#19

Are you sure a part of the file you are trying to play is not just somehow corrupted and it has nothing to do with the vero ? Have you tried a different version of the same content ?

#20

The problem is inconsistent. Sometimes it would crash, other times it plays normally. Same file.

If it was corrupted, wouldn’t it manifest the crash 100% of the time? Tell me if I’m wrong.

#21

What you wrote here makes me think that If you skip over the bit of the file that is corrupted it won’t crash but if you don’t skip over it it will.

But I’m no expert let see what @sam_nazarko or someone else from the team has to say

#22

Hi,

If the issue is only occurring with one video, have you tried ripping again from the original source? Looks like corruption to me.

Tom.

#23

Will try again.

#24

Hi,
I’m sorry to ‘re-open’ this case, but last night i ran into the same problem.
I got the May 2019.05-1 update and after restart my vero4k showed only sad face instead of videoplayback.

I thouht it’s because one of my 4k movie corrupt or sth else, but it wasn’t the case.
At the moment none of my videos can be played from Synology NAS.
I tried with my tv media player. The files were fine.

What should I do?

I’ve never seen this problem before.

Here is my latest log:
https://paste.osmc.tv/uraqijowug

Regards,
Tibor

#25

You are on GMC v19 testing version please stay within the testing thread

#26

If you rely on having a stable system, you should stick with stable builds and avoid the testing builds.

#27

Ahhh jesus, it’s my bad. Few month ago I changed to that because of my gopro files error or something. I’m going back to stable version somehow than.

#28

Let us know if you need help downgrading

#29

Thank you.

I checked the versions:
apt-cache madison vero3-mediacenter-osmc

Than I ran the sudo apt-get install vero3-mediacenter-osmc=18.2.0-12 command.
I guess this is the latest stable. Than i rebooted my vero4k. Everything was fine after.

Than I check the updater and it grabbed a latest version again 18.8-45 | http://download.osmc.tv/dev/gmc-19/public

So I put 18.2.0-12 back again.

How can I stick to latest stable and tell the updater on vero4k not to download all the gmc-19 versions?

#30

I guess I added this by myself to /etc/apt/sources.list few month ago.

Here is my source.list:

deb http://ftp.debian.org/debian stretch main contrib non-free
deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://apt.osmc.tv stretch main
deb http://download.osmc.tv/dev/gmc-19/public gmc-19 main

I remove the last line than.
I’m sorry about your valuable time.

#31

That’s correct, just remove the last line, then you are back on the normal repositories. After doing that, make sure to run

sudo apt update

to sync the cache.