Sad Face after October Update

Thanks for the follow-up. Logs from the vanilla .kodi: http://paste.osmc.tv/xujubulebi

I’ll be off to work shortly, so will pick up any replies this evening. Thanks again.

Well not much of a clue why it crashes. But similar to @nrosier you have installed many packages including X11 so may have to try to remove some of them to see if/when Kodi works again.

Good morning @fzinken , thanks. I’m not familiar with X11 … perhaps it got installed alongside another program.

Might be just as easy to do a fresh install and restore settings/addons?

I think that would be best as you have 30+ packages installed that might be conflicting.
Maybe you installed the “Desktop App” at one time.

Having the exact same issue. Here are my logs. I recently installed retropie so it seems like we all have that in common.

https://paste.osmc.tv/woteyaleho

Edit: Running the retropie installer and using the uninstall utility did not fix it. I did originally upgrade through the OSMC utility if that helps.

I don’t think retropie pushes X11 in, or?
Because that seems the common thing all three of you have X11 installed
Could it be you installed this?

Nope - I really try to keep my install slim. Seems like emulation station does install X11?

Possible, I haven’t had it installed on my current install. But I would be suprized of issues as I now that @hissingshark surely has upgraded to buster already

sudo apt-get remove x11-common 

This worked to clean up whatever package had been preventing kodi from starting.

1 Like

Interesting find. Does it still work if you reinstall x11-common?

It does work after reinstalling this package.

I have tested upgrading from Stretch to Buster, with RetrOSMCmk2 already installed and again, but only installing it afterwards.

I just checked and x11-common is indeed installed on my system - but running fine. It may be that the rogue package was dependent upon it, rather than a dependency of it.

What makes you think it was EmulationStation in particular? Or by that did you just means RetroPie in general?

Also, have you or @nrosier @brifletch been using emulators other than the ones I’ve supplied pre-built binaries for? So the installing/updating from source option? That might have taken you into unknown territory as some of RetroPie uses X11. I think MinecraftPi for example?

Having also the same issue. My logs are as follows:

https://paste.osmc.tv/ilevevesop

I just tried to install the October Update using myOSMC.

You don’t appear to have RetroPie installed.
Perhaps not the common thread then.
Like @nrosier I also use Hyperion, but again it’s all been tested.

EmulationStation seems like the component that requires X11 but I’m no expert.

I really didn’t install anything but the regular core files with retropie. I got that far and learned my controller wasn’t recognized and quit. Certainly didn’t build anything from source.

Your issue is different.
You had been testing Kernel 4.9 at one time but didn’t follow the upgrade there.

You need to change your apt sources
deb http://apt.osmc.tv videoimprovevero main
to
deb http://apt.osmc.tv videoimprovevero49 main

And then update

Cool. I was going to suggest I could look into it, see if there’s a safe way of building the more exotic emulator for you.

Here is a diff that shows what changed between broken (left pane) and working (right pane)

https://www.diffchecker.com/3ponV04x

@hissingshark I don’t believe I’ve installed anything out of the ordinary … though, I can’t say with certainty that I didn’t install any from source … possibly not intentionally.

If I remember correctly, I installed Emulation Station a long time ago (possibly didn’t work as expected - I’m not 100% sure), but only recently installed retropie, which all seemed to be working fine.

Once I’m home this evening I’ll try removing x11-common as @Fffrank did to see if that gives a positive result.

Thanks for the fast reply - I changed it and it now works for me :slight_smile: