Sad face after updating, not sure how to get logs?

Try running

sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot

and report what happens.

Do all of this in one line, right? I did that, says 0% [Working] – just wait some more?

If it’s not moving from 0% then you have no network connection. I thought you said you plugged in a network cable?

Yeah, I definitely did. The port back there has lights, it knows it is connected. Previously, before I connected the ethernet cable, it was returning an error saying there was no connection (when I had my wireless adapter in) so I know that error message at least appears with my current setup.

My actual device itself is still sitting at Updating the list of available OSMC packages … Should I maybe restart, not run the auto-update, and then try to do the SSH stuff?

Can you pastebin the output of of

ifconfig && ping -c 4 google.com

Paste the output to paste.osmc.io and report the resulting url after clicking the save button?

http://paste.osmc.io/opimitafop.sm

Is this what you’re looking for?

Exactly! :smile:
Though, all this looks good. My only suspicion is heavy traffic on the update servers… At this point, I can only suggest wait an hour or two and try the update/upgrade commands again or possibly attempt a full re-install :confused:

does ping -c 4 apt.osmc.tv return similar results to the google attempt before?

Yeah, similar results (no errors/packet loss). Well … I don’t terribly mind reinstalling this, as I primarily just watch things on my external drive and don’t spend too much time setting up any kind of preferences or building a library that I will lose by doing this.

Unless you have any other suggestions (I tried getting out of that update screen and trying the SSH commands above for updating and they also stuck at 0%), I’ll go ahead and do that. I appreciate all the help and at least now I’m a bit more knowledgeable on how to get in via SSH and run commands for the next time something breaks on its own or I accidentally burn everything to the ground.

If you aren’t in a huge hurry, you could

sudo journalctl | paste-log
paste-log /var/log/apt/term.log
paste-log /var/log/apt/history.log

And provide the URLs so me and the devs can take a look in the morning? Or at least have a chance to see what the issue was that created the problem, in hopes of preventing it for others in the future.

Sorry I can’t be of more help tonight!

The first thing returned an error. “mktemp: failed to create file via template ‘/tmp/tmp.XXXXXXXXXX’: Read-only file system
-bash: $tmp: ambiguous redirect”

Second link returns this
http://paste.osmc.io/wugosirehi

Third link returns this
http://paste.osmc.io/denabocope

That’s for your guys’ info … unless you see anything glaring immediately there, I probably will just reinstall tonight.

Did you try the new Pi SD card driver perchance?

S

I didn’t go out of my way to try anything specific, no. I was prompted for an update, hit yes to restart and then, to my knowledge, I didn’t look at the thing for over a week and came back to it like this.

EDIT: As an aside, in the full installer, is 2015.06-01 the latest or is it RC1/2 or 3?

I don’t see anything immediately wrong with your logs

It would be wonderful if you could run the following commands:

sudo journalctl | paste-log
dmesg | paste-log

It’s 4am here, so I must sleep, but I will check this tomorrow, and I kindly request, you do not reinstall yet so we can help future users should we discover an issue with your system

Sam

The 2015.06-01

If it will ultimately help, I will wait on reinstalling. Here is the output from those two things – both failed.

“osmc@osmc:~$ sudo journalctl | paste-log
mktemp: failed to create file via template ‘/tmp/tmp.XXXXXXXXXX’: Read-only file system
-bash: $tmp: ambiguous redirect
http://paste.osmc.io/ohewiwukeh
osmc@osmc:~$ dmesg | paste-log
mktemp: failed to create file via template ‘/tmp/tmp.XXXXXXXXXX’: Read-only file system
-bash: $tmp: ambiguous redirect
http://paste.osmc.io/yifuvopude

Somehow your filesystem has got corrupted which has left it in read only mode. Try one of these to fix it. Either

a) Hold down shift during boot to go to the recovery console, when the fsck is finished (it might ask you some questions) type exit

or

b) From ssh run

sudo fsck /

Then reboot when finished.

Note: If you were running RC2 or earlier with particular SD cards (including the Samsung EVO) on a Pi 2 there could be significant file system corruption that might require a reinstall. (Let us know the model of your SD card in case this is your issue) This problem was fixed in RC3 and later.

So, I can’t be sure if I was running RC2 or earlier when all this happened. I was checking for and installing updates pretty frequently, however. I was not able to get it to go to the recovery console by holding shift, so I did it via SSH. It asked me several things to fix and I said yes to all of them. It then said it was rebooting, but my screen just kept flashing the frown face. I removed power, plugged it back in and got that again. I then tried the shift+ctrl to update after it fixed all those things, and got past the “Searching for packages thing …” but then it crashed saying there was an unknown error trying to install updates and I’m back to the frown face.

At this point, I believe something has gone catastrophically wrong. Is there anything else ya’ll can get from this, like logs and what not?

I think I’d say go ahead and rebuild your system. I’ll offer thanks from the dev team here for your assistance in providing relevant info so that we can attempt to prevent future occurances of the issue. Hopefully we’ve also provided you a bit of insight into digging into the system beyond the GUI since the spirit of the Raspberry Pi is based in education :slight_smile:

Thanks again and enjoy!

Yeah, it’s at least given me a basic understanding how to get into that stuff. Also I know how to SSH into my seedbox now, so that’s neat.

Anyway, one last thing is that the SD card I used was a Kingston 4GB N0043-012/A00LF, according to the card.

EDIT: Didn’t want to bump this up with another post, but I’ve reinstalled on the same card and everything seems to be working quite well, so we at least know there was nothing faulty about the card, just in case anyone comes back to this topic.