Sad-Face-Loop with FilmOn

I have used FilmOn for a long time on OSMC_TGT_rbp2_20200402.img and previous versions without problems, while a clean install of later versions gives a ‘sad-face-loop’.

The log is made on a clean install of OSMC_TGT_rbp2_20201227.img, (incl. sudo apt-get clean, sudo apt-get update, sudo apt-get dist-upgrade) on a RasPi 3B.
The problem can easily be reproduced.

Installation of the FilmOn add-on , starts the loop when enabling the add-on.
In order to stop the loop and use ‘grab-logs -A’, I found no other way than to just take out the network cable.

Link to the log (hope it’s OK):

I have tried to google the problem, without success and sincerely hope someone can help me.

> 2021-01-02 22:41:05.238 T:1618002144   ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35)

If this only happens with the latest version it could be a SSL version problem or not updated certificates.

Check this thread

fzinken, thanks for replying.
I have checked /etc/ca-certificates.conf, but there is no ‘mozilla/AddTrust_External_Root.crt’.
Just to do something I tried to deselect ‘mozilla/USERTrust_RSA_Certification_Authority.crt’ , but it did not help.

Any other certificates I should try to deselect?

Let me know if I should post the /etc/ca-certificates.conf.