Sadly im facing a sadface-bootloop error i can’t fix by myself. It occured after i did the last update. Working on the terminal is fine but i can’t access kodi. There is always a sadface on the screen which “reloads” every few seconds.

After reverting to a working SD-Image Kodi was fine again. Then i did apt-get update and apt-get dist-upgrade which gave me the sadface-loop again.

Here is my log:

I hope anyone got an Idea how to fix this.


Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

Thank you for your suggestions. I already tried it without any effect. I tried again but nothing changes.

You’re on the development repository, so are running on kernel 5.10.3-1.

The error is this:

Feb 22 15:42:20 osmc mediacenter[395]: /usr/lib/kodi/kodi.bin: error while loading shared libraries: cannot open shared object file: No such file or directory

Library comes with package rbp2-libcec-osmc but you’ve now updated this package to version 6.0.2-3, rather than 4.0.4-5. I think @sam_nazarko will need to advise why the library is now missing.

The development repo doesn’t have a working set of files in it atm.

1 Like

So it looks like you’ll need to reinstall OSMC.

The staging repo is now being used to prepare Kodi v19.

Thank you for your sugestion. I forgot that i fooled around with the developement repo didn’t remove it. Now i removed it from the sources.list file and made the following downgrade and everything works again. Thank you very much!

osmc@osmc:~$ sudo apt-get install rbp2-libcec-osmc=4.0.4-5 --reinstall
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be DOWNGRADED:
    0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
    Need to get 310 kB of archives.
    After this operation, 18.4 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 buster/main armhf rbp2-libcec-osmc armhf 4.0.4-5 [310 kB]
    Fetched 310 kB in 1s (544 kB/s)
    dpkg: warning: downgrading rbp2-libcec-osmc from 6.0.2-3 to 4.0.4-5
    (Reading database ... 49721 files and directories currently installed.)
    Preparing to unpack .../rbp2-libcec-osmc_4.0.4-5_armhf.deb ...
    Unpacking rbp2-libcec-osmc (4.0.4-5) over (6.0.2-3) ...
    Setting up rbp2-libcec-osmc (4.0.4-5) ...