Samba only one way connection

I just received yesterday my new Vero 4K.
EVENTUALLY the Vero 4k was able to discover my Samba connection on my Kubuntu laptop.
I am not sure what I did that got it working -if anything. However the Vero 4k keeps crashing while scanning my music library!!!
Kubuntu cannot see the Vero 4k Samba though!
My previous Kodi box running Coreelec was accessible through the Dolphin file manager in ‘Network’. Clicking in the Smb directory revealed other devices. Once when it could not find coreelec I was able to type WORKGROUP after smb and it connected.
None of this works with the Vero 4K!
I also tried the IP address to no success.
“Could not connect to host for smb://osmc/” is all I get! nb I changed the name WORKGROUP to osmc.
Zeroconf is enabled (and actually will not disable).
Please help!

Did you Install the Samba Server via MyOSMC -> App Store?

No! ?
I just enabled it in the settings.

OK, thanks! I am getting somewhere!
osmc now shows in Dolphin!
I cannot access the files though. It pop up with a pass form. Entering no password does not work.
Is their a defaut set password?
Thanks.

Yes default user/password is osmc/osmc

:pray: :ok_hand:
Thanks! That works!
Hopefully the Vero 4K does not crash now when I do another scan of my music library! :slightly_smiling_face:
Thanks for your help!

Nope! :rage: It keeps crashing! It cannot complete a full scan. :frowning_face:

Suggest to enable debug logs and upload them (see below)
I would assume that it must be a problem with certain files in the shared library.
Alternative if it is just a network/access issue you could try to use kernel mount instead.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

We need to see logs. This could be caused by a corrupt file.

Try SMBv1 only as shown below
-

I doubt it’s that – it wouldn’t cause crashes, just a lack of connectivity.

I also have(had) this issue. It was some kind of WMA file if I remember correctly. I fixed it by moving all my media libraries to NFS share

Probably out of memory IMHO

I use this snipplet to install all samba required stuff on Vero or any Raspberry (with catia mappings for incompatible Windows characters). It defaults to read-only for guests. No workgroup required.
I use Dolphin too, but on Debian with KDE, a bit older (until Debian 11 later this year) but perhaps more stable. Hope it helps.

sudo apt-get install debconf-utils <&-
echo -e "samba-common    samba-common/workgroup  string $HOSTNAME
samba-common    samba-common/dhcp       boolean true
samba-common    samba-common/do_debconf boolean true\n" > autoprefs 
sudo debconf-set-selections < autoprefs
rm autoprefs
sudo apt-get install -y expect samba vlc-plugin-samba isc-dhcp-client libcups2 samba samba-common cups samba-client cifs-utils samba-vfs-modules <&-
sudo cp /etc/samba/smb.conf /etc/samba/smb.conf.backup
sudo sed -i -e "s/workgroup = .*$/workgroup = $HOSTNAME/g" /etc/samba/smb.conf
sudo sed -i -e "s/valid users = %S/valid users = windows$USER/g" /etc/samba/smb.conf
sudo sed -i -e "s/^\[global\]/[global]\n  allow insecure wide links = yes\n  unix extensions = no\n  follow symlinks = yes\n  wide links = yes/g" /etc/samba/smb.conf
echo -e "[Muh Shared Stuff]\n  path = /media/SMBSHAREDDISK\n  comment = shared folder\n  read only = yes\n  writeable = no\n  follow symlinks = yes\n  browseable = yes\n  wide links = yes\n  guest ok = no\nmangled names = no\n  catia:mappings = 0x22:0xa8,0x2a:0xa4,0x2f:0xf8,0x3a:0x2236,0x3c:0xab,0x3e:0xbb,0x3f:0xbf,0x5c:0xff,0x7c:0xa6\n  vfs objects = catia\n  valid users = $USER, tvguest\n" | sudo tee -a /etc/samba/smb.conf >> /dev/null
# catia:mappings
# " --> ¨
# * --> ¤
# / --> ø
# : --> ∶
# < --> «
# > --> »
# ? --> ¿
# \ --> ÿ
# | --> ¦
sudo useradd -m -c "tvguest" tvguest --shell /bin/bash
passwordosmcsmb=r224f24f24f2343f344545t45t4
passwordtvguestsmb=1234
sudo expect -c "
  spawn sudo smbpasswd -a $USER 
  expect {
    -re \"^.*New SMB password:.*\" {send -- \"$passwordosmcsmb\r\"; exp_continue} 
    -re \"^.*Retype new SMB password:.*\" {send -- \"$passwordosmcsmb\r\"; exp_continue} 
    eof { exit }
  }
  exit" 
sudo expect -c "
  spawn sudo smbpasswd -a tvguest 
  expect {
    -re \"^.*New SMB password:.*\" {send -- \"$passwordtvguestsmb\r\"; exp_continue} 
    -re \"^.*Retype new SMB password:.*\" {send -- \"$passwordtvguestsmb\r\"; exp_continue} 
    eof { exit }
  }
  exit" 
# sudo pdbedit -w -L # list existing samba users
sudo chmod a+r -R "/media/SMBSHAREDDISK/"
sudo service smbd restart
sudo systemctl restart smbd nmbd

So your samba share will be ‘Muh Shared Stuff’, user ‘tvguest’ and password ‘1234’.
Assuming the IP of your Vero as ‘192.168.1.VERO_IP’, you can log in in KDE via Dolphin with
smb://192.168.1.VERO_IP/Muh Shared Stuff
and on Windows with
\192.168.1.VERO_IP\Muh Shared Stuff
furthermore on Android a good free app with samba support is Cx File Explorer

Suggest switching to NFS (v3) for sharing with the Vero instead of SMB (Samba) when running 'nix on your file server. Much simpler and I believe it performs better. At the least it will also assist in troubleshooting the crashing problem.

I went to use the samba connection again and this time it would not work. I noticed my samba share labelled osmc had gone back to the default WORKGROUP. Why would it do this?
This prompted me to check MyOSMC app store to see if Samba Server was still installed - except there is no MyOSMC app store anymore!! What happened to this?? Argh!
How do I get the store back and how do I get the system to keep settings?

That is very Odd. Is there no App Store under MyOSMC anymore or you lost MyOSMC Programs Addon?
Did you change Skins? That would explain why you might have lost MyOSMC.

I switched to the Estuary skin and MyOSMC is present there. Samba Server is installed.

There is no MyOSMC directory.
Yes, I have been using Aeon NOx silvo.

MyOSMC is a Progam Addon. So you will find it under Program Addons on other skins. The OSMC and Estuary skins are designed to show it as a separate menu item.

Maybe that has reset the guisettings.xml which also includes the Samba settings.