Scan for new content context menu not working

This only happens on my Vero 4k. Works fine on my Pi3s running the latest OSMC.

When I add new content to one of my TV shows, on the Pi, I can find that TV show in the list, click the context menu and choose “scan for new content.” This will scan just this one tv show for new content and update the library accordingly.

Alternatively, I can back out to the main menu and go to the “files” section and select the top level of my TV show folder, bring up the context menu and select “scan for new content” and it will scan the entire TV shows folder.

Both of these methods work on the Pi3 (and always have, back to the days of RaspBMC). On the Vero 4k, only the top-level version works. When I select “scan for new content” on an individual show, nothing happens. I get no progress bar or anything.

I’ll have to wait until the next TV show downloads in order to get logs.

Would you want to see logs from both the Vero and Pi3?

Debug log on the Vero 4K may help
Libraries start behaving weirdly if they become corrupted.

FYI: you can export the library from Pi and import to the Vero 4K.


They are a shared MySQL library hosted on the Vero.

Okay – some logs may give some pointers
I suspect copying the entire kodi directly from Pi to Vero will solve the issue

They use the same central library. I MySQL DB hosted on the vero. You can’t copy that onto itself.

Furthermore, this has never happened in all my years of RaspBMC/OSMC on Pi1/3.

I have had library corruption prevent me from detecting new episodes in a show, but that didn’t matter which method I used to scan – this is the first time I’ve seen one method work while another doesn’t.

I’ll get you some logs soon. Next time I can make it misbehave.

All the more reason to see the logs.

I’m talking about the Kodi directory.

What does your .kodi/userdata/sources.xml look like on the Pi and on the 4K?

They are identical. I’ve pasted it below.

<sources> <programs> <default pathversion="1"></default> </programs> <video> <default pathversion="1"></default> <source> <name>Movies</name> <path pathversion="1">nfs://rrl-nas/mnt/user/Video/Movies/</path> <allowsharing>true</allowsharing> </source> <source> <name>TV</name> <path pathversion="1">nfs://rrl-nas/mnt/user/Video/TV/</path> <allowsharing>true</allowsharing> </source> <source> <name>Video</name> <path pathversion="1">nfs://rrl-nas/mnt/user/Video/</path> <allowsharing>true</allowsharing> </source> <source> <name>osmc</name> <path pathversion="1">/home/osmc/</path> <allowsharing>true</allowsharing> </source> </video> <music> <default pathversion="1"></default> </music> <pictures> <default pathversion="1"></default> </pictures> <files> <default pathversion="1"></default> </files> </sources>

I have a similar setup, and have seen this behavior several times. Sometimes I’ve had it happen from a Pi, last time was from my Linux Mint laptop. I never have found a cause or cure, short of moving a show that won’t scan to a new directory. From what I’ve seen, it has nothing to do with OSMC, it’s a generic Kodi issue.

Bummer. Where this is a problem for me is that I use Sonarr and Radarr for TV and Movies. When Sonarr finds a new episode, it tells Kodi to refresh just the show…and it fails. So, the automation isn’t working.

I now have to manually refresh the entire library. Not a huge deal, but it sure would be nice if it was working.

Another interesting tidbit that might affect this: Until recently, I was using SMB instead of NFS and never had this trouble. Could the NFS connection (vs SMB) have anything to do with this? I wouldn’t think so, but I figure I should eliminate all the variables.

You could try using an IP address instead of the host name. I also use nfs, but have my mounts in fstab instead of nfs:// in sources.xml.

If it happens again, try posting your logs. Maybe someone will see something that I’ve missed.

I don’t want to use IP. I deliberately use DNS names – I have good DNS here, not just some crappy $20 router. It also doesn’t explain why it works in the “videos” section on the entire TV Shows folder but not the individual show. Also never had this trouble while I was on SMB either.

Also, I can’t use fstab mounts because I need the WOL features to work. If Kodi thinks that the file source is local (fstab mount) it doesn’t know that it should send WOL.

As soon as I can duplicate it (it’s sure to happen again soon) I’ll capture logs.

It’s the DNS resolution within Kodi that has been notoriously flakey for ages…

Maybe try defining the name in /etc/hosts? Then I think the DNS in Kodi won’t be an issue, and you will not need to re-scan your library. Worth a try at least.

OK. I will try that. But if it works, it’s still a non-starter for me. Manually defining anything in /etc/hosts kinda defeats the whole purpose of DNS.

If that was the issue, I’d expect that it would fail in both the individual show AND in the TV folder. Also, I’ve been using DNS for years with Kodi and this problem has not cropped up.

Occam’s Razor says that the simplest solution tends to be the right one. The only recent changes to my “system” are the changeover to NFS from SMB and the change from a Pi3 to Vero 4K.

You mean that Kodi does its own DNS resolution rather than relying on the underlying DNS resolver that’s built into the host platform? That seems really stupid and akin to reinventing the wheel!

Same as how Kodi uses it’s own SMB and NFS library…

When I’ve seen this happen, it seems that Kodi thinks that nothing has changed in the directory. I’ve even tried touching all files and Kodi still refuses to see any changes. But I can try on a different system and see the changes. For me it’s always been a bazaar problem and hard to reproduce. But once a particular system decides to stop scanning a directory, that’s it for that system; it will never work again unless you completely remove the TV Show, or move it to a new directory. But it WILL scan from other systems.

The only thing I’ve never tried is using SMB, as I have nothing shared via SMB.