SD card stuck in readonly

One of my SD cards died so i took an image of my other one and since then the SD card wont boot, it doesn’t get past the initial fsck check and i get no osmc splash screen.

I’ve tried formatting the card on 2 different computers and different tools but nothing works.

Its not the switch that are on some micro SD card adapters, I’ve tried on a computer that only has a micro sd slot as well as android devices.

I can read the fat parition with no issues, if i mount the Sd card on a linux VM im able to read the data as well, so i don’t think the SD card is bad, it was working no problem until i took an image of it.

I have the same issue with an Samsung EVO 16G, I don’t know if it’s from the OSMC Installer or else where, it can really a card problem.

Which evo card do you have?


Have you tried formatting the card with this ?

Nothing that you do to the card from OSMC can “kill” the card. If it dies, it has died of its own accord.

Yes it says its read only, i know it isn’t osmc since the card was working until i put it einto my pc to create an image. Oddly enough the bad card is doing the same.

Have you tried another SD Card reader? Which OS are you using on the PC?

Tried on two different win 10 pcs and an android device. 1 pc only has a micro slot so its not the adapter

Meant what model mp16d or sp16d, i should point out that i can force a format and it looks like works but the data is always intact

confirm that

Read only mode seems to be a fail save not to loose data, This is state it turns into when having unrecoverable errors.
Had the same with a card, formatted/wiped/moved nothing worked data kept intact after googling the best answer was “Stop trying to fix, it’s broken, save data and use a new one”


But two SD card in the same day seems very unlikely or just really bad luck, but it does make sense and is actually an excellent feature. I could RMA the sd cards but I hate having my data still on the card.

After booting into a linux box it seems like ext4 partition is whats locked and cannot be formatted even after trying to take ownership.

If you have linux and you are 100% sure you can not rescue the data use sudo gparted to apply a new partition table to the SD card, that still should work.

Or if you want to bruceforce clear the data on the card and you know what you do you can use sudo dd if=/dev/zero of=/dev/<device of your sd card> bs=8192

I had a Samsung EVO 8G and yesterday i wrote on the config.txt via winscp while the pi was running, and when i rebooted the pi the card was bricked. Tried diskpart, fdisk (using an old p1), windows normal format, partition guru, Easus partition magic and none of them worked. Only this: HDDGURU: HDD LLF Low Level Format Tool showed that it was formating and the sd reader lights were turning on/off while formating but in the end nothing changed.
The only thing that did work was, was using OSMC’s installer to install osmc again, but the card was not recognized by the pi when booted. I had the 4 green blinking lights and nothing on screen.

Maybe osmc could also add an option to format the sd card, since their installer seemed to be the only thing working…I dont know how they managed to ‘insert’ data to the card.

Well how would you judge that the installer wrote to the card if it is not booting?
Having data being transfered to the card doesn’t mean it is confirmed to be written to the card.

true…i dont know if it actually wrote anything on the ext4 partition…you might be right…seeing files on the fat32 partition doesnt mean everything else worked. I’ll try the gparted thing you mentioned now…although in 1h the new card will be here:)

Edit: Nothing worked… Next valentines day, we can use our EVO cards to make someone happy. From now on i’ll be getting Transcend…with lifetime guarantee.

mine will stuck at:
switch_root: can't execute '/sbin/splash_early': Not a directory:cold_sweat:

I’m not sure what makes you think you have the same “issue” discussed in this thread. There is nothing to suggest that your card has magically gone “read only” from the error you have posted.

I’d suggest you start your own thread with as much background and information of your problem as possible. (EG what were you doing before it happened, what have you tried already to fix it…)

sudo gparted had no effected, said it deleted the partitions but a refresh and it was like nothing ever happened. trying sudo dd if=/dev/zero of=/dev/ bs=8192 which seems like it’s doing something will have to wait and see.

If gparted can make no change to the partitions on the SDcard, then that card is toast. RMA or replace.

1 Like