SD card stuck in readonly

I hope you didn’t write it like that without defining the right device?

of=/dev/mmcblk0 is what i wrote, not sure why that was missed, anyways even if it was wrong, it’s a live boot cd in a vm. It also had zero effect but took a long time to complete.

I have ordered the same adata cards again, rather cheap and comparable to samsung, considering they also have this isue. Not sure if i want to RMA since they do have lifetime warranty since my data is intact and I can actually view everything within linux.

1 Like

That most likely is interpretation of the Forum, use blockquote or preformated to avoid that.
As it is a live boot maybe try what would happen if you do of=/dev/ actually as no such device exists it should throw an error.

“adata” worst thing I ever had! Once and not again. For me Sandisk is the winner with not a single fail on 6 cards that I use.

sandisk aren’t bad but i haven’t found one with good performance in my area and they are way over priced. Adata lasted me a year so it isn’t to bad, just a shame they both took a dump at the same time, with one that was working with no issues.

The other card that died first was showing signs of corruption, partially coz kodi wasn’t shutting down properly. TV USB port, yes yes i know but i had my reasdons. I have since plugged it into it’s own power source and keep it on 24/7.

One of my cards is working since I first got the Pi1 means we are talking about 3 years of operation

1 Like

hehe true so is the sandisk in my Pi1

1 Like

I had similar effects with my first OSMC Pi3 installation.
I was unable to fix the partition of my MicroSD.
As mentioned before I had an old Ubuntu laptop with Gparted, deleted all partitions and created a new FAT32 partition.
Make a fresh installation
After that switch to a windows 10 box and used:
SD Card Formatter

Win32DiskImager Win32 Disk Imager download |

Yeah, i tried it all and nothing worked

got the new adata cards today, did a fresh install of osmc and then restored a backup. If these cards die within a year they will be my last adata purchase.

Not sure what really caused the issue on the second card but the SD slot on my computer has always been problematic so it may have been the culprit and giving adata a second chance. It only stopped booting after I created the image otherwise it was fine, i created the image for the one that actually corrupted hoping I could avoid starting from scratch.

I always have to shutdown and the turn on again to get the SD slot to work on my computer, it’s the actual slot on the computer which I will no longer use.

I wonder if it would be simpler to run osmc out of a usb stick instead of all this crap every once in a year.My Pi1 is still running a multiboot using a Sandisk card from the beginning. A raspbian system on the sd, and kodi on the stick. I bet in the near future we’ll see a pi with an internal flash memory to store the bootloader.

We have discussed it before, there is no reason that a USB install should be more stable (more to the opposite as power issues can impact the USB port.
Use a quality SD Card and no issues, as I wrote 3 years of 24x7 operations of one card in my Pi1

1 Like

As far as I know there a 10,000 cycles on a SD per cell so after this the card is gone. I don’t know atm. what a Usbstick can handle, but we have 4 usbports may you can build an RAID0 (software) with 2 of them and store only the bootloader on a card.

Well I think this is where the difference lies. Sandisk list 100,000 write cycles per sector.

Sofware raid0 will be slow as hell on a raspberry.

Was just a wild shot

I have a sandisk sd card. If put that in to Rpi3, I am able to upgrade the osmc build, download addons etc…means osmc is able to write to the card. But if I the same card in my windows pc and try to format means I am getting "The card is write protected " message. As OSMC is able to write to the card means, I think it is working fine but cant format the card from a PC. Please help I have one samsung Evo 32gb card also with the same issue.

Pi ignores write protect on SD cards.

Your adapter may be problematic.

No, I have used multiple adapters and every where same behavior. Also If I put the sdcard in a camera or in a MAC means, I was able to format and write to it but not in a Windows PC. Once format is done etcher can burn a new image to that card also. Both sandisk and samsung evo 32GB are relatively new cards. :frowning:

Anyway to rectify this problem?

May I ask how you believe the OSMC community can help you with a PC related issue?

1 Like