SDR 2160p 10-bit content still not playing correctly on Vero 4K after October update


#1

Hi,

I have quite a lot of content that is 4K 10-bit SDR. For the last few updates these files have played with heavily over-saturated colours on the Vero 4K. I was hoping the colourspace improvements in the October update would fix this but the problem remains.

Here is a log if it’s helpful:
https://paste.osmc.tv/uxecirafac


#2

Can you post mediaifo for that file, please? ATM it’s being played with BT2020 colorimetry.


#3

Here it is:

General
Unique ID                                : 0 (0x0)
Complete name                            : F:\Movies\Suspiria (1977)\Suspiria (1977) [4K UHD].mkv
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 38.1 GiB
Duration                                 : 1 h 40 min
Overall bit rate                         : 54.1 Mb/s
Encoded date                             : UTC 2010-02-22 21:41:29
Writing application                      : no_variable_data
Writing library                          : no_variable_data

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main 10@L5.1@High
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 1 h 40 min
Width                                    : 3 840 pixels
Height                                   : 1 634 pixels
Display aspect ratio                     : 2.35:1
Frame rate mode                          : Constant
Frame rate                               : 24.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Writing library                          : x265 2.8+58-d17bc7714ed2:[Windows][GCC 8.2.0][64 bit] 10bit
Encoding settings                        : cpuid=1176575 / frame-threads=5 / numa-pools=36 / wpp / no-pmode / no-pme / no-psnr / no-ssim / log-level=2 / input-csp=1 / input-res=3840x1634 / interlace=0 / total-frames=145213 / level-idc=51 / high-tier=1 / uhd-bd=0 / ref=4 / no-allow-non-conformance / repeat-headers / annexb / aud / hrd / info / hash=0 / no-temporal-layers / no-open-gop / min-keyint=24 / keyint=240 / gop-lookahead=0 / bframes=4 / b-adapt=2 / b-pyramid / bframe-bias=0 / rc-lookahead=25 / lookahead-slices=4 / scenecut=40 / radl=0 / no-intra-refresh / ctu=64 / min-cu-size=8 / rect / no-amp / max-tu-size=32 / tu-inter-depth=1 / tu-intra-depth=1 / limit-tu=0 / rdoq-level=2 / dynamic-rd=0.00 / no-ssim-rd / signhide / no-tskip / nr-intra=0 / nr-inter=0 / no-constrained-intra / no-strong-intra-smoothing / max-merge=3 / limit-refs=3 / limit-modes / me=3 / subme=3 / merange=57 / temporal-mvp / weightp / no-weightb / no-analyze-src-pics / deblock=-3:-3 / no-sao / no-sao-non-deblock / rd=4 / no-early-skip / rskip / no-fast-intra / no-tskip-fast / no-cu-lossless / no-b-intra / no-splitrd-skip / rdpenalty=0 / psy-rd=2.00 / psy-rdoq=1.00 / no-rd-refine / no-lossless / cbqpoffs=0 / crqpoffs=0 / rc=crf / crf=17.0 / qcomp=0.60 / qpstep=4 / stats-write=0 / stats-read=0 / vbv-maxrate=160000 / vbv-bufsize=160000 / vbv-init=0.9 / crf-max=0.0 / crf-min=0.0 / ipratio=1.40 / pbratio=1.30 / aq-mode=1 / aq-strength=1.00 / cutree / zone-count=0 / no-strict-cbr / qg-size=32 / no-rc-grain / qpmax=69 / qpmin=0 / no-const-vbv / sar=1 / overscan=0 / videoformat=5 / range=0 / colorprim=1 / transfer=1 / colormatrix=1 / chromaloc=0 / display-window=0 / max-cll=0,0 / min-luma=0 / max-luma=1023 / log2-max-poc-lsb=8 / vui-timing-info / vui-hrd-info / slices=1 / no-opt-qp-pps / no-opt-ref-list-length-pps / no-multi-pass-opt-rps / scenecut-bias=0.05 / no-opt-cu-delta-qp / no-aq-motion / no-hdr / no-hdr-opt / no-dhdr10-opt / no-idr-recovery-sei / analysis-reuse-level=5 / scale-factor=0 / refine-intra=0 / refine-inter=0 / refine-mv=0 / no-limit-sao / ctu-info=0 / no-lowpass-dct / refine-mv-type=0 / copy-pic=1 / max-ausize-factor=1.0 / no-dynamic-refine / no-single-sei
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
Statistics Tags Issue                    : no_variable_data 1970-01-01 00:00:00 / no_variable_data 2010-02-22 21:41:29
FromStats_BitRate                        : 41175689
FromStats_Duration                       : 01:40:50.542000000
FromStats_FrameCount                     : 145213
FromStats_StreamSize                     : 31141905185

#4

So is the problem that the Vero 4K is wrongly assuming that all 2160p content should be played with BT.2020 even where the file is encoded with BT.709?


#5

My Vero 4K is doing this too (latest update). I only have had 2 examples of such content in my library:

Remuxes of the 4K/UHD BDs of:

Suspiria (1977) (like the poster above) but since deleted.
and
Hotel Artemis (2018) which I still have.

Both are 4K with 10-bit colour, but do not have HDR and are encoded with BT.709 colourspace.

Hotel Artemis has the exact same characteristics:

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main 10@L5.1@High
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 1 h 33 min
Bit rate                                 : 68.3 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Bits/(Pixel*Frame)                       : 0.344
Stream size                              : 44.8 GiB (90%)
Title                                    : Hotel.Artemis.2018.2160p.BluRay.REMUX
.HEVC.DTS-HD.MA.5.1
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
Mastering display color primaries        : R: x=0.000000 y=0.000000, G: x=0.0000
00 y=0.000000, B: x=0.000000 y=0.000000, White point: x=0.000000 y=0.000000
Mastering display luminance              : min: 0.0000 cd/m2, max: 0 cd/m2

My AVR (Denon X2300W) receives a 10 bit BT.2020 YCbCr signal which is passed to the TV, and when the TV’s colourspace setting is at Auto, the colours are certainly incorrect and too garish.

Luckily, I can manually choose which colourspace to view on my TV (Sony XD93) so as a workaround I can force sRGB/BT.709 which corrects the image.


#6

I have at least a dozen files that are 4K/10-bit/BT.709 that all display with oversaturated colours. I also have a couple of 4K/8-bit/BT.709 that also display incorrectly. So it seems it is a colourspace issue and nothing to do with 8 or 10 bit colour.

The reason certainly seems to be that the Vero is ignoring the encoded BT.709 colourspace and is outputting BT.2020 for all 4K content.

Unfortunately, I don’t have a setting on my display that lets me manually set the colourspace so I’m seriously hoping that this can be fixed.


#7

I’ve had this issue as well and haven’t tested this with the testing kernel, since the 2160p Kodi GUI was displayed ok.

This has been an issue since the beginning when it switched to 10bit.


#8

Can someone point me to some 10-bit SDR material or upload a short clip, please?


#9

Here is a 90sec clip. I removed audio and subtitles to reduce file size.

Rar pass is osmc


#10

I’ve sent you a link via PM. Since the file is a clip from a commercially available title, I thought it best not to post it here. If you’d prefer to receive another way, please let me know. I can also provide other clips if needed.


#11

Thanks, both. I’ve solved this and will get a test kernel into staging for you.


#12

Great to hear. Thank you very much. I look forward to testing the new kernel.


#13

It’s in staging now.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


#14

After installing this update I’ve thrown every 4K SDR file I have at it and all are now working perfectly. Many thanks grahamh. :slight_smile:


#15

Great to know ! I don’t have a 4k TV to test the kernel myself but I’m glad I could help


#16

Hmmm. I think you should also see a difference on a 1080 screen - it’s about the input resolution not the display resolution.


#17

When will this patch be added to the normal updates? I am getting an LG C8 next week, and wondering if I should apply this now or just wait until it is added.

I am not on the October update yet, so I can just leave as is for now.


#18

If you apply it now you will be able to help us get the bugs out of it for non-HDR screens (assuming yours is currently SDR). :wink: There were other improvements in the October release as well.

AFAICT from feedback so far, this patch hasn’t introduced any regressions to the October build.

I doubt you will see another stable release for a few weeks.


#19

More than willing to test. I installed the Oct update, but not the patch at this point. Tried a few 4k HDR files that I have (SDR tv), and everything seemed to play fine. AVR said it was sending 4:4:4 10 bit.

Anything specific you want me to test?


#20

It’s not 4K HDR that this patch fixes. It’s 4K SDR. So if you have any non-HDR 4K files then please test those.