September update killed plex on my Vero 4K+

Im not a tech newb or anything but am not really interested in playing around with config files and back end file transfers etc. I understand that is part of the hobby but is not something Im interested in.

So what is the easiest way for me to get some form of getting plex working again on my vero?

I never saw an unofficial version of plex on the repository? Is their one I can just download and install?

The caveat is I need plex to do 4k hdr at high bit rates. Its why I bought a vero.

Here is a bit easier way to fix the add-on. First though, this is NOT an official version of the Kodi add-on and no support will be provided for it. This is just a copy of the current Plex add-on with [this] patch applied by me. If that makes you nervous, feel free to make the changes yourself as I outlined in my previous posts on this topic.

First you can download the patched add-on in zip form here…

If your using Chrome and are having issues downloading that zip file on your PC you can right click on the download button that comes when you click the link and select the “save link as” option. Chrome will then show a scary message at the bottom of your browser saying it won’t download the file. Click the arrow and choose the “keep” option and then it will download. Chrome apparently really doesn’t like zip files.

Once you have downloaded that you will need to stick it on a thumb drive or some other location that you can access from within Kodi (you only need it when installing so feel free to just stick it the same location as your media files for easy access). You will then need to enable in Kodi settings>system>add-ons>unknown sources. Then go to settings>add-ons>install from zip file> and navigate to wherever you stored that file and select it. That should automatically update your current add-on and start working again.

8 Likes

Ok ill give that a try in the next few days, thanks for sharing

Thank you for going above and beyond @darwindesign

I’m sure it won’t just be OSMC users that benefit from this

5 Likes

Thanks so much @darwindesign! Installed with no problem - Plex is working fine now.

1 Like

@darwindesign : it did the trick ! Thank you so much !

1 Like

Thanks @darwindesign i’ll check this out later. If plex ever decide to update their add-on and they call it 0.3.4.1 i assume i can just revert the version number back to 0.3.4 and it will update to the official one? Otherwise if they call it 0.3.5 it’ll update fine?

Here I can confirm:

  • the same problem with the original Plex addon

  • Composite functionality remained intact

  • @darwindesign solution corrects the problem

Thank you @darwindesign for the link to a solution description and for the modified zip.

1 Like

Awesome that custom zip file worked,

Since I have in the past gone round and round with plex support for literally years about how bad their player was on Xbox which is what prompted me to buy a Vero 4k, could someone summarize what the actual issue is?

I’d like to hound plex support on their forums until they get this fixed. I was able to get them to make some progress on the Xbox plex version after working with their support for over a year and I’ll be happy to push them on an official fix for this. I just need a summary of the details of the issue and how to fix it so I can bug Plex support about it

1 Like

I did the procedure outline by @darwindesign. It worked, plex is working normally again.

1 Like

They won’t increment it to the third decimal place like I did as that is not standard. I did test (when I first posted instructions) to make sure that a 0.3.5 would update from my sticking an extra “.1” at the end of the current build and it worked fine.

So if a future Plex update break this we can just run the zip as is to fix it again?

The source code for the Plex add-on is on a site called GitHub that allows for people to submit bug reports and code changes. A community members some time back had run into this issue, figured out the problem, and submitted a code change to fix it. I linked to this above and in previous instructions. Plex accepted this fix which means that when the next build is released the fix will be included. The issue is that Plex has not released an updated build (which would allow you to just download a zip from GitHub) or put an updated version in the Kodi repository (so Kodi clients would automatically update).

If you bring up the information window for an add-on you will find options for reverting to previous versions and locking updates.

1 Like

Ideal. Thanks for the fix. I havent applied it yet, but as others have said it works im sure mine will too.

I have just installed your patch and can confirm it works.

Thanks very much

1 Like

I also had to install the patch to fix Plex, but now I have no sound in videos. GUI sounds are working, but nothing else. I’ve gone right through my settings to try and see what might have changed, but without success.

I’m going to try reverting to previous version of OSMC…

Why not start a forum post with some logs - we will be able to resolve your problem promptly I’m sure.

Rather than resorting to a clean install I would suggest to start a new thread that includes logs and information about what hardware your using. I really wouldn’t want to try to suss it out in this thread as I think it is unlikely that the issue is with the Plex add-on (this tweak doesn’t change how the add-on works vs. the unmodified add-on running under the previous build). There were also multiple people who have been running it from the test build for a couple months now without reporting issues. I would also suggest to put the same file your having issue with through Plex on a thumb drive or similar and try playback directly in Kodi.

What is the difference between PlexKodiConnect (which I’d never heard of) and the standard Plex app? I think I’m like some other people here and ONLY use the Vero for Plex and nothing else, so this would be important to me.

I don’t care if I’m using an official Plex or some other app as long as they work well.

Brian

PlexKodiConnect (sometimes seen abbreviated as PKC) is an add-on which adds your Plex content in a regular Kodi library. Thus you get the normal Kodi experience but with Plex as the backend source running hidden. This add-on is not found in Kodi’s repository as, from what I understand, it makes some lower level changes to Kodi that the Kodi devs are not supportive of. If you are interested in trying it I would suggest to do some reading first and make a backup of your Kodi settings.

The official Plex add-on (the one under discussion in this thread and is found in Kodi’s repo) is very similar to the Plex app you would find on other platforms, just a bit outdated at the moment (ie it doesn’t have some of the newer features like the new streaming service stuff).

There is also a “Plex for Kodi” beta that can be found on Plex’s forum which has a few versions but all of which are spun off from the official Plex add-on.

Composite is another Plex client that can be found in Kodi’s repo and it more of a basic directory tree type interface. It seems to function quite well from my limited testing.

2 Likes