September update killed plex on my Vero 4K+

I just made an account to come here to post this. My daughter updated by accident (I never update anything until a few months have passed and I have vetted the stability) and now my Plex is dead in the water. Ive had to fire up my old Roku. Ill keep reading to see if theres a fix or a way to roll back. I hate when this stuff happens.

LEGEND!!!

Just got my Plex working again, worked perfectly.
Thanks man.

1 Like

Thank you so much for the solution Darwindesign, it works perfectly for me.
Best regards

1 Like

I ran this last night on mine and insta-fix! Thank you so much!

It might be worth noting that for people like me that only really use the Vero4K+ via the PfK add-on like this, you need to set up traditional Kodi file share access before you can browse to get this from any network location. Using PfK does not require any manual Kodi share setup so many may have not ever done this. I had done that set up on mine already but some folks may not and it will be a bit more complicated to follow these steps. I don’t recall if there is a USB port or something on the Vero that this file could be put on but if so would that work as well?

1 Like

I just put the file on a USB drive and plugged it into the Vero, it has 2 usb ports, one for the remote dongle and one for storage.

I will say though the Sept update is a tad buggier in general then previous updates. I’ve had it hang up on HDMI-CEC and lock up a few random times for no reason so even if you take out this update breaking Plex it still seems buggier then going from Kodi 18 to Kodi 19. Hope future updates correct the bugginess and bring the vero back to near perfect operation.

It can be put on a thumb drive or SD card and when you browse for it you would navigate to root>media>[your mount name]>[zip file]

One could also just transfer it via the network to their home folder so for example in Windows you would open Explorer (Win Key+E) and in the address bar type in \\[IP address of player]\osmc and hit enter and then drag and drop the file into that window. In Kodi you would navigate to root>home folder>[zip file]

1 Like

As Sam said, thank you so much for going above and beyond to fix this issue. I truly appreciate it. Thank you for being such a kind user in this community and helping others out!

2 Likes