Serious problem with buffering, audio-video lag and video jump

I have OSMC installed on Raspberry Pi 3. And this problem occurs only with Netflix, not with YouTube. The video lags the audio by 4 to 5 seconds, it stops to buffer about once in 2-3 minutes. Usually buffering takes a few seconds, sometimes considerably longer. Often the video will jump forward after buffering.

The error log is https://paste.osmc.tv/kiqetiqosu

Its so pervasive that Netflix has become unwatchable. I first tried to clear the cache in Netflix settings. That fixes things only for a few seconds. Things go back to normal (bad) after that.

Initially I noticed that I was also getting errors while doing software updates. That was diagnosed as “gmc-18 has been deprecated for approaching a year since 18 became the stable build. Simply remove that line from your /etc/apt/sources.list”. I did the needful and was able to update kodi ad add-on’s successfully.

The buffering problem continues. Please help me fix that.

Thanks

Have you tried watching a 720p version instead of 1080? I don’t think that 1080 works well with Netflix.

Another thing to try would be to use a wired network instead of WiFi.

Also, you don’t have Adjust Refresh Rate set to the recommended Start/stop.

And finally, I’d suggest that you remove the banned repository and any addons you may have installed from it as they are known to cause problems.

1 Like

Thanks for your tips. I changed to the 720p version and that fixed everything. Wasn’t able to find the Adjust Refresh Rate. What is it and where do I find it?
Which banned repository are you talking of? is it the one used to install Netflix? If not that then what do I use to install Netflix?

Thanks a ton!

Settings/Player/Videos

You might need to turn up the settings level to Expert, I forget.

See here: [HOW-TO ALL PLATFORMS]Can I use Netflix on OSMC?(post 4)

Thank You, I used the same instructions to install Netflix. Which is the repository that is banned?

    <source>
        <name>TV</name>
        <path pathversion="1">http://fusion.tvaddons.co/</path>
        <allowsharing>true</allowsharing>
    </source>

I dont understand, how does this show its banned and what is repository name name “TV”?

Well, you are the one who added the repository, so only you know why you named it that.

As to why it’s banned, it’s a repository for pirating. For more information:

We cannot provide any support for piracy. You should seek support from the developer of the addon or provider of the repo.

To get a better idea of our piracy policy, please see this link here https://discourse.osmc.tv/faq#piracy

2 Likes

https://kodi.wiki/view/Official:Forum_rules/Banned_add-ons