Set time zone - Time wrong

Got Alpha 4 installed on my B+ and it’s up and running but displaying the wrong time. Is this something that is just not straightened out yet or am I missing something?

Time is changed when choosing right zone from international settings… go to settings

but i was wondering are all nordic keyboard settings there ?

I see no option for international settings listed under settings. Which menu are you seeing that in?

1 Like

Settings-Appearance-International

Sure you do… settings->Appearance

But i wonder for international keyboard layouts. nordic/finnish ? how to know its correct one ?

Found it. Thanks a lot.

That does not work.

Worked for me. You getting some error? You setting everything up right?

Yes, I did. I went into international settings and chose us and Chicago for time zone. I followed all directions on this post. (Any suggestions would be welcome). It is showing December 31, 1969 as date. I wish there was a place I could set the time manually! I have RASPMC on this before and the time was perfect. All my previous Kodi functions, Live TV, TV Shows, Movies all work flawlessly except for my schedules direct feature. I use Myth TV as a back end and that used to send schedules. I am hoping I can figure out why all of this worked in RASPMC and not int he new OSMC.

I don’t think the RPi has a hardware clock. It can’t keep its own time. Is it connected to the net?

Yes, of course.

I’venot had this as a persistent condition. You may need to look into the ntp servers set for you. ISTR an earlier thread on this topic.
Derek

Thanks for the response. ntp servers are fine because I use linux and my koi works well as does another raspberry pi (as far as time and date). The other raspberry pi has RASPMC on it. I am beginning to think I need to revert to that because nothing seems to work to change the date and time. Mine is now stuck on December 31, 1969. ISTR means what, by the way.

Please upload your system journal with the log uploader. If the ntp client is having trouble connecting it should be logged there.

Thanks, it said it went to:

http://paste.osmc.io/ lunipitove

I uploaded the system journal

Ok, I don’t see anything untoward in the system journal. Can you try the following - have a look at the configuration file /etc/ntp.conf, look for the line that says #statsdir /var/log/ntpstats/ - uncomment that line by removing the #, save and reboot. Then have a look at the contents of the file /var/log/ntpstats/peerstats. It should look something like this:

57148 34950.023 92.222.75.33 9044 0.000283667 0.027343162 7.937500742 0.000000954
57148 34951.012 91.121.90.6 9014 -0.000018964 0.016704547 7.937500662 0.000000954
57148 34952.022 92.222.75.33 9044 0.000189121 0.027183663 3.937508611 0.000094546
57148 34953.012 91.121.90.6 9014 0.000026103 0.016541885 3.937508491 0.000045067
57148 34954.022 92.222.75.33 9044 0.000200195 0.027198789 1.937516296 0.000059541
57148 34955.012 91.121.90.6 9014 -0.000114651 0.016407097 1.937516155 0.000120349
57148 34956.022 92.222.75.33 9044 0.000190064 0.027101481 0.937522013 0.000054360
57148 34957.012 91.121.90.6 9014 -0.000078548 0.016585359 0.937521863 0.000072585
57148 34959.012 91.121.90.6 9014 -0.000050020 0.016438875 0.437525654 0.000054199

Another thing you can try is changing which ntp servers are used. By default it uses the debian servers 0.debian.pool.ntp.org through to 4.debian.pool.ntp.org - however those map to different IP addresses and different physical servers depending on your location.

Try commenting out those four lines and adding

server pool.ntp.org

Or some other ntp server of your choice. See if that makes any difference. Almost certainly this is going to be a network issue between your device and the time servers.

Take particular note of section 9.8 here:

TroubleshootingNTP < Support < NTP.

ntpd makes its outgoing udp connections using a source port of 123 which not all firewalls will allow, while some other ntp clients use high source ports (>1024) for outgoing queries, which could explain why some other ntp clients might be working for you.

I Seem To Recall

Thanks. I will print this out. I am not very good with programming and will have to find someone who can make some sense of this. I am sure you are right. I am annoyed because the last version of RASPMC is installed on my kitchen Raspberry Pi and the time and date read perfectly. If this attempt to rewrite the files you suggest, I will reinstall raspmc and just give up. This is was too complicated for an average person to figure out, even with advance educational degrees.

I appreciate your frustration, however keep in mind that the number of OSMC users is in the 5 or 6 digit range and as far as I’m aware you’re only the second person on the forum to report problems with the ntp client not setting the time properly.

So the ntp client DOES work in the vast majority (99.9%) of cases, it’s not as if it just doesn’t work at all…something as obvious as the date and time being totally wrong on the home screen would be noticed and reported by a lot of people if it was a widespread issue. There will be something peculiar about your particular setup the is triggering the issue.

It could be something to do with your router (not allowing source port 123 to be used for example) or your ISP, or it could be that there are routing problems between your ISP and some of the debian time servers - there are many possibilities and to be honest it could be quite hard to track down with only one or two users reporting the problem.

Nobody is expecting OSMC users to have a degree to use it, we’re talking about trying to troubleshoot a very rare issue, in which case you’re helping us to help you by helping improve OSMC. (It’s still only a release candidate remember)

If you’re more comfortable using Raspbmc then that’s fine, just keep in mind that there aren’t going to be any more updates to Raspbmc, as OSMC is where all future development work is being focused on.

OSMC may still have a few minor issues at the moment and areas that are not quite finished, but sometimes starting fresh and building a new foundation from the ground up is the only way to move forward - much like moving house is a big hassle but the only true way to thoroughly clean a house and get rid of old junk! :smile:

Thanks for the kind words and you are correct. This version o OSMC is really wonderful. I just worry about the time and date thing and i know until I used RASPMC it was always an issue. I don’t know how I ever got along before but I am blessed guys like you are in there working on these wonderful programs. Keep up the great work. I will continue my quest to get this date and time issue resolved and let you know when it is fixed and what the problem is. i don’t think it is my IP because other versions are okay. It has to be something logical, as you say.