Setting up wifi EW-7811Un

i have a raspberry pi 2 and i’m not able to set up wifi with a Edimax EW-7811Un. lsusb shows this:

osmc@rasposmc:~$ lsusb
Bus 001 Device 005: ID 046d:c316 Logitech, Inc. HID-Compliant Keyboard
Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter
[Realtek RTL8188CUS]

i have found different threads regarding issues with wifi, but most of them are pretty old… to be honset: i don’t even know where i would configure wifi… most logical option would be gui > my osmc > network, but there i have only the options “wired” and “mysql”…

i have tried connmanctl (because i saw this on some 4 year old threads :slight_smile:) :

connmanctl> technologies
  Name = Wired
  Type = ethernet
  Powered = True
  Connected = True
  Tethering = False
connmanctl> enable wifi
Error wifi: Method "SetProperty" with signature "sv" on interface "net.connman.Technology" doesn't exist

connmanctl> scan wifi
Error /net/connman/technology/wifi: Method "Scan" with signature "" on interface "net.connman.Technology" doesn't exist

what am i missing?

Well you are missing a driver for the device.
Currently it is not supported. @sam_nazarko may introduce the driver in an upcoming update. See this thread

1 Like

sorry, i found many threads regarding this adapter but didn’t see that one…
so until this is solved i’ll stick with wired lan…