sFTP vs FTP speeds

I installed Setup vsFTPd on Debian/Ubuntu - Vultr.com hoping that FTP would be faster than sFTP. No luck.
Via iperf I get awesome speeds, but only 4-5 MB/s via FTP and sFTP.

Any clues as to why?

Thanks!

Have you installed the FTP Server from My OSMC -> App Store?

Sorry, sam - I just edited my question to qualify it.

Probably best to use the optimised vsftpd in the App Store

Fully purge the current version you have.

Also helps to know where you’re transferring files to?

Thanks Sam, done now - did not make a difference.
I a writing to a USB attached 7200 HDD.

I just tried upping directly to the /movie folder (ie. not to the USB) - same slow speeds.

Are you using a wired LAN connection or a wireless one?

It’s wired through a switch.

How is the disk formatted?

I think it is exfat

Also, I wanted to try via SMB, but I cant see the USB HDDs there.
I connect fine, but can only see the /movies, /music, /pictures & /TV shows. I did try to chown the media folders - no luck.

Can you select / ? Your drives should then be mounted in /media.

exFAT probably goes through FUSE so will slow things down.

Use ext4 if you can

No, I can’t seem to go up to /

OK, I generally go with exFAT to move drives from my Mac to other OS’s.

Ok, don’t let us mix things up. Samba is not the theme of this topic.

Just to be sure we have the same stand of information:

  • you activated FTP server from the MyOSMC store (other FTP servers are removed)
  • you login using user osmc/osmc using an FTP client
  • you see your drive’s directory under /media and can cd into it
  • if you there put a file, you only get 4-5 MB/s

Can you confirm this?

Yes, I can confirm that. I can also confirm that I get the same speeds if I ftp to the /movies dir (ie. not on the USB drive). I also tried both sFTP and regular FTP.
I CAN push it a bit higher if I transfer several files at the same time.

It’s no biggie, I can just set the transfers over night. But it is odd. I can transfer through the public internet faster than this.

Mmhhh , I just formated a USB 3.0 prendrive to exFAT:

I get 8.4 MB/s pushing data and 11.3 MB/s getting stuff from the Vero.
With ext4 filesystem on the stick I get full speed in both directions, as Sam predicted.

Can you SSH into the Vero and

  1. modify in /etc/vsftpd.conf line xferlog_enable=YES
  2. sudo systemctl restart vsftpd
  3. do a file transfer again
  4. upload the log using sudo paste-log /var/log/vsftpd.log and provide the return URL here
  5. upload mount information by sudo findmnt -A|paste-log and provide the URL here

Thx