Sickrage doesn’t start since the last update of OSMC

Hi Guys,

I’m running OSMC on a pi3 and Sickrage was working fine until last OSMC update. I’m not sure what causes it to stop but had no other change in my system other than the update.

When I type :
sudo service sickrage start

I get:
Job for sickrage.service failed because a timeout was exceeded.
See “systemctl status sickrage.service” and “journalctl -xe” for details.

24

And the journal:

Logs: https://paste.osmc.tv/ivazuyubon

Please help

From SSH, try running the same startup command as is run from /etc/systemd/system/sickrage.service. It’s on the ExecStart line. (You will probably need to logon as the sickrage user before running the command.)

Let us know what, if any, messages you see.

@dillthedog good one! If I run it manually it works.

What should I do to keep it running automatically?
Thanks for the quick reply

I see you ran it with sudo, so it looks like it might be a permissions problem, since I think it normally runs under the user sickrage. You need to check in /etc/systemd/system/sickrage.service to see if that is correct. I don’t have it installed, so I’m guessing a bit.

As I said last time, you should also try to logon as the sickrage user and run the same command. Alternatively you could try:

su -l sickrage -c "/opt/sickrage/SickBeard.py -q --daemon --nolaunch --datadir=/opt/sick"

I’m not sure that the datadir is really /opt/sick, so you’ll need to repeat in full the ExecStart command from the sickrage.service file.

Ok, found out what happened.

As of Oct 2018 Sickrage changed to the github to Sickchill:

And that caused it to stop working. I had to re install using the new address.
I’ve updated the code to help others install:

sudo useradd sickchill
sudo usermod -a -G osmc sickchill
cd /opt/
sudo git clone GitHub - SickChill/SickChill: Less rage, more chill. sickchill
sudo cp sickchill/runscripts/init.systemd /etc/systemd/system/sickchill.service
sudo chown -R sickchill:sickchill /opt/sickchill
sudo systemctl enable sickchill.service
sudo systemctl start sickchill.service

It would be a good idea to update the script on: How to install CouchPotato and SickChill on Raspberry Pi to reflect the new source.

Tks

1 Like

I’ve updated. Thank you for your links and changes :grinning: