Simply plugging in the Vero causes desktop PC to lose internet

Hi. New Vero 4K arrived today and while going through setup I noticed my PC had no internet connection. Turned off the Vero, still the same. Unplugged the Vero and was able to get PC back online. So it seems that just having the Vero on the network is enough to render my PC useless.

My PC uses a wifi adapter (USB style). The Vero is hardwired to the router. Does anyone know the cause and cure of this problem? If not, the Vero will have to go back…

Thank you.

Do I assume correctly that the Vero and your PC are configured to use DHCP to receive an IP address?

This is likely to be an IP conflict.

1 Like

Hi folks. I don’t know if the PC uses DHCP, how does one check?

My current media player is a Dune which had a static IP address. I’ve just gone into My OSMC/Network and ‘manually configure’ and gave the vero (the Dune had been 237). But the OSMC ‘status’ refuses to budge from ‘eth0 (No Internet)’. Does this info help us?

Depends on which OS you use.

Have you configure netmask, gateway and DNS server correctly?

Yes, same as the Dune had been:
255 255 255 0
192 168 1 1 (twice)

Well the message “No Internet” can have several reasons. I suggest you access the Vero via SSH on and then do some tests like:

I connected with PuTTY and was just about to hit ‘enter’ on that ping command when a box flashed up saying something like ‘software affecting connection’. If I can’t use my PC and the Vero simultaneously, I would seem to have an insurmountable problem…

Don’t trust this to be true. It’s not always accurate.

Something like doesn’t help. The exact wording is likely to be relevant and useful.

“Remote side unexpectedly closed network connection” (not the same as first mesage but same effect).

Prior to that, ping was generating lots of lines like this:
64 bytes from seq=7 ttl=120 time=40.146ms

In My OSMC, I tried searching for an Update (new device, there has to be one, right?) and on top right of my TV screen was ‘downloading update 0%’. It never moved from 0% so I have to believe my Vero is not connecting to the router. The ethernet cable can’t be faulty, it’s the one I had with the Dune.

Any further suggestions would be most welcome. Thank you.

Did you disable the SSH server in the MyOSMC app store? Or possibly choose not to enable it on first device startup?

If you have a Windows OS: press Windows key + R => type in: cmd [Enter] => type in: ipconfig /all
The result show you below the WLAN/Wi-Fi-Adapter section which IP address your PC has and if DHCP is activated or not.
As already mentioned it looks like an IP address conflict

After that please type in ping -t (see if you your router is reachable dont close the window and after that plug in your new Vero media-player and look if any error message occurs (e.g. duplicate IP address etc.)

Hi. SSH is definitely enabled. Thanks for that Ipconfig suggestion. It pinged away quite happily until I connected the Vero then changed to ‘Transmit failed. General failure’ as my PC lost internet. Actually, connecting the Vero deprives everything of the internet – smartphone and tablets all lose connectivity. But here’s the weirdest thing - unplugging the Vero from the router doesn’t allow you to reconnect. Neither does powering off the Vero. You have to switch it off at the wall.

Which suggests there’s a serious issue here – a device which, simply by being in standby, wipes out your internet! I do hope someone here can shed some light. Thanks to all for your time.

If you lose wifi its a router config issue pretty obvious. You could try factory resetting your router and let it set up again.

While there might possibly be some weird situation occurring, this is still most likely to be an IP address conflict, where two devices are using the same address.

So the obvious question is: have you tried another IP address? And if the first one doesn’t work, try a few more - and make sure they’re well spaced apart.

Wait. Before you “blame” the device, you must double check your network configuration For example if the new media player is configured for whatever reason as new default router i.e. all other devices lost the Internet connection. If you disable the Vero the local arp address table entry for the Vero devices is still there and known by the other devices e.g your PC ( = MAC address of VEro = the “wrong” MAC address)
To double-check this you can open a DOS shell with Windows key + R on your PC => type in : arp -a watch out the MAC address for your router then power on vero (your PC lost the internet connection and now please repeat the arp - a command and check/compare if the MAC address has been changed for your default gateway/router.

As an alternative: you can configure DHCP on router/PC/Vero etc. to avoid such network issuses

I’ve tried the Vero’s DHPC option and also the Manual option (using a couple of different IP addresses). Whatever option, Vero doesn’t connect to internet (downloading an Update buffers at 0%).

Both before and after connecting the Vero, my router’s MAC stayed the same.


For testing purposes only: Switch off the Dune. Please configure the Vero with the identical network config as the Dune player:
IP address:
network mask:
assuming your router has
After that take the Dune network cable and test the connection.

Thanks for your continued interest. The situation has changed - I plugged in my old router (glad I kept it) and the Vero and everything else works perfectly. The problem must therefore be with my current router (a Huawei HG633) so I’ve posted on my ISP’s support forum.

Good to hear . Greetings from Gelsenkirchen :wink: