Vero not connecting to network properly

Hi. My problem concerns connectivity. In a previous thread:

I thought I had it fixed by changing router but that soon proved false.

My PC has a USB wifi adapter and a DHCP IP assignment. When I add the Vero to my network there are 2 issues:

the Vero won’t connect to the internet (OSMC/Network says ‘eth0 (No Internet)’), and

my PC and other devices lose the internet.

I’ve given the Vero various manual IP addresses as well as an automatic one and have tried 3 different routers. There was a ‘eth0 (Connected)’ one time but it didn’t last.

My Dune player works fine with these numbers:

IP address = 192.168.1.237

Subnet Mask = 255.255.255.0

Default gateway = 192.168.1.1

DNS Server #1 = 192.168.1.1

For the Vero, I’ve used the same except for ‘237’ obviously. Why it won’t connect and stay connected I’ve no idea. Can anyone suggest what on earth is going on here? Thank you.

can we have a bit more information on the rest of your set up?

Any firewall rules?
standard ISP kit or your own?
usual vlans?

Hi NWGiles
Any firewall rules? - Normal Win10 firewall untouched by me
standard ISP kit or your own? - Standard
usual vlans? - Virtual LAN d’you mean? No, just normal LAN, I believe.

As you also seem to have problems to stable connect to the Vero via SSH my suggestion is to connect a USB keyboard to the Vero and access the local terminal to run some testing commands.
if you have that setup ready let us know and we talk you through the steps to do.

Sadly, not something I own.

Hi,

Still sounds like a duplicate IP to me, if you have smart phone android or iphone, you could could scan the network with fing to double check:

Tom.

Hi Tom and thanks for that. After plugging in the Vero, Fing reveals 2 new devices – the Vero and Generic/Amazon, both with a different IP. What would Generic be – the remote dongle maybe?

My other observations after using Fing with Vero connected:

Fing tells me ‘You’re not connected to the internet’.

It also tells me that the Vero ‘has multiple IP addresses’ (but doesn’t list them that I can see except for the main IP address e.g. 192.168.1.6).

If I give the Vero a manual address and then refresh Fing, Fing still shows the previous DHCP address.

If this gives anyone any clues, I’d be mighty chuffed.

Run on your windows machine arp -a after you pinged the two IP addresses you see for the Vero and post the output here.

Fing is now showing ‘Streaming Dongle/Amazon/Fire TV’ (I don’t have Fire TV) so I can only assume that aforementioned Generic/Amazon has been renamed. Must surely be to do with the Vero…

Also, Fing is now showing the manual address I’ve given to Vero. Ping results for you, fzinken:

Pinging 192.168.1.212 with 32 bytes of data: [212 is the address I gave the Vero]
Reply from 192.168.1.212: bytes=32 time=1ms TTL=64
Reply from 192.168.1.212: bytes=32 time=1ms TTL=64
Reply from 192.168.1.212: bytes=32 time=1ms TTL=64
Reply from 192.168.1.212: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.1.212:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Windows\System32>ping 192.168.1.8

Pinging 192.168.1.8 with 32 bytes of data: [this is the mysterious Amazon/Fire TV]
Request timed out.
Reply from 192.168.1.8: bytes=32 time=218ms TTL=64
Reply from 192.168.1.8: bytes=32 time=2ms TTL=64
Reply from 192.168.1.8: bytes=32 time=3ms TTL=64

Ping statistics for 192.168.1.8:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 2ms, Maximum = 218ms, Average = 74ms

C:\Windows\System32>arp -a

Interface: 192.168.1.5 — 0x6
Internet Address Physical Address Type
192.168.1.1 dc-d9-16-c6-fc-0d dynamic ROUTER
192.168.1.2 00-16-e8-75-56-87 dynamic AUDIO PLAYER
192.168.1.4 40-88-05-2d-b3-7d dynamic SMARTPHONE
192.168.1.8 4c-ef-c0-26-b8-53 dynamic AMAZON FIRE TV
192.168.1.212 90-0e-b3-03-b9-9a dynamic VERO (SHOULD IT NOT SAY STATIC???)
192.168.1.237 14-c0-89-14-15-57 dynamic OTHER MEDIA PLAYER
192.168.1.255 ff-ff-ff-ff-ff-ff static DON’T KNOW, NOT ON FING
224.0.0.2 01-00-5e-00-00-02 static
224.0.0.22 01-00-5e-00-00-16 static
224.0.0.251 01-00-5e-00-00-fb static
224.0.0.252 01-00-5e-00-00-fc static
239.255.255.250 01-00-5e-7f-ff-fa static
255.255.255.255 ff-ff-ff-ff-ff-ff static

That’s definitely not the Vero
https://aruljohn.com/mac/4CEFC026B853

So you must have a Amazon device in your network!

The Vero MAC should be 90-0e-b3-03-b9-9a so that all looks fine.
So can you now connect to 192.168.1.212 via ssh stable?

You’re right - I forgot about the Kindle used by Mrs Dortmunder!

PuTTY/osmc/osmc gives me a command line style screen but I don’t know what to do with it…

Well that is good if you stable can connect to it we can start the trouble shooting. Execute these commands and provide the URLs
ip addr | paste-log
ip ro | paste-log
ping -c 4 192.168.1.1 | paste-log
ping -c 4 8.8.8.8 | paste-log
ping -c 4 www.google.com | paste-log

This is getting ridiculous. Tem minutes ago I logged into PuTTY with osmc/osmc easily. Now, I can only input the first ‘osmc’. It then asks for the password but my keystrokes have no effect. Does that tell you anything? If not, I’ll try again later as I have to go now. Thank you so much for your efforts to help.

Yes they do. For security purposes there is no echo of any input keys in the password field.

Well, up to now, both my typings of ‘osmc’ appeared onscreen and, after the 2nd one, some blurb would appear. At that last attempt, the cursor wouldn’t move when I tried to input the password.

Typing in the password without any onscreen text should be normal. Haven’t seen it any other way before.

Just type in osmc again after the username and press enter. Should work.

Sadly, I can’t run those commands, fzinken. Although I can log into PuTTY, commands cannot be run due to the disconnected internet.

Out of curiosity, I disabled my firewall but that didn’t help. I’ve found another user with the same problem:

but there’s no mention of him ever fixing it and he’s no longer active so I can’t ask him.

It looks like I’m running out of options…

Ok, my bad. Just run them without paste-log and copy paste your putty output here.
ip addr
ip ro
ping -c 4 192.168.1.1
ping -c 4 8.8.8.8
ping -c 4 www.google.com

Here they are:

osmc@vero:~$ ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 4096 qdisc noqueue state UNKNOWN group default

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

inet 127.0.0.1/8 scope host lo

valid_lft forever preferred_lft forever

inet6 ::1/128 scope host

valid_lft forever preferred_lft forever

2: eth0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

link/ether 90:0e:b3:03:b9:9a brd ff:ff:ff:ff:ff:ff

inet 192.168.1.222/24 brd 192.168.1.255 scope global eth0

valid_lft forever preferred_lft forever

3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000

link/ether cc:4b:73:6d:f0:62 brd ff:ff:ff:ff:ff:ff

……

osmc@vero:~$ ip ro

default via 192.168.1.1 dev eth0

192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.222

192.168.1.1 dev eth0 scope link

……

osmc@vero:~$ ping -c 4 192.168.1.1

PING 192.168.1.1 (192.168.1.1): 56 data bytes

64 bytes from 192.168.1.1: seq=0 ttl=64 time=1.095 ms

64 bytes from 192.168.1.1: seq=1 ttl=64 time=0.943 ms

64 bytes from 192.168.1.1: seq=2 ttl=64 time=0.918 ms

64 bytes from 192.168.1.1: seq=3 ttl=64 time=0.846 ms

— 192.168.1.1 ping statistics —

4 packets transmitted, 4 packets received, 0% packet loss

round-trip min/avg/max = 0.846/0.950/1.095 ms

……

osmc@vero:~$ ping -c 4 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes

— 8.8.8.8 ping statistics —

4 packets transmitted, 0 packets received, 100% packet loss

……

osmc@vero:~$ ping -c 4 www.google.com

ping: bad address ‘www.google.com

Ok, from a LAN perspective all looks OK. Now we need to dig further:

  1. First what’s the output of ipconfig /all on your Windows machine?
  2. Do you have any Webfrontend to configure your router?