Vero not connecting to network properly

I’ve omitted some ‘Media disconnected’ items (Ethernet adapters x2 and Wireless LAN adapters x2):

Windows IP Configuration

Host Name . . . . . . . . . . . . : xxxx

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

DNS Suffix Search List. . . . . . : lan

Wireless LAN adapter WiFi:

Connection-specific DNS Suffix . : lan
Description . . . . . . . . . . . : 150Mbps Wireless 802.11bgn Nano USB Adapter
Physical Address. . . . . . . . . : 74-DA-38-8B-AB-D0
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : fddc:d916:c6fc:d00:448:9ff8:632:2a19(Preferred)
Temporary IPv6 Address. . . . . . : fddc:d916:c6fc:d00:2973:f10d:e24c:2ea0(Preferred)
Link-local IPv6 Address . . . . . : fe80::448:9ff8:632:2a19%6(Preferred)
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Lease Obtained. . . . . . . . . . : 01 May 2019 07:05:53
Lease Expires . . . . . . . . . . : 02 May 2019 07:06:10
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 427088440
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-22-37-CE-E9-10-C3-7B-4C-8B-DC
DNS Servers . . . . . . . . . . . : fe80::1%6
NetBIOS over Tcpip. . . . . . . . : Enabled

I can play with the router settings by putting into my browser.

Ok, there must be something on your router that blocks the Vero from going to the internet. If you share some of the screens from your router config we might be able to help

While looking at your windows config it would be interesting to know if your windows machine still can reach internet when you disable IPv6.

is there another router into your network? cause DNS servers within ipconfig output are the same as default gateway, are there no other DNS servers from your ISP? within my router i can select to use ISP DNS


can you disable ipv6 on router? i’ve seen strange things when ipv6 was on on router when within network no use is for ipv6

Disabling IPv6 on my PC has no adverse affect - I can still access websites. I’ll cap some router screens later (short of time just now) - anything in particular you’d like to see?

Hi mtv. My router has and as Primary and Secondary DNS server which I believe are those of my ISP. I tried using them when allocating an IP address to the Vero but it still wouldn’t connect. Although the router uses, my Dune player works perfectly as follows:

IP address = (or any high number)

Subnet Mask =

Default gateway =

DNS Server #1 =

As regards IPv6, my router is on IPv4. As you can see, you don’t disable IPv6 but you can ENable it.

What Huawei router is it? It clearly blocks ipv4 and denies DNS. From the logic it must be some security settings on the router which prevent this client to be able to access the internet.

The strange thing seems to be that you got an IpV6 address, while it doesn’t seem to be on into your router (as you confirm).

I’ve a win10 laptop with ipv6 but not configured on router, just as an example:


no Ipv6 address has been given, It’s not pointing to something but it seems there is something odd in there, when you’ve got an dhcp v6 address.

the dns address you mention can’t be reached from my end but that could be ISP related.

you’ve wired the vero direct to the router?

As @mtv mentioned it would be strange that your Windows machine get’s a IPv6 address, could there be another device giving out IP’s?
The other point your windows machine is connected via WIFI, have you tried to connect the Vero via wifi as a test?

Possibly IPv6 stateless autoconfiguration happening here.

As far as I understand stateless autoconfiguration the IPv6 address would include part of the MAC address which is not the case here.

As regards IPv6, I googled it and managed to completely disable it via Powershell as you can see in the picture.

Sadly, the Vero still refuses to connect. I tried My OSMC/Network/Wireless and enabled the adapter. The name of my ISP appeared with a pink dot, blue dot and 4 white dots but I didn’t get a connection. (Does the Vero let you connect wirelessly without plugging in a dongle?)

I’ll get some route caps later as I have to go now. Thanks to you all!!

Yes, the Vero has built in wireless adapter. Did you connect to your WiFi with the correct passphrase?

I don’t use Windows 10 but I thought that the privacy extensions for stateless autoconfiguration were already in Windows. This is mentioned on Wikipedia: IPv6 - Wikipedia.

Oops… just realised that you have to ‘right arrow’ to the ISP name in order to input the wifi password. I’ve connected wirelessly to 2 routers (Huawei HG633 and DLINK3782) but ‘no internet’ in both cases, sadly.

I’m looking at my router’s settings and apparently I have 14 devices on the network which is way too many. There’s an option beside each to ‘Remove from network’ but should I do that when it’s not easy to tell which device is which?

Here are some other router settings in the hope that it gives someone a clue as to my problem. My continued thanks…

So do you actually have 2 routers operating on your network?

which router is the DHCP server?
and on which router is the vero connected (wired) and which router is the "master"ssid sending?
why is 14 devices way too many to have internet access? Normally it would be an issue to have less bandwith, but no internet is odd.

I have a spare, only one router used at a time.

Just a thought – if Vero doesn’t work on multiple routers then probably router itself is not to blame. But could ISP detect if a device is capable of running Kodi and block it for that reason?

I’m sure you don’t have both routers in the same network (, haven’t you?

Both routers can be configured for parental/access controlling, the HG633 has a hidden menu for this (use google). That’s what I would check at first.

But you are the only person experiencing this issue. It’s virtually certain that this is an issue with your network. We still want to help you resolve this though.

Highly unlikely.

To avoid confusion, I’ll work with one router, the HG633. I looked at the hidden parental control menu but there are no ‘rules’ set so the problem isn’t with that, I’d say.

Forget what I said about 14 devices, I’ve just noticed it’s a list of active AND inactive devices.

To recap, I’ve completely disabled IPv6 on my PC and router. I’ve connected the Vero to the router via Ethernet and wireless, using DHCP and manual IP addresses – a connection is made but neither the Vero nor my other devices can then get to the internet.

Again, my thanks for al the offers of help.

Last idea: Can you check on the Vero at main menu ->MyOSMC->network->tethering that thethering is disabled?

1 Like