Skin is broken after each reboot since July update

Continuing the discussion from Skin regularly reverts to OSMC standard skin after reboots by itself since last update on my Vero… :frowning::

Not sure what you mean by template.

Please give an exact description of your problems and logs, and we can help


Hey @sam_nazarko
l use Bello template.
After each reboot, I can see a “help” popup, empty with an ok button.
If I click on ok, this popup disappears but there is no menu, nothing.
I need to use my ios remote app to send a command to change the template.
Template changes. I answer no to the question : “keep this change?”
Bello reloads and looks good… until the next reboot.
(sometimes theme goes back to osmc after reboot instead of broken bello…)

Here is some logs :

Thanks for your help.

Still there after September update…

I’m not sure what issue you’re referring to here


My post just above.

Rather than ‘template’ the word you are looking for is ‘skin’.

Bello only has beta support for Helix and no support for Isengard as far as i can see. This appears to be more of a skin issue than an OS/Kodi issue so you will likely need ot take this up with the skin developer.

Ok thanks !

I’m having a similar problem, but it is with multiple skins.
i run 4 profiles, each setup with a particular skin.
the master is running on metropolis. the others are quartz, amber and aeon nox.
here are some observations:

  1. Fresh boot: if i log in to ANY of the profiles besides the master, the skin is reverted to metropolis (or whatever skin the master account is using). if i attempt to log off at this point, the system crashes. I go to the appearance settings but it still says has the set skin selected (eg theme is “metropolis” but it says “quartz” or “amber”) in appearance. in order to switch the skin properly, i have to select metropolis (master skin) first so that i will be prompted with the question “do you want to use this skin?”. any attempt to select a different skin will just change the label but not apply.
  1. I log in to the master user. all seems well, but i do notice some menu items missing - ive tried it with amber and metropolis - “recent” is missing, some menu items in the settings are blank and it only all goes ok if i re-select the skin in appearance settings.
    if i attempt to log off, all is ok and no bugs seem apparent, and the other profiles load nicely.
  2. This does not happen in the windows and osx versions.
  3. This problem started with the august update.
    i am running raspberry pi + usb install + mysql server + ftp shares. network is via wired connection.

Thanks in advance and i hope i gave you an idea on what may be causing this.

tried re-installing, but functionality is still broken.

i’ve temporarily worked around this by using auto-login, but log-off aint working (crash) so i have to switch default profiles via settings then reboot.

There are two reasons you are getting no response here. First, you’ve hijacked a completely unrelated thread. Second, you’ve provided zero diagnostic information to work with.

well, i shouldve started a new thread then, after browsing through the threads and finding the closest resemblance to the bugs i’m getting. though i suspect a faulty add-on (which most likely came with one of the skins i’m installing), and i’ll probably check the logs when i find time, and post em if i remember to do so (im as lazy as %^*#). till then, i’ll just have to live with it, since its always better than switching to openelec or xbian :slight_smile:

So no real solution yet.
I just switched to this skin. It’s a fork of Bello.

Thanks for the info, man.
Im currently on auto-login mode to prevent the “missing shortcuts” bug. I noticed that the available options are those of the default osmc skin (eg no “recently added” but “genres”, “years” are available). Please confirm if you observe the same behavior. The log, unfortunately, does not show the part when it reads the skin settings, so i cant tell which skin config file is loaded (or i havent found it yet)
I read the log file further, it seems whenever you log off straightaway after logging in, osmc will have to force close libraryprovider and artworkdownloader, which results in a crash, which is entirely recoverable if you wait around 30 seconds for osmc to get back on its feet. this does not happen if you play a file first, stop it, then log off. Really weird if you ask me.
anyway, as long as there is a workaround, its still usable. still great software, keep on truckin, osmc :slight_smile:

resolved! Profile problem with 2015.09 - 2 - #34 by Yaffle