Skin regularly reverts to OSMC standard skin after reboots

This has been reported for Vero but it’s happening also for some other platforms like rpi1 as in my case.

I’ve already reported the bug to skinshortcuts addon as it seems related to it. After some back and forth it looks like the cause might be a combination of issues in OSMC and the script.

To be clear, as the skin shortcuts contributor who has responded to the issue linked above, this appears to be entirely an OSMC issue - for whatever reason skins (in this case Maximinimalism - a skin which doesn’t utilise skin shortcuts) aren’t being loaded on restart/profile change, and instead the default OSMC skin is being loaded. As this skin does use skin shortcuts, but Kodi is reporting to the script that a different skin is selected, the script is getting confused about which skin it should be writing the menu for, resulting in the error reported in the link posted above.

In summary, something appears to be going wrong with OSMC which is causing it not to load the skin the user has specified.

However, I’ve left the skin-shortcuts issue open for the moment, just in case I’m mis-interpreting what’s happening. And, if it is a skin-shortcuts-specific issue, contact me on GitHub and we’ll see what we can do to fix it :slight_smile:

(Sorry, I should have said entirely an OMSC or user issue - I don’t want to emphasise that this is necessarily an OSMC issue, just that - from my perspective - it doesn’t seem to be a skin shortcuts issue, as it initially appeared)

The issue on the vero is resolved as far as anyone had told us.

If you dont shut down the pi correctly then the guisettings won’t necessarily be saved properly. Corrupt that file and the system will use defaults.

So that is the very first thing that needs to be checked.

Full debug logs are also needed.

I always shutdown the pi properly and there seem to be no error during the process. I’ll attach a debug log in any case.

This is the sequence of events that happened during the first run (kodi.old.log):

  1. Start OSMC, log in one of the 4 profiles I have
  2. The skin shown is OSMC’s default
  3. Go to Settings-Appearance-Skin and change it to another one (Conq in this case)
  4. Wait till the theme is fully loaded
  5. Shutdown the system using the UI

The second log (kodi.log) is the one generated when I restarted OSMC after shutting down the system

  1. Start OSMC, log in the same user profile as the one I used before
  2. The skin shown is OSMC’s default
  3. After some time a notification is shown with the following text
    “Skin Shortcuts. Creating menu…” and after some time “Skin Shortcuts. Writing menu…”
  4. Then the skin I had selected in the previous run (Conq) is properly loaded.

Just tell me if you need anything else. I’m looking forward to having this fixed as it’s a really annoying issue. Thanks for taking a look!

Please do not jeopardize this thread. It’s a good idea to create a new one for your issue. Thanks.

Have you seen this Kodi issue?

Well I don’t see the “Help on First Start” but the bug described in the last comment is perhaps the cause of the bad behavior I’m seeing. Unfortunately seems that there is no activity since 5 weeks ago…

BTW I’ve tried Kodi (just it, no OSMC involved) on a amd64 machine (version 15.2-RC3) and the skins are working perfectly when switching between users. Well there is this thing about the login screen getting the skin of the latest logged in user but that’s not what is important here.

So I’d say it’s either an OSMC issue or a platform issue (it does not work for me on a Raspberry Pi 1).