Slow wifi with Edimax ew-7811Un (Raspberry Pi 2)

I have the wifi adaptor mentioned in the title, and it’s incredibly slow – too slow to play any videos over the network. I tried the same adaptor in a Windows machine and it’s perfectly fine there (confirmed by comparing it with the built-in wifi on that machine - both adaptors get ~5MB/s transfer speed over the network). I also tried an Asus wifi adaptor on the pi, and it worked great (I got the Edimax one because it’s much smaller).

I’m connecting to a Netgear R8000 router.

Any ideas here? I searched and saw some people having issues with this adaptor dropping connections, but those issues seem to have been sorted out a couple releases ago.


What version of OSMC are you on?


I have 2 of these adapters with no issues, make sure your wifi network is using WPA2+AES for best speeds.

Wow thanks for the quick replies guys!

I am on RC3, update utility shows that I am up-to-date.

My wifi network is using WPA2-PSK [AES] for its wireless security.

I’m about 7 feet from the router, which has awesome range, so I don’t think that’s the issue (especially since my ancient Asus adaptor works great on it).

A little more info:
I tried doing a wget with both adapters. The Edimax one only gets about 50KB/s, whereas the Asus one gets ~5MB/s (I get about 5MB/s with the Edimax one on a windows machine).

According to wavemon, the Edimax adapter actually has better signal strength than the Asus adapter.

I’m stumped. :frowning:

Some logs may help us see the issue


Sure, which ones should I look at?

Hopefully these are what you were looking for. I dumped/uploaded all the logs using the utility in OSMC:

Thanks again :slight_smile:

I have built several media boxes over the years, and every one that uses a wifi adapter, uses the Edimax EW-7811UN. They all work well, even when viewing a live stream.

Thanks for the reply - yeah I’ve read good things about it being used in the Raspberry Pi, which is why I chose it. I thought maybe mine was defective, until I tried it in a Windows box and it was just as fast as I would expect it to be. :\

One of my adaptors that I test is an Edimax EW-7811UTC which I think is the same chipset in a different form factor, and I have noticed reliability issues with it in OSMC. It certainly doesn’t perform as well as one of my other adaptors, especially on 2.4Ghz, and I have had intermittent connectivity problems with it.

One suggestion for the discrepancy in speed between what you see in OSMC and windows, is I notice that the log says it connected on 2.4Ghz, while as far as I know it’s a dual band adaptor. (Mine is) It’s possible that if you have a dual band network with the same SSID on both bands that the Windows driver is favouring connecting on 5Ghz while the Linux driver is favouring 2.4Ghz.

If it is indeed a dual band dongle and your router is also dual band, can you try enabling separate SSID’s for 2.4Ghz and 5Ghz and forcing the adaptor connect on 5Ghz on OSMC ? (By connecting to the 5Ghz only SSID)

Thanks for the reply. My router is set up with separate SSIDs for 5GHz vs 2.4, so I’m certain my windows box and the pi were on the same 2.4GHz network when I was testing. :confused:

I only see the 2.4GHz network in OSMC so I don’t believe my adapter is dual-band.

I also just tried using a different power adaptor, as well as a powered usb hub, same results.

I have that adaptor and I can confirm that it doesn’t support 5Ghz. It only supports b/g/n 2.4Ghz.

The chipset is: Realtek RTL8188CUS.

Well, I got one of these, and the speed issues have gone away (even though they are the same chipset, as far as I can tell):

I’d say the other one was just a dud, but it worked fine in a windows box. Oh well, good thing they are cheap. :slight_smile:

I was struggling with this same adaptor last night, on another Pi running Ubuntu. Everything was set-up, connected, but the connection would drop, even though power management was off.
I used the very same device with my Pi1 and it worked perfectly.

After much Googling I tried a tip from the ether: I changed the wireless mode on my Router to ‘g’ only. and the problem went away. My network can’t reach ‘g’ speeds anyway.

Maybe a driver issue? Worth a punt perhaps.?

I have been having this issue too. I enabled added max_usb_current=1 to /boot/config.txt, and that has seemed to help a little. Before doing that, my connection would drop all of the time, and I would have to reboot. Now I have the below speeds.

osmc@osmc:~$ speedtest-cli
Retrieving configuration...
Retrieving server list...
Testing from WideOpenWest (
Selecting best server based on latency...
Hosted by Imagine Networks (Troy, OH) [107.95 km]: 117.639 ms
Testing download speed........................................
Download: 0.69 Mbits/s
Testing upload speed..................................................
Upload: 1.51 Mbits/s

I have a 100 Mbps down and 10 Mbps up.

I’m curious if @wermy or anyone else is still having problems with this adapter. I’m about to buy another Pi and it will be in a place that I can’t easily drop a network cable. I don’t own any usb wireless adapters to test with.

Unless someone else wants to recommend a better adapter? My router is 802.11n.


I don’t want to open a new topic because I have exactly the same issue, with a raspberry 1…
Here’s my speed test :

Retrieving configuration... Retrieving server list... Testing from Orange ()... Selecting best server based on latency... Hosted by SFR (Paris) [15.00 km]: 52.019 ms Testing download speed........................................ Download: 0.80 Mbit/s Testing upload speed.................................................. Upload: 1.13 Mbit/s

With a wired connection :

Retrieving configuration... Retrieving server list... Testing from Orange ()... Selecting best server based on latency... Hosted by Orange (Paris) [15.00 km]: 5.499 ms Testing download speed........................................ Download: 89.28 Mbit/s Testing upload speed.................................................. Upload: 87.58 Mbit/s

Anyone knows why ?

PS : I’m using the Edimax EW-7811UN dongle

Check your wifi strength with wavemon

sudo apt-get install wavemon

Here’s what y get :

wlan0 (IEEE 802.11bgn), ESSID: "", nick: "" │link quality: 96% (96/100) │signal level: 17 dBm (47,00 mW) │RX: 16 426 (10,13 MiB), invalid: 0 nwid, 0 crypt, 0 frag, 0 misc │TX: 12 831 (7,40 MiB), mac retries: 0, missed beacons: 0 mode: Managed, access point: 18:62:2C:88:B9:22, sensitivity: 0/0 │ │freq: 2,462 GHz, bitrate: 72,2 Mbit/s │ │power mgt: off │ │retry: off, RTS/cts: off, Frag: off │ │encryption: n/a (requires CAP_NET_ADMIN permissions) │ │wlan0 (UP RUNNING DYNAMIC BROADCAST MULTICAST) │ │mac: 74:DA:38:1A:B7:2C, qlen: 1000 │ │ip: