SMB connection issue after June update

Does this only happen with some files?

Yes, I’m currently looking for a pattern :wink:

Which version of SMB are you using on your NAS? I seem to recall this problem only affecting SMBv2.

I know what’s causing this issue and can push a fix, but it then breaks WMA playback. So I want to get a bit more information before making any changes.

The NAS is configured to support both SMB v1 and v2.
Kodi is using v2 according to a tcpdump trace.
Two files from the same show (same codecs) are behaving differently.

Here the end of the tshark trace :

75 0.058055 192.168.111.4 → 192.168.111.253 SMB2 183 Read Request Len:65536 Off:393216 File: Tv\XXX.mkv
77 0.058985 192.168.111.4 → 192.168.111.253 SMB2 183 Read Request Len:65536 Off:458752 File: Tv\XXX.mkv
78 0.059644 192.168.111.253 → 192.168.111.4 SMB2 28038 Read Response
84 0.061276 192.168.111.253 → 192.168.111.4 SMB2 23694 Read Response
86 0.062247 192.168.111.4 → 192.168.111.253 SMB2 183 Read Request Len:65536 Off:524288 File: Tv\XXX.mkv
88 0.063166 192.168.111.4 → 192.168.111.253 SMB2 183 Read Request Len:65536 Off:589824 File: Tv\XXX.mkv
89 0.063804 192.168.111.253 → 192.168.111.4 SMB2 22246 Read Response
93 0.064569 192.168.111.253 → 192.168.111.4 SMB2 43966 Read Response
95 0.065389 192.168.111.4 → 192.168.111.253 SMB2 183 Read Request Len:65536 Off:1518230551 File: Tv\XXX.mkv
97 0.066321 192.168.111.4 → 192.168.111.253 SMB2 183 Read Request Len:65536 Off:1518296087 File: Tv\XXX.mkv
98 0.066930 192.168.111.253 → 192.168.111.4 SMB2 16454 Read Response
104 0.067731 192.168.111.253 → 192.168.111.4 SMB2 13558 Read Response
106 0.068563 192.168.111.4 → 192.168.111.253 SMB2 183 Read Request Len:65536 Off:1518361623 File: Tv\XXX.mkv
107 0.069198 192.168.111.253 → 192.168.111.4 SMB2 143 Read Response, Error: STATUS_END_OF_FILE
108 0.069245 192.168.111.4 → 192.168.111.253 SMB2 183 Read Request Len:65536 Off:1518427159 File: Tv\XXX.mkv
109 0.069843 192.168.111.253 → 192.168.111.4 SMB2 143 Read Response, Error: STATUS_END_OF_FILE
110 0.069926 192.168.111.4 → 192.168.111.253 SMB2 300 Read Request Len:65536 Off:720896 File: Tv\XXX.mkv

Does your NAS support SMBv3?
Can we get a trace of that?

Hi @stevanazzi and @j.davids ,

could you check whether you specify the smb versions on Vero and Syno like shown below?

Running NFS fine on Synology DS416J. The xxx16j has SMB3 so try switching both to SMB if you dont use NFS. NFS is faster.

Hi, with v3, it works fine. Thanks for the tip.

1 Like

Now that I can finally respond again, the solution by JimKnopf worked wonderfully.

Thanks to everyone who tried to help.

@stevanazzi, @j.davids: Could you tell what DSM version is running on your Synology NAS? You find that data at the Synology’s Control Panel->Info Center->General.

Here it’s a small DS214se with DSM 6.2.3-25426.

I’m hoping to fix the issue for SMBv2 users tomorrow.

No clue what DSM version I was running before as I updated while troubleshooting but I am currently running 6.2.3-25426

And you’ve had the issue also with 6.2.3-25426?

Hi @JimKnopf,
It’s a DS218j with DSM 6.2.2-24922 Update 4.

I’m ready to upgrade to DSM 6.2.3-25426 but didn’t want to do concurrent upgrades while debugging.

Could you tell us later after upgrade to DSM 6.2.3-25426 whether you can reproduce this issue with the original settings (max. smbv2 on both devices)? Thx in advance.

:man_facepalming: forgot to mention that part… Yes.

Hi,
the issue is still present with DSM 6.2.3-25426 and SMBv2.
All ok with SMBv3

I’m having the same issue with a Synology NAS and Vero 4K, using SMB v2. Since I’m not in a hurry I will wait for the fix.

Or should one generally have SMB3 enabled? I wonder why it’s not by default?

It’s surely recommended for performance and security.

I can confirm that enabling SMB v3 on Synology NAS fixed the issue.