SMB Shares - Cannot Browse After Update

Just to add to the thread - seeing the same problem with username/password being rejected for smb shares on my Asus RT-AC68U.

It sounds like you have the Password Required issue aka “Lock Preferences for smb:” error. Have you tried the instructions I posted above?

Ah, sorry, I should have been more specific - I have the password rejection issue trying to connct to a share on my Asus router which is Unix based.

James_SS, I am having the same issue. Kodi is unable to locate SMB shares on 2 OSMC pi 2 with most recent April _2 update. My media is shared on a Unix-based ASUS router with NAS capability for SMB. A user and password are set. However, Kodi asks for username and password and does not accept the correct user and password. A third pi running an up-to-date version of Raspian Stretch is able to access the media.

I assume this isn’t running Kodi with upstream libsmbclient (which is the real issue), or hasn’t been updated in the last four days.

Still working on it, not much progress so far. I have been working on this for the past three days (it’s about to approach 3AM again).

1 Like

You’re correct. The pi that can access the smb shares is not running Kodi.

Hi boys… i’m newest here and i have found this thread by google and i have obtain this similar problems on my Pi2:
On my Windows 7 X64 i have some sharing folder (i thinks using SMB right) and from “Advanced Sharing” i have gave “Full Access” for “Everyone”.
This is working for a lot of time… i ever used my shared folder on my OSMC installation but from recent upgrade i thinks i have obtain this problems and now osmc ask a password for access to my SMB sharing folder.

On Windows 7 i have disabled the “Sharing by Password” option but no help and osmc continue to ask for a password also it’s not set on windows :slight_smile:

I have read here the possibly “Workaroung” by @Phoenix (here → SMB Shares - Cannot Browse After Update - #44 by Phoenix) but i have some question:

  1. from promt of dos “net user osmc osmc /add” create a new account on my Windows 7… but i force to use “osmc” or i can use somethings like “ShareIT” or ever i can use ?

  2. After that… i thinks i need to add this user to sharing folder option right ? Or i can leave all permission to “Everyone” ever i use it ?

Can’t work this one out, sorry chaps.

I’ve spent a few days on this and have exhausted possible fixes from our side. I contacted a Samba maintainer as well as the Debian Samba Maintainers List and they have acknowledged some regressions. We may have to wait for them to fix this upstream. Hopefully this will be addressed by them in the next couple of weeks.

I’m unable to produce an old libsmbclient that doesn’t crash via Kodi, and new versions have moved to a new build system, ‘waf’. The migration for this seems half complete, so it’s not trivial (to a non Samba developer) how to build just libsmbclient for Debian and doesn’t build reliably on all OSMC systems.

We simply must wait.

Thanks for the effort and careful diagnosis. It helps a great deal to know where the problem lies. will freeze updates on the machines that still work and survive. Staggering updates strategy does work.

  1. You can use a login and password what you want. This is only example.
  2. Someone on forum wrote that “everyone” include all accounts, so should work without change, but in case you can add it.

Sorry if this is a dumb question, but can we just reinstall a previous build? Where would I go for that? Or do we really have to wait?

Actually the current image available at which also would be choosen by the installer would not have that problem until you upgrade.

Thank you. I’ll tweak on this a little more tonight, then likely just reinstall and wait until the all is clear to update. Is there anything I’ll really lose in reinstalling, besides my Kodi preferences and add-ons? I run a fairly vanilla Kodi on the Pi2.

If we’ve already upgraded, is there a way to revert the SMB upgrade without resorting to full reinstall of OSMC?

No as the packages are not available in the repository anymore, currently the only quick and dirty way is using an old image.

Can you guys revert all users to previous build that worked with an update

No – this isn’t possible I’m afraid, as the update was pushed upstream by Debian, not us. We’ll have to wait for the Debian Samba maintainers to either fix the issue or provide guidance on how to restore the old functionality. They hope to get a new release out in a few weeks.

Ad said by fzinken the only "dirty"way is to format your sd and the reinstall using an old image.

I’ve done this way.

Remember to do a full backup on a usb stick!

Then magically (after the backup restored on the old image) all smb folders reappear!

Reply Deleted… i have resolved myself :slight_smile:

I try to explain how i do:

  1. Create new user whit a password following the @Phoenix suggestion
  2. All my windows shared folder has garanted dull access write/read to “Everyone”
  3. On sources i have put smb:// (the ip of my windows pc)
  4. I have to do manually edit the password.xml… contain this:
        <from pathversion="1">smb://</from>
        <to pathversion="1">smb://<usercreated>:<password>@</to>

All working whitout problems… no need to add the new user… all it’s working whit everyone setted correctly…

In what section of sources.xml did you add this? I added it to the “files” section and it worked. Note that this is JUST the IP and NOT IP/share. Mine looks like this <files> <default pathversion="1"></default> <source> <name></name> <path pathversion="1">smb://</path> <allowsharing>true</allowsharing> </source> </files>

OH NO, I just posted my internal IP address, I’m sure to get hacked now :slight_smile: :tired_face:

1 Like