SMB Shares - Cannot Browse After Update

So today i decided to update osmc to the latest version using the update option located in Apps --> OSMC -->Update

Update ran perferectly, but now i’m unable to browse my windows shares using SMB (samba)?

Now when i go to connect to Windows Network (SMB) it shows that it’s working, but when it’s done it’s shows no shares. Before It would be listing all my shares for every comp.

Any Ideas on how i can get them to show up again??

I almost never can see my shares using the source addon feature in Kodi, and have to access them using a form of address like:

 smb:\\\10.0.0.33\myvideo

NB that should only be a double backslash not a triple, but the forum software defeats me
later: realised that should be:smb://10.0.0.33/myvideo
HTH
Derek

Nothing will have changed with SMB browsing between RC1 and RC2 as only a very small number of changes went into Kodi between RC1 and RC2. (RC1 already had a version of Kodi that was only just before 14.2)

If you’re referring to sometimes not being able to browse to windows networks via Windows Network (SMB) when setting up a new share, (browsing by workgroup and then server name) then that has been unreliable in XBMC/Kodi for years, particularly on Linux.

This is not an issue with OSMC but an underlying issue in Kodi that the Kodi devs seem to be unable or too busy to fix over a period of years…

The recommended way to connect to an SMB share is via IP address (make the server a static IP) and by typing in the full path manually during setup as in the example dandnsmith gave above.

It will work sometimes via hostname but it will not always be reliable depending on your network configuration, and browsing via workgroup name to find a machine will often not work at all. Not much we can do about this unfortunately. Connecting via IP address is generally very reliable.

While I doubt this will affect the problem in question above, I would note that updating from RC1 to RC2 completely overwrote my smb.conf file and prevented me from accessing the OSMC root file system from my windows 7 PC (it didnt create a backup either)

smb.conf is for the samba server - it has nothing to do with the built in SMB client in Kodi, and therefore to do with the problems discussed earlier in this thread.

Yes, at the moment upgrades to the samba package will overwrite the smb.conf - there is a reason for that - because we provide our custom smb.conf in a separate package to the actual samba package, (which already has an smb.conf of it’s own) we install the smb.conf using a dpkg-divert, and it is not safe (supposedly) to mark a diverted conf file as a conf file in dpkg to prevent upgrades overwriting user customisations. We are thinking about solutions to this but don’t have one at this time.

As for preventing you from accessing the root filesystem - we don’t share the root filesystem and there haven’t been any significant changes to smb.conf since the samba-app-osmc package was created. You can see the history of the smb.conf file here:

The only changes have been to disable cups (which doesn’t work on OSMC anyway and just generates log spam) and to reduce logging verbosity.

On all my Pi’s (which all run headless with ssh access, Energy monitoring, OWFS server and Fileserver - now deprecated) I share the root file system which enables me to edit files in windows using Editplus so the alpha release of osmc which had an updated version of samba (with security = share deprecated) caught me out as did the update from rc1 to rc2 with the overwriting of the smb.conf file.

I did mention that I didnt think this would affect the OP problem, I was just pointing out that some changes in SAMBA had taken place between RC1 and RC2

As for preventing you from accessing the root filesystem - we don’t
share the root filesystem and there haven’t been any significant changes
to smb.conf since the samba-app-osmc package was created. You can see
the history of the smb.conf file here:

but I share it via the smb.conf file which was overwritten, so the update prevented access from my windows pc - its not a problem I just didnt know that it would be overwritten, a couple of minutes ssh soon sorted it :smile:

Today i updated also.
Since then i just cannot access my Windows 10 PC. It’s always asking user and pass.
I’ve got another OSMC on other Pi, i copy the passwords.xml from one to another and it still doesn’t work. On the Pi that is working i didn’t update.

Did you search? This has been covered quite extensively.

Hi Sam, I’ve been involved in one of the other threads regarding this issue and I still don’t have a solution, other than changing my username/password structure. Is it definitive that I can no longer access my Windows 7 shares which are not password protected, from OSMC, after the security update, or is there a way to do it I have somehow missed in the threads related to this issue?

I believe you just need to set Read permissions for the ‘Everyone’ group

Thanks Sam. My ‘Everyone’ share was set to ‘read/write’. I changed it to ‘read’, rebooted the RPi, and I’m still asked for a username/password when I try and access the share in Kodi.

Maybe my first screenshot misled you and others. I copied it from Google, because I want something in English, but I couldn’t find anything better in hurry.

Below is real screenshot from my PC. “Wszyscy” mean “Everyone”.

You need to 2 accounts:

  1. “Everyone” ← This let you connect from devices which don’t ask about password
  2. “osmc” ← This account has a password and let OSMC connect. How to hide an account in order to not mess up in the system I described in previous posts.

I tested it and it works. I hope it’s clear now.

Same Problem here… Raspberry Pi 2, after last update i cannot access my shared folders (windows 7 pc)… SMB keeps asking username and password… I have tried everything, only setting password in my pc user seems to work… If there is a solution without setting a pw i would appreciate it…

Thanks for the good work :slight_smile:

Why don’t you want set a password?
You can create additional account, hide it and never see it again.
You still will be able to use your local profile without pass. Nothing change.

I am glad you posted a workaround. But I feel like this workaround is complicated, or at least likely to create future headaches. For this reason, I also would rather not create extra accounts and passwords.

What if you have 3 osmc boxes (like me)? Or 10? You have to create an account for every one? And then you need to mess with the registry each time to hide these mystery accounts?

I’ve created another user account on my windows 10 machine, added this to the list of people to share with in one of my shared folders to test with. Tried entering the username/password when prompted in osmc and no dice. is the username the Name it shows at the top of the start menu in windows 10? or is it the email address i’ve tried both with the proper password with no dice so im not seeing what you mean…

As for not wanting to set a password why should i want to set one? SMB is shared across the local network only, I’ve been using it for years and years with no issue, no password needed ever. I dont understand what this update did, i realize there was a wide range of security updates but should we really have to setup an account and password for smb access. I feel like if this was just a security update there wouldnt be any drastic change, but now you’re saying we have to enter a username and password from now on I feel like that should have been covered a bit more in the changelog or something.

Honestly i feel pretty dumb, i’ve tried numerous recommendations on this forum with no luck… all i want to do is enjoy my shows, and music but i feel like im special ed. Im more than willing to help diagnose any problems but i feel like there should be an update to fix what was broken, i was kindof hoping a fix would have already been posted by this evening. (please im not trying to be rude, i realize people on this development team have lives outsize osmc, i just thought with so many complaints i read before that it would have been addressed quickly)

1 Like

I have now resorted to adding a new user with a U/P and sharing my media to that user, and it worked. Oddly enough, I only shared one of my media folders to that user and all of my shares started working, so I suspect something is actually still broken, that didn’t need fixing in the first place.

I’m with you guys who think this should never have happened in the first place. I can only imagine if I was away and my wife had done the update!

1 Like

Hi Sam. I’ve been around since the beta of RASPBMC and i apreciate very much your work.
I’ll try to make a very detailed information of what happened to me.
I’ve got OSMC running on my RPi2, configured with MySQL connected to my Windows 10 PC (the server machine let’s day it)

  • Yesterday i was watching a TV Show (Agents of S.H.I.E.L.D.), when it ended i decided to to and see another TV Show, that was when it appeared the information that was a new update available and if i wat to update? Of course i updated, i never had a problem before.
  • After the update i went to the recent TV Shows and pressed play on the episode i was going to see and it just said that the item was not available and if i want to remove it from my library.
  • like it was not he first time after a update i had a little problem with my shares, i did what normally works. Shutdown the RPi and rebooted my Windows 10 PC. But the problem existed the same
  • That was when i went to FileManager and tried to access my PC. I choose SMB, then WORKGROUP and when i select the workgroup (UNDEAD) it just asks for a user and password, and don’t even have access to my smb shares.
  • So something changed the access to the PC on the update. I have another account, i tried entering the credentials of the other account, and it’s the same, i tried every possible combination … i think :slight_smile:
    My user is ‘Rui’ and i tried entering on the pass and pass@UNDEAD none worked.
    Sorry for the big text, hope it helps. For now i will just use the addons to watch what i want 'cause i can’t count with the library integration of the addons.

Keep the good work Sam … and help me :slight_smile:
Sorry for the bad englist, but i’m portuguese.

[quote=“silvioj, post:16, topic:3294, full:true”]
I’ve created another user account on my windows 10 machine, added this to the list of people to share with in one of my shared folders to test with. Tried entering the username/password when prompted in osmc and no dice. is the username the Name it shows at the top of the start menu in windows 10? or is it the email address i’ve tried both with the proper password with no dice so im not seeing what you mean…[/quote]
None of this. Email address can’t be use probably due to “@” symbol.
At the top of the start menu you can see full name.
I believe for logging you should use just “Name”. You can check it under: Computer management -> Local Users and Groups.
I would recommend using offline account, not LiveID, will be less confusing.

Hard to say, but I think one account for all boxes will be enough.

1 Like

Ok done it… works… thx