SMB Shares - Cannot Browse After Update

Thank you sir, and yes i ended up setting a local account up last night but still had no luck. I double checked the password for the new account I created and I guess i never set one up. Could have swore i did lastnight, and even used one to login I thought, but, all is well now should be fairly simple to add that acount to all my shared folders, wish there was a way to highlight all folders and batch do this.

Thanks for the assistance.

Same story as everyone else. Update on the 14th caused OSMC to require password and username. It will not accept anything. Checked to see if there was an update to SMB in the app store but it is the same version 1.1.8 from 2015-05-24. I uninstalled SMB server and reinstalled it but nothing works.

While the update did not brick my system it might as well have made it a paperweight for at the moment it no longer works.

Please can you help. Either by giving clear instructions on how to fix this. (changing permissions does not work as they were already set) or by letting us know when this will be resolved. I understand the need to make items more secure, but that should not be at the cost of functionality. I really don’t want to reinstall everything but I will downgrade if need be.

I have found the solution, for myself anyway. I am running pi2+ and Windows 7. After days and hours of playing around and reading the forums, it turned out that for the username and password, you have to now put in your windows login info from when you first startup or login to Windows. So your user account name and then the password you first put in to login to Windows. And hey presto dumb works perfect again.

Windows 7 on a Pi2+ as well. What if you don’t want your windows account to use a password. I cannot log in currently with the password left blank?

Ok, lets try to avoid confusion here. Most people seem to report that they have an issue to access SMB shares (without username and password) that they have running on their NAS or Windows PC from their OSMC Box.
It sounds like you are reporting to have an issue the otherway around means accessing the shares on the OSMC from your PC.

  1. Please confirm and give exact detail of the PC your are trying to connect from to OSMC
  2. Provide the journal log grab-logs -J and samba logs paste-log /var/log/samba/log.smbd
  1. Most people seem to report that they have an issue to access SMB shares (without username and password)
    Only after the recent 2016-04.2 update. It has been running successfully for years (using xbmc then kodi and as of late OSMC)

  2. that they have running on their NAS or Windows PC from their OSMC Box.
    Yes I have a NAS drive (that works) and a Windows 7 PC that now does not.

  3. It sounds like you are reporting to have an issue the otherway around means accessing the shares on the OSMC from your PC. Please confirm and give exact detail of the PC your are trying to connect from to OSMC
    No not at all. I have OSMC on a Raspberry Pi 2+ and I am trying to access content on my Windows 7 computer like I have for a long time until the recent update. My Windows 7 PC does not have a password and I would rather keep it that way.

  4. Provide the journal log grab-logs -J

  5. samba logs paste-log /var/log/samba/log.smbd

Ok, so than you problem is the same (accessing Windows 7 shares). I just got confused as you wrote “update to SMB in the app store” which is the Samba Server and not the client.
In regards to accessing Windows 7 shares, as of now I only can point you to the threads that recommend creating a user on Windows 7 for OSMC and give that user the permissions on the shares you want to access.

Same problem here. OSMC won’t access my windows 10 computer smb shares without a user name and password (which is not set). I can cast to OSMC from the computer but obviously that’s not ideal. I have no desire to deal with putting a password on that machine or setting up extra accounts. I live in a rural area with extremely little risk of anyone being able to access that computer. I’d be happy to downgrade to previous version at this point if this can’t be fixed.

I tried the instructions given here to create a hidden account:

I tested this on one folder and it does not work. OSMC will not allow me to access the folder even though my security preferences in Windows 7 give “Full Access” to both “Everyone” and explicitly to “osmc”

You didn’t hide account, but completely deactivated it.

You should follow this instruction: How to hide user accounts from the login screen in Windows 8.1

TIP: If you deactivated account, account will disappear from folder permissions even if you activate it again. You must add it once again.

1 Like


Unfortunately I don’t use Samba shares in my house, but I took a look at the Badlock CVE and think I know where the issue may lie

I will produce a Pi 2 / 3 test build quickly. I would appreciate some feedback. If this works well I will push new builds to all platforms.



Thank you Sam, I am having this same Samba share problem with my new VERO on 2016.4.2 as well as a Pi with 2016.4.2.

An untouched Pi with 2016.4.1 works fine.

Will be happy to test the fix.

Ok while the instructions were for Windows 8.1 and not Windows 7 like what I have (the only change was I had to search for “Computer Management” from the start bar). THAT DID IT. I now have a hidden osmc user account. Any chance that someone could make a WikiHow like instructions for people just to make it easier. That really wasn’t very straight forward :-/

NOTE: This solves the Password Required issue aka “Lock Preferences for smb:” it does not assist with the Operation not permitted error.

I was going to upload the osmc.bat and osmc.reg file for others just to make it easier for others trying to do the same. But I am not allowed.

So here is what you need to do:

  1. Add a user with a password or create a password for an existing account.

If you don’t want a logon screen on your computer, please follow the steps below:

Open Notepad and copy this into it

@echo off
net user osmc osmc /add
net localgroup Administrators osmc /add
net user osmc /active:yes

Save it as osmc.bat

Next open Notepad again and copy this into it

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList]

Save it as osmc.reg

run both files as administrator

Now you have a hidden account
username: osmc
password: osmc

  1. Now follow the instructions found here and change the Security settings in your shared folder:

If you modified an existing account give that user or Everyone Full Control.

If you followed my instructions above for a hidden account please either add a new user osmc and give that user Full Control or give Everyone Full Control.

If you find that does not work. Please follow @FaustoGSR’s steps 3 & 4 shown below

        <from pathversion="1">smb://</from>
        <to pathversion="1">smb://<usercreated>:<password>@</to>
1 Like

I’d be happy to test a potential fix too :slight_smile:
I’d much rather spend some time testing than have to settle for hidden accounts or passwording up my PC.
Thanks @sam_nazarko!

Sign me up for testing as well!! Been going nuts re-typing the password trying to make it work:-/

The build does not work properly.

CVE-2016-2111 is intentionally patched to prevent Guest access to shares. I will continue to look at the proble.


Hi there. Is there any way to roll back to an earlier release? I’m running the latest OSMC build linked into a SMB share from a Hackintosh server (running 10.10 - I know Mac Samba is a bit flaky but the laptops in our house are all Mac, so I need AFP support). As with Windows shares, the latest OSMC update has broken my SMB connection and none of the suggested cures have worked so far.

Any way to roll back? Right now the OSMC Pi is going to be sitting idle until there’s a fix, which is a waste of an otherwise-great system…



Hi, I am experiencing what seems to be the same problem as everyone else however, i’m not sure my scenario has been mentioned in this thread…

My setup is as follows:

  • 1 HTPC running Windows 10 which has all my media
  • 1 RPi 2 running MySQL and has all the library data
  • 2 RPi 3 as just clients

I only received the RPi 3’s yesterday. I also noticed a problem with my RPi 2 in that it would not play any movies so I wiped the microSD card and reinstalled OSMC to resolve the problem. Having also just received the new RPi 3’s I set those up identical to the RPi 2 without the MySQL server. All 3 RPi’s are running the latest version of OSMC (April 2016)

Now here’s the strange thing. My RPi 2 will not play any movies still using SMB paths. It says the file is no longer available and i’m getting prompts to enter a username and password. Both my RPi 3’s can play movies and access the files fine.

My HTPC does not have any passwords. I’ve had this setup working perfectly since January and I don’t play movies via the RPi 2 often, but yesterday when I tried I noticed it wasn’t working at all.

Hopefully this helps in some way. I’m happy to provide debug logs if it will help come up with a solution. I would rather not change my setup to include passwords and would prefer to wait for an update to fix this.

What happens if you swap the Pi2 sd card with a Pi3 does the problem follow the card or the Pi?

If it follows the card then copy the userdata folder from the working card to the non working card

Just thought I would share what I did to fix my user/pass problem after messing around settings trying to get anonymous/guest to work again.

If you created a new user/password, added that account to the share(s), and OSMC still repetedly asks for username/password for the PC, try this (especially if you did like me and changed GPO settings trying to get anonymous to work):

  1. Open gpedit.msc
  2. Go to Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options
  3. In the right pane, find; Network access: Sharing and security model for local accounts
  4. Make sure it is set to: Classic - local users authenticate as themselves

After following some potential fixes for anonymous access, I changed this setting, then promptly forgot I did so. After caving and creating a user/password and it still didn’t work, I checked the GPO again and forgot I changed this. Changed it back to Classic and now my user/pass works.