Has SMB 2 and 3 support been added since this FR was created?
I’ve disabled SMB 1 on my Synology NAS because of the latest security issues and also lower performance and can’t access its shares since.

Probably – it would help if you told us what device you were using.
I would suggest starting a new post first :slight_smile:

A Vero 4K.

Do you need any more infos Sam? What’s the reason for only compiling the kernel with SMB1 support which is more hardware demanding, slower and has the security implications?


This is still on my list.
Did you mount via fstab or Kodi?

Via Kodi. Thanks Sam!


Did you try a kernel mount yet?
SMB2 is enabled on the Vero 4K kernel: CIFS_SMB2 [=y]

SMB1 is disabled on my network for security reasons but I can mount
SMB2 shares without issue. I use fstab for my mounts for performance


No haven’t tried that because I guess that would require to change the path in Kodi which would result in all watched markers be gone etc.
How does Kodi mount network shares?

Kodi uses libsmbclient (a library)
Mounts in the OS provide better performance and readahead.

You would indeed lose the markers unless you used remapping. But I’m actually just asking if you can try a kernel based mount, because SMB2 is supported in Vero 4K’s kernel and should be working without issue. I’m not asking you to migrate your library but just to confirm whether this is an issue with OSMC on Vero 4K or a generic Kodi issue.

Will do tomorrow!

Sorry, took me one more day.
When I switch the Synology NAS to “SMB2” or “SMB2 and Large MTU” the mount fails with

mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

My fstab entry looks like

//nas/video /mnt/video cifs defaults,user,noauto,username=foo,password=bar 0 0


//nas/video /mnt/video cifs defaults,user,noauto,username=foo,password=bar,sec=ntlm 0 0

Still the same.
I now had the time to look further into it myself. I expected that a version handshake takes place or the Linux kernel trying all of its supported versions starting with the newest/most feature rich which doesn’t seem to be the case. When I specify the vers=3.02 parameter the mount works.
I’ve found this param here:

Thanks for that information. I’ll see if there’s anything that I can do to make the mounting process simpler.

Glad it’s working now.



Only try to make libsmbclient support version 2 and 3 and add a note somewhere that using a kernel mount is preferred to the Kodi way for performance and features.
Thanks Sam!

Just found the thread Vero 4K SMB2 windows shares and wonder if OSMC will get SMB2/3 support without mounting the share through the kernel with fstab?!

If you mean via Kodi, then that is already possible.

Since when?

Kodi uses libsmb. We have supported this since OSMC came out

So why are connections to a SMB1 disabled SMB server not possible then and you told me to use a kernel mount instead? :confused: