Smbclient connects to Samba share but mount -t cifs does not

I am trying to mount a samba share that is in a Raspberry Pi running OpenWrt to a directory on another Pi in the same LAN that is running OSMC.

I am running this command from OSMC terminal:
smbclient \\\\openwrt\\4TB2 -U root

It prompts for my password and lets me list the files in the 4TB2 share.

However when I try this command from OSMC terminal:
mount -t cifs //openwrt/4TB2 /mnt/4tb2

I get a password prompt but the same pwd does not authenticate me and I get the error:
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

This command gives the same error(95)
mount -t cifs //openwrt/4TB2 /mnt/4tb2 -o username=root,password=pwd,vers=3.0

The /mnt/4tb2 directory exists. Do I need to make changes to my smb.conf or what is going wrong?

Confusingly, if I try it the other way around… and try to mount a share that is on the Pi running OSMC Pi to a directory on the Pi running OpenWrt… it does work.

So I run this command from OpenWrt and it mounts the 4TB1 share:
mount -t cifs //osmc/4TB1 /mnt/4tb1 -o username=osmc,password=pwd,vers=3.0

Maybe this is a firewall issue with OpenWrt?



I was specifying the wrong SMB protocol version in the mount command.

smbstatus told me OpenWrt was using SMB3_11

So running this command from the OSMC Pi now works:
mount -t cifs //openwrt/4TB2 /mnt/4tb2 -o username=root,password=pwd,vers=3.11