So far only one issue with the Vero 4K...no boot with drive connected

Got my Vero 4K today and so far it only has one major issue. It will not boot with my external drive connected.

It is an 8TB powered external drive formatted in NTFS. If it is connected when the Vero tries to boot, all I get is a screen saying ‘Please Stand By’ and an infinite boot loop.

I have tried with a flash drive 64GB in NTFS and that is fine. I still get a flash of the ‘Please Stand By’ screen, but it then goes on to boot up.

I can only imagine what will happen when I get home later and connect it to my USB hub with a further 10TB of storage connected! :joy::joy:

Any thoughts?

Is this a Seagate drive?

Yes it is Sam. Are they a problem?

The issue occurs due to a halted endpoint bug. I know Seagate fixed this for some drives with firmware updates.

I can think of a workaround that might work, but we would need to test it. Do you know how to use SSH?

If it results in a fix, I’ll happily learn. You just may have to baby step me through it a bit.

Hi lstar337,

Before Sam gets back to you on the work round, I suggest reading this:

https://osmc.tv/wiki/general/accessing-the-command-line/

Thanks Tom.

Thanks Tom, I will.

Unfortunately I now have a more pressing problem. No digital audio passthrough is working with my amp. Granted the amp is old, but DD 5.1 and DTS worked fine on my Wetek Core.

My amp is connected through optical and I have enabled ‘passthrough’ and ‘AC3 capable reciever’ and ‘DTS capable reciever’ (in fact, I think I have tried every single setting combination at this point), but none of them trigger my amp to go into DD or DTS mode. It just stays in ‘Pro Logic’ mode for everything.

There is one way I can get a digital signal through, and that is by turning on ‘AC3 Transcoding’. This triggers my amp into DD mode as soon as a file (AC3 or DTS) is played, but I don’t want everything transcoded, only the formats my amp cannot process.

I did notice that under ‘Passthrough output device’ it says: AML-M8AUDIO, HDMI but I don’t know if the HDMI is significant.

I also have a choice of ‘Audio output device’ which is: Default (AML-M8AUDIO Analog), PCM or AML-M8AUDIO, HDMI. However I didn’t find either passed through the correct audio.

Maybe I just haven’t hit on the right combination of settings yet.

Any ideas?

For S/PDIF output, the following settings should be used:

Audio device: PCM
Number of channels: 2.0
Output configuration: best match
Passthrough: enabled
DTS/AC3 passthrough: enabled
DTS-HD/TrueHD/E-AC3 passthrough: disabled
AC3 transcoding: enabled

This should give you exactly what you want.

Yeah, unfortunately that doesn’t work.
That is how I set it at first because that is how I had my Wetek Core set up.
I can’t even force my amp into DD/DTS mode, it isn’t having any of it!

This is my amp: http://pdfstream.manualsonline.com/b/b8310cb7-0a3a-484f-9082-fb8400e6aaab.pdf

Do you have “sync playback to display” disabled unter settings/player/videos?

No, and that was the issue!

Thank you Wuschel_Wuschel! :grin::grin::grin:

1 Like

This option doesn’t seem to be trivial and straightforward to many users… :see_no_evil:

Always happy to help :+1:t2:

I don’t even know why it was enabled! I don’t recall doing it.

I’ve had a look at this, and I’m not sure if we can actually gracefully reset the disk from user space so that it works properly on reboot.

For now the workaround is to connect it after booting. I’ll see what can be done to address this in the near future.

Sam

Thanks for looking at this Sam.

I am fine with removing the drives for a reboot (as it is hardly ever needed), my concern is the rest of the family who will not understand why it doesn’t boot after a crash or something. Hopefully a fix won’t be too difficult or far off. I understand OSMC should not be closely compared with Open/Libre ELEC, but the drive caused no issues with these two OS’s. Maybe that info will help, I don’t know. :blush:

I suspect you ran LibreELEC on a different class of hardware however.
The crash occurs before OSMC even starts, because of a bug with Seagate drives that cause issues with our bootloader.

Sam

Yeah, it was on my S812 based Wetek Core.

Is there anything I can do to my Seagate drive to make it play nice? Or is that a dangerous slope to be on?

This fix from August 2017 should address it:

The issue is with safely updating the bootloader however.
I’m looking in to if there’s a better way to do this.

Ah, OK.

I’ll leave it safely in your hands. :wink::slightly_smiling_face:

Please try this (via SSH):

(edited for now), don’t use

And reboot.

It disables USB based booting.
So if you need to reinstall OSMC, you’ll have to do this with an SD card.

Sam