So tired of crashes

So after the latest update totally fd up my pi2…i decided today to reformat it. So i reformated the whole thing, reinstalled htop,wavemon,ddclient,vncserver and copied my Kodi settings back to .kodi folder.
Then i decided to reconnect my wifi…only to see osmc crashing again, every time i try to set up a manual IP instead of the automatic one.

There were of course other crashes as well…but this is the most important problem… I need that manual ip address…and from the logs i see that it happens because:

TypeError: apply_network_changes() takes exactly 2 arguments (1 given)

So what can i do now ?

My osmc version: VERSION_ID=“2015.07-1”
And my log files: http://paste.osmc.io/ihejafurin
And the networking_gui.py script with modification data 4/8/15: http://pastebin.com/v6F9Pi5b

ps: Is there any way i can reinstall kodi, without reinstalling the whole system ? something like apt-get install mediacenter ?

The issue you are referring to prevents WiFi from being configured with a static IP. This has been fixed in Git and will be released as an update shortly. Unfortunately, you will need a Wired Internet connection to get this update (for obvious reasons) or DHCP Wireless connection

Not sure reinstalling Kodi will help but you can run sudo apt-get install --reinstall rbp2-mediacenter-osmc.

Sam

Thanks, i copied the .py file from the git and fixed the problem.
My osmc boot logo is messed up now…that zig zag thingy. Is there a way i can fix this ? The bug started when i tried to tweak config.txt to force 720p resolution…because when the TV is off and the pi reboots it doesnt recognize the TV’s max resolution.
Before there was an image file we applied and patched things up. But that doesnt work anymore.

here is the file i copied if anyone wants it:

How have you tweaked config.txt to accomplish this? edid.dat file?

by adding:

hdmi_force_hotplug=1
hdmi_ignore_cec=1
hdmi_ignore_cec_init=1
hdmi_group=1
hdmi_mode=5

although it worked…reverting back to the defaults, didnt fix the broken logo.

My OSMC boot logo is also messed up, just like Sandbirds description. This happened after last update. I have not tweaked any config file.

Rpi, 512MB
Overclocking: Fast
HDMI 1080p

Can you please provide a photo or video of the problem?

There was a bug where 1366x768 resolutions were not displaying correctly. This was originally fixed by @DBMandrake and later refined by @popcornmix. It will help if you can let us know:

  • What HDMI mode you are on? I see @sandbird has specified his.
  • dpkg -l | grep splash-osmc

Sam

I did, but i removed those settings trying to fix the splash screen. Now i have (through osmc gui) 1920x1080p,
my config.txt is:

dtoverlay=lirc-rpi:gpio_out_pin=17,gpio_in_pin=18
sdtv_mode=2
disable_overscan=1
hdmi_force_hotplug=1
hdmi_drive=2
hdmi_force_edid_audio=1
hdmi_ignore_cec=1
over_voltage=2
start_x=1
gpu_mem_512=256
sdtv_aspect=3
core_freq=500
hdmi_ignore_cec_init=1
over_voltage_sdram=0
initial_turbo=0
overscan_scale=1
hdmi_mode=0
dwc_otg.speed=1
force_turbo=0
sdram_freq=500
gpu_mem_256=128
hdmi_group=0
gpu_mem_1024=256
arm_freq=1000

and the grep thingy shows:

root@osmc:~# dpkg -l | grep splash-osmc
ii  armv7-splash-osmc                    1.2.1                       armhf 
Splash screen implementation for OSMC using ply-lite

and ofc the splash wont return back to normal, no matter what i try.

Now selecting an NFS drive crashes Kodi as well (sometimes)…
Seriously which is the latest most stable version i can get and just stay there…no updates no nothing.

Revert your overclock settings to default tell us if the behavior continue.

sorry to say this, but i am dropping osmc…I just installed xbian and everything works just fine.
I dont know why things started breaking, but even with a clean install i was getting crashes with my setup. The alpha builds were more stable than this :confused:
Maybe later on i’ll come back again. Hope all goes well with you guys.

400.000 happy OSMC users without crashes will feel sorry seeing you moving to xbian

2 Likes

Did you even try to revert your overclock settings?

Will reverting the overclocking fix:

  • Broken splash screen (again) and noone giving a solution about it.
  • Selecting things in the GUI that has to do with networking crashes kodi (NFS drives, applying network settings etc)
  • Kodi randomly hangs during the night when the tv is off, and the only thing that is active during nights are update checks.
  • Sometimes kodi will not connect to my wifi router and only if i try 2-3 times by giving the password again it will work. Tried wep, wpa, wpa2…all doing the same thing.

The pi2 is located behind my parents’ tv…meaning every time i have to go there and reset it…while my pi1 running Raspbmc in the storage room is online working fine for over 2 months now…and it has exactly the same apps installed (ddclient, vncserver and a static ip and even a php server)

I’ve gone through Rasbian, Openelec, Raspbmc and now Osmc and comparing all them…i’ve never experienced so many crashes that i did with osmc.
I just installed Xbian to it…compiled the vnc server on, installed ddclient set up a static ip, even overclocked it and i havent got a single crash. I even copied my .kodi folder from osmc (removing anything osmc related, and it just worked)
I just want a box behind the tv working as expected without any manual labor…just like raspbmc was running on my pi1.
Even the remote control doesnt work properly on osmc…sometimes i have to hit some buttons twice because they are not registering…like there a lag with the controller…while the same remote under xbian is working fine.
I really like osmc, its functions, the simplicity and the speed…but honestly its not for me…maybe its my addons or the fact that i am using its linux distro for other things besides watching movies…but its really buggy compared to the other distros i’ve used :confused:

ps: its not the temperature either
CPU Temp: 48.6 C
GPU Temp: 48.7 C

It’s entirely possible! There is nothing that guarantees your pi will run stable at any clock speed other than default. Most users I’ve seen testing clock speeds on Rpi2 reported that their device was NOT stable at 1000Mhz. An excessive, unstable overclock can create all sorts of strange crash behavior.

RE: splash screen… Did you notice that you and one other person on this forum are the only ones experiencing the issue? This suggests with high probability that the issue is specific to some config or hardware issue at your end, not an issue with OSMC. Being that the device was designed to remain on at all times, it would seem that a borked splash screen should be the least of your issues problems once system stability is restored.

During the alpha builds i had it OC at 1000, same with Openelec and raspbmc, never had a problem then. After the June update all hell broke lose. And besides, the wifi bug that it was not connecting to my router, was happening only with osmc.
About the splash screen, there was a patch released earlier this year: Splash screen is damaged - #6 by DBMandrake
that fixed it back then. The problem started when i put the sd card on my pc and edited the config.txt to force 720p resolution for when the tv is off and the pi reboots, so it gets the proper resolution…after that reverting back the changes doesnt affect the broken splash screen.

What about the fact 1 month ago with the June/July update when the whole system turned read-only after the update ? I was not the only person that had that problem. Did we all have a faulty hardware ?

Enjoy your other distro then. You are clearly unwilling to take suggestions from those who support this one.

1 Like

Why are you so stuck with the overclock ? Do you want me to redo everything i’ve done without the OC and see that i’ll still have problems with the wifi and the crashes?
I reinstalled osmc 2 days ago…I didnt even get to the OC when i had the broken splash, the wifi not connecting to my upstairs router, and the random crashes. I even stopped installing all that linux stuff (ddclient, vncserver) the first night because it was getting late so i can continue the next day, only to find it stuck in the morning in dimmed mode and the clock had stopped around 4 in the morning. We are talking vanilla install now…Nothing was installed…no customization, nothing…
I’ve used the same wifi dongle, router and remote with raspbmc and openelec before that and i never had any problems then.
And if its the hardware fault with the pi2 then how come ALL the above are working fine with xbian ?
I really like osmc, i dont want to switch distros but you have to acknowledge the fact that something is wrong with osmc atm. Something happened since the June release.
Forget about the broken splash. Why do i have so many wifi problems ONLY with osmc ? IF i reboot it 80% of time it will not reconnect automatically. I have to manually stop/start the wifi adapter from the gui and reenter the password 2-3 times for it to connect.