[Solved] After 16 update lost shared DB connection and etc

I did the latest update last night and after I rebooted I lost my info on each of my sources. When I edit them I have no scrappers configured. I also have no info for any of the shows/movies. The advanced settings.xml file is still present in the profile directory and under settings I still have the MySQL connection info.

I will give that a try this evening. I have 5 KODI boxes so I will shutdown all but 1 and see what happens.

ok, so I tried what you suggested and it didn’t work. What I am noticing is that I can’t set the content source. I have a folder for TVShows and it was initially not set after the upgrade. I try to set it and does not keep the setting. I tried the same for Movies folder and I get the same results. The new DB is around 6.3MB which is about the same as the old DB so I am pretty sure that is working.

So you shutdown all machines (other than one) accessing the database deleted all the Jarvis databases http://kodi.wiki/view/Database_versions and then rebooted the single machine and let it upgrade all databases before you started the other machines?

Suggest to check the actual database entry for that source after you change the content type

Correct. I shutdown all the Kodi’s. Deleted the video99 DB. Turned on the one Kodi. Not sure what I should check in the database… I do know that I have tried to set the content source multiple times. It asks if I want it to do an update of the content but I never see a window pop-up where it is actually doing anything.

I have another Kodi that is still on 15.2 and it works fine.

I have found out that if I am using the local DB in Kodi then I can set a source and it saves. If I am using a shared SQL server and try and set the source in Kodi it does not save. Every time I go back into the look at the source it is blank. I never had this issue with v15x. Please help. I am kinda dead in the water right now.

Check on your mysql server that all v16 databases/tables are created correctly (http://kodi.wiki/view/Database_versions). Otherwise you may want to try to delete them and let Kodi do another upgrade.

http://kodi.wiki/view/MySQL/Upgrading this page, Common Problems, Section 3.1, Method 2

According to this page you should drop any video db greater than 93 http://kodi.wiki/view/Databases/Versions

I went ahead and reset all 5 of my Kodi devices and started fresh with one of them and so far it is working. Still building the shared DB and then I will configure the other ones to connect to the shared DB. Thanks for all the help.

Good to hear, if you are successful please mark as solved