[SOLVED] Deutsche Welle addon not working

I get the following errors when trying to use the DW addon with OSMC on my Raspberry Pi 3.

2021-05-27 17:07:07.214 T:1916342288 WARNING: JSONRPC: Could not parse type "Setting.Details.SettingList"
2021-05-27 17:07:07.473 T:1916342288  NOTICE: Register - new keyboard device registered on application->keyboard: Keyboard (0000:0000)
2021-05-27 17:07:07.474 T:1916342288  NOTICE: Register - new mouse device registered on application->mouse: Mouse (0000:0000)
2021-05-27 17:07:07.483 T:1916342288  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
2021-05-27 17:07:07.489 T:1916342288  NOTICE: Loaded playercorefactory configuration
2021-05-27 17:07:07.489 T:1916342288  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
2021-05-27 17:07:07.490 T:1916342288  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
2021-05-27 17:07:07.501 T:1916342288  NOTICE: initialize done
2021-05-27 17:07:07.501 T:1916342288  NOTICE: Running the application...
2021-05-27 17:07:07.518 T:1916342288  NOTICE: starting zeroconf publishing
2021-05-27 17:07:07.518 T:1916342288  NOTICE: CWebServer[80]: Started
2021-05-27 17:07:07.520 T:1637830880  NOTICE: ES: Starting UDP Event server on port 9777
2021-05-27 17:07:07.526 T:1637830880  NOTICE: UDP: Listening on port 9777 (ipv6 : true)
2021-05-27 17:07:07.711 T:1713365216  NOTICE: Register - new cec device registered on cec->RPI: CEC Adapter (2708:1001)
2021-05-27 17:07:17.280 T:1399836896  NOTICE: Skin Helper Service --> WebService - start helper webservice on port 52307
2021-05-27 17:07:17.281 T:1671401696  NOTICE: Skin Helper Service --> Skin Helper Service version 1.1.3 started
2021-05-27 17:07:37.331 T:1916342288  NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.dw/play?m3u8=https%3A%2F%2Fdwstream4-lh.akamaihd.net%2Fi%2Fdwstream4_live%401$
2021-05-27 17:07:38.571 T:1391444192  NOTICE: Creating InputStream
2021-05-27 17:07:38.917 T:1391444192  NOTICE: Creating Demuxer
2021-05-27 17:08:09.101 T:1391444192   ERROR: OpenDemuxStream - Error creating demuxer
2021-05-27 17:08:09.102 T:1391444192  NOTICE: CVideoPlayer::OnExit()
2021-05-27 17:08:09.154 T:1916342288  NOTICE: CVideoPlayer::CloseFile()
2021-05-27 17:08:09.155 T:1916342288  NOTICE: VideoPlayer: waiting for threads to exit
2021-05-27 17:08:09.155 T:1916342288  NOTICE: VideoPlayer: finished waiting
2021-05-27 17:08:35.033 T:1637830880  NOTICE: ES: Client  from ::ffff: timed out

I have searched the web and this forum (Deutsche Welle not working on Pi Zero but works with libreELEC) and tried the various suggestions but still can’t get it to work.

Anyone got it going and give me a hint.

Full, complete debug logs may give more clues.

Have you contacted the add-on developer?

Sorry new to this OSMC stuff.
How do I get the debug logs?
How do I find and contact the developer?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Via the Kodi Forum.

Thanks for your reply.
I have uploaded the logs


I also found this link
which if you scroll to the end mentions using VLC as an external player. I don’t have this installed with OSMC so I did not try this.

That would only be available if you have a X-Server installed which conflicts with Kodi on OSMC.
But based on the Forum the VLC was just to test for latest FFMPEG version.

> 2021-05-28 13:48:24.610 T:1915617296  NOTICE: VideoPlayer::OpenFile: plugin://plugin.video.dw/play?m3u8=https%3A%2F%2Fdwstream4-lh.akamaihd.net%2Fi%2Fdwstream4_live%40131329%2Fmaster.m3u8&title=DocFilm+-+China%27s+Cities+-+The+Competition+for+Living+Space
> 2021-05-28 13:48:25.442 T:1393627360  NOTICE: Creating InputStream
> 2021-05-28 13:48:25.588 T:1393627360  NOTICE: Creating Demuxer
> 2021-05-28 13:49:05.251 T:1393627360   ERROR: OpenDemuxStream - Error creating demuxer

My guess is the URL’s are not working anymore. Have you tried the DW Addon on another Kodi Platform than OSMC?

I have found that the link has a title=xxxx on the end.
On trying to play this in VLC on another computer it will not play.
However removing the title=… from the link will play in VLC
I have contacted the developer with this information and hope for a response.

1 Like

Let’s hope the Addon would be fixed. If you want to play it on OSMC in the meantime you could add that corrected URL into a Stream Playlist.

If you mean by putting
into a .strm file, I have tried and get the same error as from the addon - ```
OpenDemuxStream - Error creating demuxer

Yeah that is what I meant. I just tested that on my Pi3 (which runs the current testing version of OSMC) and it works there. So it might be a problem with the older version while I wonder about that.
If you are eager jump on the testing waggon

I think I will wait for the update to filter through. It sounds like it won’t be long.
Will the update happen automatically, or do I have to request it somewhere?

Will be automatic (notification) unless you disabled that.

Does it tell me when the update has been done?

It will have a popup when the new update is ready to be installed. Then after the restart it will be ready to use.

Thanks for your help - Wait and see and fingers crossed.

I now have 19.1 and the strm files are working. I have not bothered to check the DWTV addon as the strm file provides me with what I need