[SOLVED] EmulationStation working only in SSH

Hi there, I’ve been looking to adding Retropie to OSMC, I followed the tutorial without encountering any error, I even loaded some ROMs on the correct folder, but when I boot my Raspberry Pi 3B, then go to OSMC’s “My programs” folder and select “Retrosmc”, a loading “OSMC logo” animation started playing in the center of the screen for about 1 sec, then the screen got black with a white underscore symbol ( “_” ) on the top left of the screen, then after another few seconds, OSMC’s main menu showed up again like if it rebooted or something.

I’ve tried going into SSH and typed this:
sudo systemctl stop mediacenter

it indeed blacked out when mediacenter stopped and started emulationstation, prompting me to input a controller (which I successfully did, a NES game is currently running as I type.

Is there a way to fix the OSMC “Retrosmc” application so it can start emulationstation?

Thanks by advance guys! (and sorry for my bad English, I hope it all make sense, if not, feel free to ask me to rephrase myself, I’ll be more than happy to comply)

Haha, okay, feeling pretty stupid right now but I’m still giving the answer:
I followed that advice : [HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC - #1454 by RJ45

And it all went good! :smiley:
Happy ending!

1 Like