[SOLVED] Error 2 Share not available

Hi all, I am getting the dreaded error when trying to access smb.

I have 2 raspberry pi devices and 2 windows devices. All connected through mysql to share the library.

Raspberry Pi #1 is setup as the main device and scans my pc over smb regularly to add new files to the library.

The others do not have sources setup as they don’t scan and can use the details stored in mysql.

I upgraded the main pi from raspbmc to osmc today and it went very smoothly. I added the sources to match mysql (as I forgot to backup sources.xml) with no problems.

Pi 2 is a b+ running a wireless connection. I did the same rebuild, but when I went to browse smb (so it stores login credentials), I immediately get the error 2 share not available issue.

I have seen people talking about source permissions etc, but the error appears before it gets anywhere on the smb network. Unfortunately, while manually adding a network location lets me browse the server OK, I still can’t watch files, as it hasn’t stored the credentials correctly.

Sorry for the long post, but having searched around, no one seems to have a setup like mine and I can’t find a way

Thanks in advance for your help

Tried this?


1 Like

Nope, indeed I did not. I will try it as soon as I get home and see if it helps.


Absolutely superb. Never had to do that before because smb browsing never gave me a problem, however, that will stick with me now…

Many Many thanks

1 Like


I have the same error. but I dont use password…