[SOLVED] HDMI splitter sound away after TV off/on, reboot Pi2 required

The issue I am currently experiencing with OSMC:

I have no HDMI sound from Kodi, after I switch my TV off and on again. (Where ‘off’ is the remote controls off-button, so the TV is in standby)

  • Rebooting Kodi (from bottom line confluence menu) temporarily works around this issue (unitl next time switching the TV off/on).
  • I have a “Ligawo HDMI extractor” attached. Removing the extractor works around the problem, but then I have no Toslink optical sound connection to my expensive sound system.
  • Replacing the Raspberry 2 B by a Raspberry 1 B+, running Kodi Feb 2 2015 on Raspian 3.12.31, while keeping the extractor installed, works around the issue
  • Replacing the Raspberry 2 B by a Raspberry 1 B+, running last Kodi/Raspbian version from around August(?), while keeping the extractor installed, worked around the issue (trashed my SDCard with this version, no reproducible here)
  • Replacing the Raspberry 2 B by a Raspberry 1 B, Rev 2 (this is older than B+), running same Kodi version 15.2, but on XBian 1.0, while keeping the extractor installed, works around the issue
  • fixing a /boot/edid.dat which was recorded without the HDMI extractor, did not fix the issue (after the extractor was installed again)
  • Replacing the extractor by manufacturer did not fix the issue
  • cross-replacing the extractor with one of the other Kodi boxes WAS NOT DONE YET (I thought I did, but then I found indications, that I replaced the one with itself - instead replaced it with the other)
  • cross-replacing the TVs (Samsung UE55 vs. LE37) did not moved the issue with the TV, it stays at the RPi2 OSMC box
  • replacing Raspi 2B hardware by another Raspi 2B did not fixed the issue (I have no recordings about which software and settings I used here, so I’ll repeat it soon. I guess I just replaced the board and put the old microSD into the new board)

What I was doing when this issue occurred

  1. using Kodi, after a fresh startup. Sound okay.
  2. switching the TV into standby “off” with remote control. Here it takes no matter, if I also first disconnect the Anynet/CEC session, or let it staying online.
  3. I am switching the TV into “on” again. Select external source CEC/Anynet “Kodi” -> NO SOUND from Kodi
  4. rebooting OSMC, SOUND OKAY

I you can replicate this issue on demand. I provide some steps on how an OSMC developer can reproduce the same issue
Use a Rasberry Pi2
Connect a HDMI digital audio extractor between TV and OSMC.
Just navigating the menues with having UI sounds activated is enough to check, if sound is working.
But you can try playing music or movie, to check the problem.

The device I am currently running OSMC on
Raspbeery Pi 2 B made in UK

That peripherals are attached to the device
Ligawo HDMI extractor (http://www.amazon.de/dp/B00CAQN0CM)
or
Delock 62492 HDMI Stereo / 5.1 Kanal Audio Extractor (http://www.amazon.de/dp/B00EV2WNKS)

And an official recommended 2000mA power supply

Has this issue been introduced by a new version of OSMC?
Not sure if a new version of OSMC or if the Raspi 2 port of OSMC. I had it with all versions of OSMC/Raspi 2 you issued since August, while I don’t have it with multiple Raspi 1 issues of Sams Kodi images.

When did the issue first appear and can you recall a time when it was not present?
1st appeared with the new Raspi2 hardware.

logfiles
http://paste.osmc.io/ihukojanix is from replicating this issue (here the sound is broken after TV comes on again)
http://paste.osmc.io/wulinotepa is with the repairing reboot, which makes sound working again

what I also did for replication / diagnostic
sudo /opt/vc/bin/tvservice -d temp.dump && /opt/vc/bin/edidparser temp.dump | grep -E '(best)|(preferred)|(support )|(name is)|(audio)|(sound)' && tvservice -s && tvservice -a

and got :
Enabling fuzzy format match... Parsing edid_after_suspend_removed_ligawosplitter.dat... HDMI:EDID version 1.3, 1 extensions, screen size 121x68 cm HDMI:EDID features - videodef 0x80 !standby !suspend !active off; colour encoding:RGB444|YCbCr422; sRGB is not default colourspace; preferred format is native; does not support GTF HDMI:EDID found monitor range descriptor tag 0xfd HDMI:EDID monitor range offsets: V min=0, V max=0, H min=0, H max=0 HDMI:EDID monitor range: vertical is 24-75 Hz, horizontal is 15-81 kHz, max pixel clock is 230 MHz HDMI:EDID monitor range does not support GTF HDMI:EDID found monitor name descriptor tag 0xfc HDMI:EDID monitor name is SAMSUNG HDMI:EDID found preferred CEA detail timing format: 1920x1080p @ 60 Hz (16) ... HDMI:EDID preferred mode remained as CEA (16) 1920x1080p @ 60 Hz with pixel clock 148 MHz HDMI:EDID has HDMI support and audio support edid_parser exited with code 0

the preferred mode is always CEA16, regardless if I nail it in config.txt or let it negotiate every time.

the only difference between with extractor and whithout extractor is:
HDMI:EDID HDMI VSDB deep colour support - 48-bit:no 36-bit:yes 30-bit:yes DC_yuv444:yes HDMI:EDID HDMI VSDB deep colour support - 48-bit:no 36-bit:yes 30-bit:no DC_yuv444:yes HDMI:EDID HDMI VSDB has physical address 4.0.0.0 HDMI:EDID HDMI VSDB has physical address 4.1.0.0

To make a long story short, I stronly guess there is somewhat with re-activating Raspi 2 HDMI after the HDMI sink came back from suspend.

What can I do to support hunting the bug?
I could install whatever you need on the Raspi 1 B, rev2 to have a very close-to-Raspi-2-system
I would install whatever you direct me to the Raspi 2, …

Best regards, and please do not keep me hanging on…
Laser Man

Additional test was done today:

with another Raspi 1 B rev2 (this is the last rev before B+) I used the HDMI audio extractor, but now I took OpenELEC 6.0 onto the SD, to see if the issue is RPi2 or OSMC related only. OpenELEC is also using isengard 15.2 KODI.

Result:
same problem here. So the RPi 2 is not part of the problem, nor is it an “only OSMC problem”.

I’m at the end with what can I test to isolate the root cause.
Please give me hints!

When you tried this,

a) Did you also use hdmi_force_hotplug=1 and not just hdmi_edid_file=1 ?

http://kodi.wiki/view/Raspberry_Pi_FAQ#TV_is_not_detected_unless_powered_on_first

hdmi_force_hotplug will make the Pi unaware of any changes to the HDMI link status - it will completely ignore whether the link goes up or down, and ignore any edid changes.

b) Did you try capturing an edid.dat when going through your “HDMI extractor” while the sound is working ? (Eg capture it before turning the TV off and on)

It’s hard to see how this problem is not the fault of the HDMI extractor - if it works for you in certain configurations you listed that is probably more by luck than by design…

Hi DBMandrake,

Yes, this is my current try since a week:
initial_turbo=0
force_turbo=0
hdmi_force_hotplug=1
hdmi_drive=2
hdmi_ignore_cec_init=1
hdmi_edid_file=1

Yes, I did captures for a high number of setup and states, in case a helpful buddy will ask for it :wink:

But how can I upload it to paste.osmc.io from my desktop PC? Or is there a way to up it also from within the OSMC menu?

Yes, I completely understand this point of view. On the other hand, the guys at Ligawo Supplier “DeluxeCable” have been very helpful and also did a lot of checks and investigations. They swear, the device and its PSU is running perfect under all situations. Anyway, I after ranting again and again, I got another set in return of my first. It hast very different serial number, but still has the problem with KODI 15.2 and Raspi 1/2 if the distribution is OSMC or openELEC. But does not have the problem, if using KODI 15.2 and the distribution is XBian. since XBian is … a bit of grumble, grumble … thing I don’t like, I’d like to continue with OSMC.

I have the Raspi1-B-rev2 from my co-worker for some days, thus I’ll do some more cross-checks. Just direct me towards the right way, please :wink:

BR,
Laser Man

Just finished another Test:

with the above used Raspi 1 B rev2 (from my co-worker) I used the same “problematic” HDMI audio extractor, but now I took OSMC 2015.07-1 and then updated to OSMC 2015.10-1 onto the SD, to see if the issue is OSMC related only.
With both OSM versions, I repeated the on-off-on sequence and sound check 3 times.

I used all default settings (except before 1st time booting the freshly written SD-Card, I forced it to use HDMI in config.txt to prevent using legacy Video). So I was able to see the setup wizzard (or what’s the name).

Result:
NO PROBLEM. OSMC RPi(1) don’t show the problem, and the HDMI extractor is not broken or otherwise crappy.

Next steps here:
will use the 1st RPi2 once again with same “clean setup”, reporting what came out

Please stay tuned and tell me, how I can upload edid.dat to paste.osmc.io from my desktop PC?

BR,
Laser Man

edid.dat is a binary file - you won’t be able to upload that to paste.osmc.io - it’s only for text files.

You should be able to attach a small file to a forum post however, otherwise use something like dropbox.

A while ago, and the outcome was still the same: no sound.

Because I don’t remembered the details anymore, I’ll repeat the test next few days with now a 1 year later OSMC (2016/11 instead 2015/10).
Today, I had to replace the SD Cards of my above named Pi1 system with recent OSMC (2016/11) and since then, my DTS now also remains silent at the Pi1 SPDIF connection. :frowning:

Pls. stay tuned.

I am not quite sure, if the following is essential the fix, but after replacing a cable and after upgrading OSMC to Nov/2016, the problem is away.

regarding the cable, please read:
need-help-with-dts-on-optical-spdif-hdmi-splitter