[Solved] How to delete DNS entries

After you have manually specified any DNS addresses in MyOSMC there seems to be no way to ‘delete’ them. Typing doesn’t work. Can it be done from a command line?

Well what do you want to do without a DNS server?
If you want it automatically assigned need to switch back to DHCP

I knew someone would ask why :wink:

My internet connection is on mobile broadband on the Pi USB which connman doesn’t recognise. It binds any DNS IPs it knows about to my wired home network (eth0) which has a static IP. Then when I manually connect wwan0 (broadband router which is a DHCP and DNS) the routing table is a mess and other machines on the home network can’t find the internet. Just thought it would be cleaner if I could get it to forget those DNS entries.

Unless you know how to get connman to find a wwan0 interface. It’s not listed in technologies.

Thanks for the quick reply, though.

I’ve read your last post a few times and the configuration is still unclear to me.

1 You have a wired connection on eth0 with a static IP address on your “wired home network”. What does eth0 connect to? A home router, possibly with its own WAN interface?

2 You have a “mobile broadband” router connected on a USB port that acts as a DHCP server and DNS resolver. So does your Pi have two IP addresses when you run ifconfig or do you only see eth0 and lo (and possibly wlan0)? BTW is the mobile broadband router on of those USB dongles?

I’ve had mixed success getting 3G and 4G modems to run on routers, though never had a reason to try on a Pi. For me it was very much a hit and miss affair, with things like Huawei HiLink causing real problems (though great when hooked up to a Windows laptop). Documentation for these devices is generally somewhere between poor and non-existent. Russian-language forums can sometimes provide answers but it’s not easy for non-Russian speakers, as I’m sure you can imagine.

1 Like


The only connection to the outside world is a mobile broadband router (Huawei E5372). It’s plugged into the Pi and is a DHCP on That has to be set up ‘manually’. The Pi is wired to a wireless access point which connects all other machines in the house on network. They get to the internet through the Pi with some ip route and iptables lines in a start-up script on the Pi. It should have been more elegant to use connman’s tether function but as I said connman doesn’t recognise the wwan interface.

It all works (took some time!) so I don’t need any help with that. I was just trying to get rid of a couple of lines in my start-up script:

#! /bin/bash

# set up Huawei router on usb
if ! lsusb | grep "Modem/Networkcard"; then
        # change mode to router
        usb_modeswitch -v 12d1 -p 14fe -J

# look for the router
if lsusb | grep "12d1:1506"; then
        ip link set wwan0 up
        dhclient wwan0
        echo 1 > /proc/sys/net/ipv4/ip_forward
        iptables -t nat -A POSTROUTING -o wwan0 -j MASQUERADE
        # in case these have been created by connman
        ip route delete
        ip route delete
        ip route change default via dev wwan0

I like the sound of “it works”.

12d1:1506 It’s a Huawei!

Yeah, connman…

Answer: the config files are in /var/lib/connman and you can just delete the line in the settings file for the connection which starts nameservers.