[Solved] I'd like to see the OSMC can support chinese language in future

the Raspbmc support chinese language very well,
now the Raspbmc is upgrade to OSMC,
but it looks like that the OSMC alpha 4 can’t support chinese language.

Where does it not support Chinese ?

Language selection in Kodi ? (should be there already in Settings->Appearance->International)

Language selection in a console login session ?

Keyboard layout in Kodi and/or in a console login session ?

As none of the developers speak or write Chinese you will need to explain to us exactly what Chinese language features are missing.

sorry
it’s my fault
must set [Font] as “Arial based” in Appearance->Skin ,before select language.

Thanks for reporting that.

It could be a bug that the font needs to be manually selected. After selecting these is Chinese supported correctly ?

You can replace the font in /usr/share/kodi/addons/skin.osmc/16x9/Font.xml

remember to put your fonts in /usr/share/kodi/addons/skin.osmc/fonts/, these default fonts don’t support CJK characters.

Check this link: http://mzyy94.com/blog/2015/02/16/raspberry-pi2-osmc-jp/

Well, I can’t change the font in GUI. It’s not selectable, but I can do that in the default Kodi theme.

chinese language supported very well.
other operating system (like xbian) also need to manually selected the Font before change language.

thanks for reply
this problem has been solved.

I’m sorry, but how is this solved? Chinese language support works in Confluence skin by changing font to Unicode Arial in skin settings, but this is not possible in OSMC skin. I’m not asking for a Chinese UI, I just want to be able to see Chinese characters from files and addons.

It would be great if this could be implemented considering the initial screen after first boot where one can select a language. Currently it’s pointless when the selected language is not supported by the default OSMC font.

You have to manually substitute them with CJK fonts (like Source Han Sans).

In both Confluence skin and OSMC skin, the UI can be changed by below steps,
step1: set [Font] as “Arial based” in Appearance->Skin
step2: set [language] as “chinese” in Appearance->International

What kind of files do you mean? currently it support to display Chinese subtitles.
For addons, if Chinese characters are coded in it’s xml file, then the Chinese characters can be displayed.

Take below “addon.xml” file as an example.

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<addon id="repository.hdpfans.xbmc-addons-chinese" name="HDPfans中文插件库" version="1.1.3" provider-name="HDPfans">
	<extension point="xbmc.addon.repository" name="HDPfans Add-on Repository">
		<info compressed="false">http://xbmc.hdpfans.com/addons.xml</info>
		<checksum>http://xbmc.hdpfans.com/addons.xml.md5</checksum>
		<datadir zip="true">http://xbmc.hdpfans.com/zips</datadir>
	</extension>
	<extension point="xbmc.addon.metadata">
		<summary>Install Add-ons from HDPfans repository</summary>
		<summary lang="zh">从HDPfans脚本库安装XBMC扩展功能</summary>
		<description>Download and install add-ons for HDPfans addon repository.If you are interested in XBMC plugins, please join us: www.hdpfans.com.</description>
		<description lang="zh">从HDPfans插件库下载安装XBMC扩展功能模块。如果您对xmbc插件开发感兴趣请加入我们:www.hdpfans.com。</description>
		<disclaimer>All media is collected from Internet.</disclaimer>
		<disclaimer lang="zh">您所看到的所有内容均来自互联网聚合</disclaimer>
		<platform>all</platform>
	</extension>
</addon>

Well, the option to change the font is greyed out in OSMC RC skin, see attached picture. By files I mean any metadata that are in Chinese from song and video files.

I can see that the OSMC skin has all the labels available in Chinese, but the default font is not able to display them.

Have you looked at my screenshot? The option to change the font to “Arial based” is not available.

Sorry for late
I saw the screenshot,it’s probably a bug of the system.
I have been using the Confluence skin.didn’t notice that the fonts can not be change in the OSMC skin.

I am having the same issue. I just installed OSMC yesterday using the RC2 image. Can’t change font in the default skin.

Having the same issue as sunny above. Can’t change the default OSMC skin font to “Arial based”.

Works for the Confluence skin, but I want to use the default OSMC skin.

Not being able to change the font is a known issue on the current OSMC skin. This is being worked on and will be fixed when an updated design is released.

Is there a work around to change font for osmc skin. maybe via command line?

Not really. At the moment you would need to use a different skin.

+1 for fixing this bug :thumbsup: