[Solved] July update wiped out Live TV

After updating, my TVHeadend PVR client was disabled (previous to the update it was enabled). Always takes me a bit to find it, but i found it and enabled it. However, LiveTV doesn’t show up on the main menu. So i rebooted, still no LiveTV. I use the “LiveTV” button on the remote and a window pops up that says “PVR manager is starting up. No PVR clients have started yet. …”. TVHeadend PVR server is showing as installed.

  • Can i “restart” the server from the web interface?
  • Do i need to reinstall (uninstall/install) TVHeadend PVR server from the app store?
  • Is there a way i can archive my setup just in case it gets wiped out during the install?
  • would log files help debug this issue? If so, which one?


EDIT - also wiped out my FTP server, but it too shows “installed”
EDIT, EDIT - scratch the FTP server thing… “which ftp” doesn’t show anything even though the server is there

Logs please



EDIT - well, i tar’d my tvheadend directory for back up and unistalled then installed TVHeadend server. Still no LiveTV. :cry: On a positive note, this is the second time i’ve uninstalled then installed TVHeadend server and the configuration is remembered each time.

It is a feature to preserve the configuration.

I think you may be confused. The TVHeadend server is not the same thing as the TVHeadend PVR client


That may very well be true. Nonetheless, I’ve enabled the client (it was disabled after update if I recall correctly) and I’ve uninstalled and then subsequently installed the server from the app store and I still don’t have LiveTV option on the OSMC main menu.

EDIT - As I understand it (which may be incorrect), the server is what you install from the app store and log in to from a browser at osmc:9981 (if I recall the port correctly). That’s where I had to spend HOURS manually adding muxes, setting up EPG and channel icons. That’s the “configuration” I was attempting to back up and the same configuration that persisted after an uninstall/install.

@sam_nazarko , did you have a look at the log file?

EDIT - I enabled debugging then rebooted. I also hit the “LiveTV” button on my MCE remote (which envokes the “tuner” linux button press) and i got the message about no PVR clients have started (bla bla bla). But, i don’t see that button press in the log file. But i DO see some warnings regarding JSON and PVR stuff. The log file is at http://paste.osmc.io/utoluhozox . Also, just FYI, i did install the JSON perl package in order for my zap2xml.pl script to work correctly (i verified it still works).

Sounds as if you do not have the front end enabled via Kodi. Possible due to the upgrade.

I’ll try to be more clear and accurate… the TVHeadend HTSP Client is ENABLED in the kodi settings that I have access to through the OSMC menus using my IR remote. I previously and erroneously called the client the “TVHeadend PVR Client”. Sorry if this caused any confusion.-

EDIT - your post did cause me to question the client more than I had. After googling, I found the following Tvheadenend 3.4 and Kodi 15 beta 2 - Tvheadend . Perhaps there is an issue with the compatibility of the client with the Isengard build of Kodi. In fact, per the Isengard Kodi wiki page ( http://kodi.wiki/view/Kodi_v15_(Isengard)_changelog ), there were a LOT of changes pertaining to LiveTV and PVR functionality/interface.

One more thing… what does it mean to “uninstall” an Add-on??? I have the option to enable/disable, configure as well as uninstall. I haven’t used that option because I’m unsure of how I would subsequently install the add-on (I know how to install apps from the app store, but I’ve never installed an Add-on). This is probably a good point for me to learn a little more about the differences between “apps” and “add-ons”.

So should I try to “uninstall” the TVHeadend HTSP Client?

Per the change log
Removed internal Tvheadend (HTSP) VFS client code in favour of its external PVR Client Addons

Enable/disable installed and able to use
Unistall not on your system

So what does this mean? Do I need to enable a different add-on? Do we need the OSMC dev team to make a new app available in the app-store?

Also, after an uninstall of an add-on, how do I subsequently install that add-on back? (although this doesn’t sound like it will fix my issue)

I would head over to the kodi forums.
Since I do t use pvr I can’t give any clear guidance on this situation.

thanks for that pointer. Unfortunately the suggestion is to “uninstall” the pvr.htp addon and install the pvr.tvh addon: “To make it possible for users of the official addon to update to this newer version, the addon name has been kept as “pvr.hts”. This means those that are currently using the “pvr.tvh” addon will have to uninstall it and install the official version instead, then reconfigure the addon.”

So, I will try to use the uninstall option and hope that the addon will still show up in the list and I can subsequently install it… and hope that will fix my issue :slight_smile:

Well CRAP! Exactly what i thought would happen, happened… I uninstalled the TVHeadend HTSP Client and the Add-on disappeared from the list of Add-ons. Now i need to get it back. Any suggestions?

sudo apt-get install --reinstall rbp2-mediacenter-osmc
sudo reboot

May be rbp1, depends if you are on pi1 or pi2


Didn’t work :frowning:

Ok, here’s what i did:
osmc@osmc:~$ sudo apt-get install rbp2-mediacenter-osmc
Reading package lists… Done
Building dependency tree
Reading state information… Done
rbp2-mediacenter-osmc is already the newest version.
rbp2-mediacenter-osmc set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
osmc@osmc:~$ reboot
osmc@osmc:~$ Connection to osmc closed by remote host.
Connection to osmc closed.

After this, i used the remote to navigate to Add-ons and sure enough, TVHeadend HTSP Client is in the list, but, it’s enabled. Don’t know how that happened. And still no LiveTV.

You did not copy my command correctly. Note the use of --reinstall


damn! thought that was a comment. trying again now

well, that did something different but it didn’t change the behavior… still, when i enable the client, nothing happens, no LiveTV option

I’m not sure what to say. The addon is enabled, have you configured it? That should be it really… The only other thing I can suggest is deleting your .kodi directory and starting fresh or trying another skin in case the one you are using does not support it properly.